Probleme mit Pythong / https / Produkten

  • Hallo,


    ich versuche mein altes Webprojekt (war auf einem debian 6 Rechner) auf einen debian 7 Rechner zu übertragen.
    Die Plone version ist 3.3.5. Auf eine höhere Version migrieren ist nach vielen Versuchen gescheitert. Dennoch, zumindest den Umzug möchte ich hinbekommen.
    Soweit klappt alles ganz gut. Seite steht.
    Leider hapert es noch an der Installation der Produkte. Als Beispiel "PloneFormGen".
    Ich habe dieses Produkt in meine buildout.cfg eingetragen.


    Wenn ich bin/buildout durchführe erhalte ich folgende Fehlermeldung:


    Wenn ich das richtig sehe ist also Python nicht mit ssl installiert worden(?). Zumindest entnehme ich das so mehr oder minder dieser Seite:
    http://developer.plone.org/tro…or-unknown-url-type-https


    Ich habe nun auch das folgende Paket installiert:


    sudo apt-get install libssl-dev


    Aber leider funktioniert das ganze immernoch nicht. Wenn ich die configure Option aus obigem Link ausprobiere erhalte ich:


    Ok... ich bin mir nun nicht sicher OB das Problem wirklich an der falschen Python version liegt. Falls ja bin ich mir nicht sicher OB ich überhaupt python 2.4.6 gegen 2.7 austauschen kann? Habe gelesen, dass das zumindest unter ubunute zu großen Problemen führen kann.
    Und grundsätzlich dachte ich, dass Python 2.4. automatisch von Plone installiert wird? Kann es sein, dass die Version auf neueren Debian versionen einfach nicht mehr läuft?
    Das wäre ja ungünstig. In dem Fall MÜSSTE ich ja fast schon auf debian 6 umsteigen oder nicht?


    Also bin für jede Hilfe dankbar. Im Endeffekt möchte ich nur, dass meine Produkete ordentlich installiert werden was im Moment noch nicht der Fall ist.

  • Hallo,

    nein Du kannst nicht einfach mit Python2.7 arbeiten, dazu muss Plone vorher aktualisiert werden.
    Du brauchst also ein Python 2.4 was der Plone installer eigentlich mit bringt. Den Installer für Plone 3.3.5 kannst Du Dir von plone.org ziehen.
    Der installierst dann alles.
    Eine Migration sollte in der Regel auch möglich sein, wenn auch manchmal etwas nachgeholfen werden muss ;).


    Python2.4 habe ich glaube ich nur auf Squeese laufen, was bekommst Du denn für einen Fehler?