CSS funkt nicht mehr so recht ab Firefox 16

  • Hallo,
    seit Firefox V 16.x kommt das linke frame, bzw der Inhalt, nicht mehr zum Vorschein (http://patzmannsdorf.heimat.eu/index.htm) - nur mehr das image ganz oben. Unter IE, Chrome, Firefox 15 gehts. Das linke frame ist http://patzmannsdorf.heimat.eu/index-8.htm. Abgesehen davon, dass frames nicht mehr so zeitgemäß sind ... habe ich rausgefunden, dass diese eine Zeile wahrscheinlich das Problem verursacht -wenn ich die raus nehme, gehts glaub ich => die Ausgabe schaut nur schlecht aus:


    #divSlideCont {
    Z-INDEX: 10; LEFT: 0px; VISIBILITY: hidden; WIDTH: 170px; POSITION: absolute; TOP: 100px; HEIGHT: 300px
    }



    Das ganze CSS Zeugs:[INDENT]<STYLE type=text/css>
    DIV.clSlide {
    PADDING-RIGHT: 4px; PADDING-LEFT: 4px; Z-INDEX: 10; LEFT: 0px; PADDING-BOTTOM: 4px; WIDTH: 129px; CLIP: rect(0px 128px 22px 0px); PADDING-TOP: 4px; POSITION: absolute; HEIGHT: 22px
    }
    DIV.clSlideSub {
    PADDING-RIGHT: 4px; PADDING-LEFT: 4px; Z-INDEX: 10; LEFT: 0px; VISIBILITY: hidden; PADDING-BOTTOM: 4px; WIDTH: 128px; CLIP: rect(0px 128px 20px 0px); PADDING-TOP: 4px; POSITION: absolute; HEIGHT: 22px
    }
    DIV.clSlideSub2 {
    PADDING-RIGHT: 4px; PADDING-LEFT: 4px; Z-INDEX: 10; LEFT: 0px; VISIBILITY: hidden; PADDING-BOTTOM: 4px; WIDTH: 128px; CLIP: rect(0px 128px 20px 0px); PADDING-TOP: 4px; POSITION: absolute; HEIGHT: 22px
    }
    #divSlideCont {
    Z-INDEX: 10; LEFT: 0px; VISIBILITY: hidden; WIDTH: 170px; POSITION: absolute; TOP: 100px; HEIGHT: 300px
    }
    A.clSlideLinks {
    FONT-WEIGHT: bold; FONT-SIZE: 10px; COLOR: black; FONT-FAMILY: Verdana, Helvetica, Helv; TEXT-DECORATION: none
    }
    A.clSlideSubLinks {
    FONT-WEIGHT: bold; FONT-SIZE: 10px; COLOR: #515151; FONT-FAMILY: Verdana, Helvetica, Helv; TEXT-DECORATION: none
    }
    A.clSlideSub2Links {
    FONT-WEIGHT: bold; FONT-SIZE: 10px; COLOR: #737373; FONT-FAMILY: Verdana, Helvetica, Helv; TEXT-DECORATION: none
    }
    </STYLE>
    [/INDENT]


    Hat jemand eine Idee was da los ist, oder mit Firefox 16, 17, ... ?
    Danke für einen oder 2 Tips!

  • Natürlich!
    Ich hab die Seite vor Jahren gemacht und immer nur erweitert mit Menüeinträgen. Nun meckert der Firefox v16 - die anderen Browser verkraften anscheinend meinen Blödsinn ... ich hatte gehofft es wäre einfacher, denn es ist ja vermtulich "nur" eine Zeile, oder ein Argument ( ?? #divSlideCont ?? ) ...

  • patz, was hälste denn davon das mal neu zu machen? ich mein frames.. da blickt doch eh nur wer durch der einen am rappel hat :mrgreen:


    außerdem wäre es für dich ne schöne übung und die page bekäme nen facelift :)


    ps: ich wusste gar nicht, dass man mit css auch funken kann.... wie geht denn sowas?

  • ja, ich wurde überzeugt alles neu zu machen. Aber die Frames ... naja ... ob ich die weg lasse ... wir werden sehen. Ich hab immer nur gehört die sind heutzutage Quatsch, aber niemand konnte mir sagen, was daran wirklich so schlecht sei.
    Sieht so aus, also ob noch nicht die richtigen Leute hier vorbeigesehen hätten, die in diesem Fall den Firefox v16 genauer kennen und den Unterschied zu v15 wissen. Egal, aber funkendes CSS bleibt dabei ;-)

  • Ich hab immer nur gehört die sind heutzutage Quatsch, aber niemand konnte mir sagen, was daran wirklich so schlecht sei.


    Nichts einfacher als das: http://www.subotnik.net/html/frames.html


    Sieht so aus, also ob noch nicht die richtigen Leute hier vorbeigesehen hätten, die in diesem Fall den Firefox v16 genauer kennen und den Unterschied zu v15 wissen.


    Ist vom Prinzip her auch egal, denn wenn du sowieso alles neu machst, erledigt sich das Problem von alleine. ;)

    Einmal editiert, zuletzt von Bandit ()

  • Nunja, seit 13:00 ist sie verträglicher gemacht (problematische Menü im linken frame mußte ich schnell umbauen) und geht wieder. Also Danke für alle Ratschläge. over and out!