Problem mit Domainkonfiguration (O2), unerwünschte 301 Weiterleitung auf "de.de"

  • Hallo zusammen,

    ich bin neu hier und stell mich kurz vor, mein Name ist Klaus, ich bin hier für ein Integrationsunternehmen als Webmaster und Admin tätig. Meine aktuelle Aufgabe ist es, einen Lieferdienst (also Webshop) für die Bezirkskliniken MFR zu erstellen.

    Da habe ich nun ein Problem, bei dem ich nicht weiterkomme und bräuchte etwas Support von jemandem, der sich mit DNS-Konfiguration auskennt. Unsere Domain "www.lieferdienst-bka.de" liegt bei O2. Von unserem Provider habe ich eine IP-Adresse bekommen für das Verzeichnis in dem unser Shop liegt.

    Soweit so gut, diese IP habe ich im Domainverwaltungstool von O2 eingegeben. Das funktioniert auch, sofern unsere URL mit "www" aufgerufen wird. "www.lieferdienst-bka.de" führt also korrekt in unseren Shop.

    Ruft man die Domain jedoch ohne "www" auf (also "lieferdienst-bka.de") findet ein 301 redirect auf "http://www.lieferdienst-bka.de.de" statt. Also doppeltes ".de". An der htaccess liegt es nicht, die Weiterleitung erfolgt schon vorher.

    http://www.redirect-checker.org/index.php

    Weiß jemand Rat oder könnte mir bei der DNS-Konfiguration behilflich sein?

    Viele Grüße,
    Klaus

  • Habt ihr denn keine Admins, die den Webserver konfigurieren? Für mich sieht das nach nginx aus, da wird etwas falsch konfiguriert sein.

    nginx hat aber keine .htaccess, sondern irgendwelche config-Dateien, das müssten dann aber Deine Admins wissen.


    Sollte ich mich mit nginx täuschen und es läuft ein Apache Webserer stattdessen, gilt dennoch: Der Webserver ist fehlerhaft konfiguriert.

    Stichwort VirtualHosts, Deine Admins sollten damit was anfangen können.

  • Hi Arne,

    nein, das ganze liegt bei einem externen Hoster mit dessen Auswahl ich auch nicht glücklich bin. Aber gut, nun weiß ich, wo ich nachhaken muss.

    Vielen Dank und viele Grüße,
    Klaus