Responsive Webdesign - Hinweis für IE 5.5 - 8.0

  • Hallo Zusammen,


    ich habe meine Website im Responsive Design erstellt und mittels http://caniuse.com/css-mediaqueries die Kompatibilität mit verschiedenen Browsern "erfragt". Da unter dem Internet Explorer (Versionen 5.5 - 8.0) die Betrachtung meiner Website nur eingeschränkt (bis gar nicht) möglich ist, möchte ich einen Hinweis ausgeben, wenn ein User mit dem IE 5.5 - 8.0 meine Website besucht.


    Bei der Verwendung von Flash auf unterschiedlichen Website´s sieht man das immer "recht unschön" (Bitte Aktualisieren Sie ... blablabla).


    Mittels google Analytics habe ich bereits geprüft mit welchen Browsern meine Website bevorzugt besucht wird. Die Versionen IE 5.5 - 8.0 sind hier sehr selten, weshalb ich mich - wie erwähnt - für die Lösung des Hinweises entschieden habe. Kann mir jemand sagen, wie ich das nun am sinnvollsten umsetzen kann?


    Aufgabenstellung im Detail:


    - User mit IE 5.5 - 8.0 besucht meine Website
    - Hinweis "Um diese Website vollständig betrachten zu können ... aktualisieren Sie bitte Ihren Browser ...)


    Mittels JS, index.php ???


    Danke im Voraus, Manni

  • Dann hast du etwas falsch gemacht.


    Die Mediaqueries sollen von Browsern beachtet werden deren Viewport kleiner ist als der Durchschnitt der Desktopbrowser. Da der IE 8 und kleiner auf mobilen Geräten also mit kleineren Viewport gar nicht im Einsatz ist fällt das raus. Die Mediaqueries werden vom IE8 gar nicht beachtet und somit ignoriert, weshalb man ja die mediaqueries so bequem einsetzen kann.


    Alternativ kannst du auch mit conditional comments dem IE8 eine andere Css-Datei geben, was aber eigenlich gar nicht notwendig ist.


    Kleiner als IE8 ist eigentlich so gut wie niemand mehr unterwegs. Die kleinste zu berücksichtigende Version ist also der IE8 und der ist auch bald beerdigt.
    Siehe dazu http://www.browser-statistik.de/