Umlate im Plone Volltextindex

  • Hallo an alle


    zuerst mal ein kurzer Überblick. Ich bin relativ "jungfreulich" mit Plone und nutze es hier als Intranetlösung.


    Ich nutze folgende Version:


    • Plone 4.3.2 (4307)


    • CMF 2.2.7


    • Zope 2.13.21


    • Python 2.7.3 (default, Oct 15 2013, 16:16:39) [GCC 4.7.2]


    • PIL 1.7.8 (Pillow)


    Um Dokumente direkt im Browser ansehen zu können habe ich noch collective.documentviewer 2.2.1 installiert.


    Als Betriebssystem habe ich mich für Debian entschieden, da ich mit Debian die meister Erfahrungen habe.
    Soweit läuft auch alles. Der Doc Viewer konvertiert alles korrekt, ob .pdf, .doc, .xls, etc.
    Die von Docsplit abgestellten .txt files (welche vermutlich den Plone Volltextindex füttern) enthalten noch alle die korrekten Umlaute.
    Laut Plone wird der Volltext Index plone_lexicon mittels den Komponenten Splitter und I18nnormalizer gefüttert. Und hier geht vermutlich was schief.
    Denn so wie ich es sehe sollte doch der i18n die Umlaute mit ASCII Characters ersetzen und so aus ä ein ae machen und so weiter.
    Nun werden die Umlaute im Volltext Index einfach entfernt statt getauscht. So kann ich nicht nach "ähnliche Wörter" oder "aehnliche Woerter" suchen, sondern müsste "hnliche Wrter" eingeben um die gewünschten Suchergebnisse gezeigt zu bekommen.



    Hat hier jemand einen Tipp oder hatte schon ein ähnliches Problem?



    Danke im Vorraus



    LG limex

  • Hallo Limex,


    hast Du mal versucht, ohne den DocumentViewer eine PDF-Datei zu indizieren?
    Passiert das da auch oder tritt das nur im Zusammenhang mit dem DocumentViewer auf?
    Es könnte sein, dass beim indizieren der Text-Dateien die Infos zu der aktuellen Sprache nicht vorhanden sind.
    Denn Plone verwednet diese um die korrekten Normalisierungen zu erledigen.