Imageprocessing beim Gambio-Shop

  • Hallo Forum,


    kennt sich jemand mit Gambio-Shops aus ?


    ich habe 50 Bild-Dateien per FTP in den original_image Ordner geladen und dann im backend imageprocessing laufen lassen.


    Angezeigt wird dann: "50 von 50 Bildern verarbeitet" und der Button "Start" und der Button "Abbrechen", jedoch kein "Speichern" - Button.


    Bei erneutem imageprocessing habe ich wieder 50 von 50 Bildern.


    Was ist da defekt ?

  • Du kannst jetzt noch tausend mal auf "Start" klicken und du wirst tausend mal "50 von 50 Bildern verarbeitet" bekommen. Es werden immer aller Bilder im original_image-Ordner durchlaufen

  • heisst das, wenn ich jetzt noch 1000 Bilder in den original_image-Ordner lade, läuft mein image-processor 1050 mal.


    Und wenn ich dann nochmal 50 lade, 1100 mal ? Es kommen täglich neue Bilder hinzu. Wenn ich dann z.B. bei 30000 bin, läuft das image-processing 2 Tage lang ? Oder wie geht das ?

  • Wir können ja nur aufgrund deiner Angaben die Schlüsse daraus ziehen, demnach sieht es so aus. Die Software greift immer auf das gleiche Verzeichnis zu und bearbeitet dann alle Bilder. Kommen neue hinzu werden die alten mit verarbeitet.
    Warum fragst du das aber nicht den Hersteller, der hat das programmiert und der kennt auch die Lösung dazu, wir kennen die Software ja noch nicht einmal.

  • Was hindert dich daran, den original_image-Ordner nach dem Image-Processing zu leeren? Die Original-Bilder werden in dem Shop doch nicht gebraucht, oder?

  • Hallo,


    danke, das ist richtig. Die Bilder können gelöscht werden.


    Habe trotzdem folgende Fehlermeldung nach dem processing:
    in /www/htdocs/w010a3be/html/admin/includes/classes/image_manipulator_GD2.php:326
    Backtrace:
    #0 imagejpeg called at [/www/htdocs/w010a3be/html/admin/includes/classes/image_manipulator_GD2.php:326]
    #1 (#image_manipulation) create called at [/www/htdocs/w010a3be/html/admin/includes/product_info_images.php:62]
    #2 require called at [/www/htdocs/w010a3be/html/admin/includes/modules/export/image_processing.php:115]
    #3 (#image_processing) process2 called at [/www/htdocs/w010a3be/html/admin/gm_module_part_export.php:59]


    ================================================================================
    2013-09-9 10-25-26 (93.210.30.169)
    WARNING(2): imagejpeg(): Unable to open '/www/htdocs/w010a3be/html/images/product_images/popup_images/deko077.jpg' for writing: Permission denied
    in /www/htdocs/w010a3be/html/admin/includes/classes/image_manipulator_GD2.php:326
    Backtrace:
    #0 imagejpeg called at [/www/htdocs/w010a3be/html/admin/includes/classes/image_manipulator_GD2.php:326]
    #1 (#image_manipulation) create called at [/www/htdocs/w010a3be/html/admin/includes/product_popup_images.php:62]
    #2 require called at [/www/htdocs/w010a3be/html/admin/includes/modules/export/image_processing.php:114]
    #3 (#image_processing) process2 called at [/www/htdocs/w010a3be/html/admin/gm_module_part_export.php:59]


    ================================================================================
    2013-09-9 10-25-26 (93.210.30.169)
    WARNING(2): imagejpeg(): Unable to open '/www/htdocs/w010a3be/html/images/product_images/info_images/deko077.jpg' for writing: Permission denied
    in /www/htdocs/w010a3be/html/admin/includes/classes/image_manipulator_GD2.php:326
    Backtrace:
    #0 imagejpeg called at [/www/htdocs/w010a3be/html/admin/includes/classes/image_manipulator_GD2.php:326]
    #1 (#image_manipulation) create called at [/www/htdocs/w010a3be/html/admin/includes/product_info_images.php:62]
    #2 require called at [/www/htdocs/w010a3be/html/admin/includes/modules/export/image_processing.php:115]
    #3 (#image_processing) process2 called at [/www/htdocs/w010a3be/html/admin/gm_module_part_export.php:59]

    Mit der Bitte um Hilfe
    Hilf


    www.jewel-world.de

  • Hallo explanator,


    ich bin halt noch Anfänger, dem man noch alles vorkauen muss. Es ist ja noch kein Meister vom Himmel gefallen. Ich bin ja auch gerne bereit "Lehrgeld" zu zahlen.


    Übrigens ist das Gambio-Forum nicht mehr für normale Leute geöffnet, nur noch für Leute die erst mal 100,- Euro löhnen, ohne Garantie eine Antwort zu bekommen.

  • Es sollte hier allerdings reichen, wenn man die Fehlermeldung richtig lesen würde:

    Zitat

    WARNING(2): imagejpeg(): Unable to open '/www/htdocs/w010a3be/html/images/product_images/popup_images/deko077.jpg' for writing: Permission denied


    Damit sollte eigentlich alles klar sein.

  • Das hatte ich auch gelesen, hatte obiges deko077.jpg überall gelöscht, trotzdem kams immer wieder.


    Habe dann aus lauter Verzweiflung alle image-Verzeichnisse, Ordner und Dateien mit Schreibrechten 777 versehen (ca. 4 Std. Laufzeit) und siehe da, nun funktioniert es. :-D