Beiträge von PieAeitsch

    Hallo zusammen,


    eine kurze Frage hätte ich noch: Wieso werden bei der Ausgabe eines Inhalts jegliche style-Attribute aus Tags entfernt? Die HTML-Filter Einstellungen habe ich denke ich richtig gemacht: Unter Attribute taucht das Style-Attribut nicht in der Blacklist auf, unter Style habe ich die Stile, die ich benutzen möchte (wie z.B. border, width, height) ergänzt.
    Meine inline styles werden auch gespeichert! In Kupu ist die Änderung zu sehen, auch nach Speichern und späterem Wiederaufrufen der Seite im Bearbeitungs-Modus bleibt sie erhalten - lediglich in der Ausgabe ist style-Attribut verschwunden.


    Hab auch unter portal_transforms>safe-html geschaut, aber da geht's ja nur um die Tags und nicht um Attribute...


    Hat jemand noch eine Idee woran das liegen und wie man diese Filterung verhindern kann? Vielen Dank!!


    Viele Grüße
    PieAeitsch

    Hallo,


    vielleicht weiß hier jemand Rat? Mein Auftraggeber möchte am Ende jeder Seite einen Hinweis "Redaktionell verantwortlich: " gefolgt von einem Namen zu stehen haben. Für jede Seite soll sich dieser Name individuell festlegen lassen; der Name entspricht nicht immer dem Namen des angemeldeten Users.
    Dieses Feld soll sich im Footer-Bereich unterhalb des Dokumentes befinden, in meiner Umsetzung entspricht das dem Bereich, in welchem auch die Aktionen "Artikel empfehlen" und "Artikel drucken" zu finden sind, also abgetrennt vom Hauptinhalt.
    Hat jemand einen Vorschlag, ob überhaupt und wenn ja wie so etwas realisierbar ist? Ich habe lediglich Zugriff auf die Plone Site im ZMI, wenn nötig kann ich über den Serveradmin Produkte nachinstallieren lassen.


    Noch eine Frage: Ist es möglich zwei verschiedene Navigationspunkte auf das selbe Element verweisen zu lassen?


    Wäre für jeden Hinweis dankbar!


    Grüße
    PieAeitsch

    Hallo, auch hier danke für deine Antwort!


    Leider funktioniert .../search/@@manage-protlets oder .../sitemap/@@manage-protlets nicht (Suche sagt "0 Ergebnisse", bei Sitemap kommt die ganz normale Sitemap-Seite). Plone Version ist 3.1.7...


    Gibt's noch ne andere Lösung? Danke!


    Gruß PieAeitsch

    Hallo,


    noch eine kurze Frage:
    wie kann man es realisieren, dass die Seitenleisten (Hauptnavigation links, Kalender und andere Portlets rechts, etc.) auch auf Spezialseiten wie Suche oder Sitemap sichtbar sind (Plone 3) ??
    Standardmäßig scheinen die Portlet-Leisten ja bei diesen Seiten schlichtweg zu fehlen.


    Vielen Dank!


    Gruß
    PieAeitsch

    Hallo!


    Wenn man versucht, in einen Seiteninhalt ein YouTube Viedeo einzubinden (z.B. über die Einbetten-Funktion von kupu), wird dieses Video in Firefox nicht dargestellt, da auf der fertigen HTML Seite die type="..."-Attribute, sowie der <embed>-Tag fehlen !? Im HTML-Filter habe ich alles rausgenommen...


    Gibt es noch einen anderen Grund, weshalb die Elemente aus dem HTML-Code gefiltert werden könnten?


    Grüße
    PieAeitsch

    Hallo!


    Wie es aussieht, ist ja einiges tatsächlich nur noch über Zugriff auf das Dateisystem möglich.. Ich habe die Seite nun über Workarounds dennoch zum Großteil den Anforderungen gemäß umsetzen können..


    Danke für eure Hilfe!

    Hallo Forum,


    ich muss zum Anfang der nächsten Woche ein HTML+CSS Layout in eine Plone-Site einebaut haben und musste gerade feststellen, dass auf dem System Plone 3 installiert ist. Bislang hatte ich nur mit Plone Version 2.5.3 gearbeitet und was das Erstellen von Skins betrifft scheint sich ja hier einiges geändert zu haben.


    Ich habe schon rausgefunden, dass einige der Änderungen nun über das portal_view_customizations-Tool vorgenomen werden. Wie kann ich aber die Reihenfolge der Elemente im Header-Bereich verändern?? In der main_template steht dort nur ein Verweis "structure provider:plone.portaltop" aber die eigentliche Template für portaltop kann ich nirgendwo finden !?!? Konkret möchte ich das Suchfeld vom Header in den rechten Seitenbereich verschieben, sowie die Servicenavigation in den footer.. Das war doch alles so klar und einfach vorher, wieso ist das jetzt so kompliziert ??


    außerdem frage ich mich, wie ich die Hauptnavigation wieder in den linken Seitenbereich kriege. Die Property left_slots = (...)here/portlet_navigation/macros/portlet(...) scheints ja auch nicht mehr zu geben :-(


    Jeder kleine Hinweis oder Tipp wie man hier vorgeht würde mich sehr sehr freuen, tausend Dank schonmal!!
    Ach ja: ich habe leider keinen Zugriff auf das Dateisystem - nur auf das ZMI der Seite....


    EDIT: Ich habe mittlerweile die folgende Seite entdeckt: http://www.domain.de:8081/meineplonesite/@@manage-viewlets. Hier kann ich wenigstens innerhalb eines Segmentes die Reihenfolgen der Elemente verändern. Wie kann ich denn jetzt aber bestimmte Unterelemtente in andere Oberelemente verschieben ??



    Viele Grüße
    PieAeitsch

    Hallo zusammen,


    ich muss eine Plone-Seite aufbauen, dessen Navigationsstruktur aus 5 Hauptkategorien und diversen Unterseiten und -kategorien besteht. Die Startseite soll die erste Seite der ersten Unterkategorie sein. Eine separate Startseite ist nicht vorgesehen.
    Nun kann man ja als Startseite nur einen bestimmten Artikel aus dem Root-Verzeichnis auswählen, nicht aber aus einer tieferen Ebene. Gibt es dennoch einen Weg, das so zu realisieren?


    Die Plone-Version ist 2.5.3.


    Wäre für jeden Tip dankbar!


    Viele Grüße
    PieAeitsch

    Okay, ich habe es jetzt selber hingekriegt mit einem kleinen Script, mit dem sich zumindest die Einträge anhand des Titels aus der Navigation ausblenden lassen.
    Nachteil: Beim Umbennenen der Objekte muss auch das Script angepasst werden.


    Hier also eine kurze Anleitung für alle, denen das oben beschriebene "Feature" auch auf die Nerven geht:


    1. im Template-Ordner ein Script (Python) erstellen:
    Name: "NavigationEintraegeAusschliessen"
    parameter list: "titel"
    Code:



    2. Die plone_portlets/portlet_navtree_macro "customizen" und die folgende Codezeile suchen:

    Code
    1. tal:condition="python: bottomLevel &lt;= 0 or level &lt; bottomLevel-1"


    und ersetzen durch:

    Code
    1. tal:condition="python: (bottomLevel &lt;= 0 or level &lt; bottomLevel-1) and here.NavigationEintraegeAusschliessen(item.Title)"



    ... Sicherlich nicht die eleganteste Lösung, aber sie erfüllt ihren Zweck !


    Grüße ph

    Ja, ich dachte mir schon, dass das nicht einfach ist, aber ich glaub nicht, das meinem Kunden das so gefällt, wie es jetzt ist. Eventuell gibts ja nen Hack oder so?


    Es ist zum ersten mal, dass ich mich Plone/Zope arbeite, deswegen bin ich noch nicht ganz so fit, was die Integration zwischen Python und der Zope-Objektstruktur betrifft. Kann mir dafür vielleicht jemand sagen, wie ich in Python den Objektpfad der aktuell angezeigten Seite auslesen kann?
    Damit ließe sich ja eine Funktion erstellen, die prüft, ob sich das Element in den zu versteckenden Bereichen befindet und sich im Navigationsscript dann als condition einsetzen lässt.


    PS: Gibt es evtl. eine einfache Möglichkeit, Objekte von Plugins von Drittanbietern (im speziellen ploneboard und Plone Gazette) aus der Navigation auszublenden?


    Vielen Dank & Gruß
    ph