Beiträge von Schippo

    Hallo Gastl,


    ich werd die Verlinkung zu dem Artikel wohl besser vergessen. Der Betreiber scheint hiermit auch überfordert zu sein. Danke Dir auch ganz herzlich für die Unterstützung.


    Ich hab noch ein Problem mit einer veralteten Jquery-Version, die in einem meiner Foren einen Fehler auslöst. Leider kann man die weder einfach löschen, da sie vom Forum benötigt wird, noch kann man sie so einfach durch eine neuere Version ersetzen. Ich bin kein Profi, vielleicht kennt Ihr Euch ja hiermit besser aus. Mit der Jquery-Option noConflict kann man zwar die alte und neue Version von Jquery nutzen, aber so firm bin ich dann doch nicht. Möchte nicht noch mehr Fehler produzieren. Falls ich hier alleine in den nächsten Tagen nicht weiterkomme, würde ich mich nochmals melden, aber dann über einen neuen Thread.


    Viele Grüße von Schippo

    Doch... genau da landet der Link... zwar etwas höher (bei dem Bild, wo auch sich auch die ID befindet)

    Genau da wollte ich eigentlich auch hin, zu dem Bild. Du hast Recht, das verschiebt sich alles nur durch das Nachladen. So'n Mist aber auch, ich denke, da kommen wir wohl momentan nicht weiter. Ich versuch's mal beim Admin der Seite. Nochmals vielen Dank. Sollte Dir doch noch etwas einfallen - ich schau später noch mal vorbei.


    Hab noch einen schönen Tag und grüßli

    Hallo Sailor,


    ganz herzlichen Dank für Deine Mühe. Du hast mir schon mal ganz doll auf die Sprünge geholfen, denn so hatte ich die ID nicht platziert. Ich hatte hier wohl viel zu umständlich gedacht. Das Chaos mit der Seite war mir auch aufgefallen. Aber die Sprungmarke funktioniert, landet nur leider nicht auf den Anfang des Artikels. So wahllos in der Mitte ist das nix.


    Mal schaun, ob der Betreiber hier etwas machen kann, falls der mich überhaupt versteht.


    Schönen Tag noch und Grüße von Schippo

    Sorry, Ihr Beiden, daß ich mich erst heute wieder melden kann, aber ich hatte Bereitschaft auf Abruf und mußte weg. Danke für Eure Tipps, aber ich komme hier nicht weiter.

    Du brauchst doch von der 'Fremdseite' nur den Quellcode ansehen (in deinem Browser). Im Code suchst du dann an der Stelle, an die du verlinken willst, nach einer passenden ID - diese ID in deinen Link eintragen und es sollte funktionieren.

    Das hab ich gemacht, es gibt hier auch eine ID, aber auch die führt mich nicht zum Ziel. Bei meiner eigenen Webseite funktioniert das mit ID alles einwandfrei, bei dieser Fremdseite scheint der Wurm drin zu sein. Vielleicht auch vom Betreiber so gewollt. Ich hab gelesen, daß es auch Fälle gibt, wo eine solche Verlinkung erhebliche Probleme bereiten kann. Wenn Euch hier nicht noch etwas einfällt, werde ich wohl das Handtuch werfen. Vielleicht könnt Ihr Euch das ja mal anschaun. Nachstehend die URL. Der Artikel, auf den verlinkt werden soll, ist der Letzte auf der Seite, ab dem letzten Bild.


    Nachruf Johnny,


    Beim Auswahl-Quelltext gibt es keine ID, im Seitenquelltext habe ich eine gefunden (bis fast nach unten scrollen)

    Code
    1. id="cc-m-textwithimage-6611227086"

    Danke Euch vielmals für Eure Unterstützung.


    Gruß von Schippo

    Hab ich doch geschrieben, daß ich auch den letzten Slash am Ende weggelassen habe. Hat nichts gebracht und auf alles andere habe ich doch keinen Einfluß, ist doch eine Fremdseite. Oder steh ich jetzt hier auf'm Schlauch?


    Danke erst mal und Gruß

    Hallo Sailor,


    so sah mein erster Versuch aus - funktionierte leider nicht. Alles andere waren dann mehr oder weniger nur Verzweiflungsaktionen. Ich vermute, daß die Ursache dafür ist, daß die url der Fremdseite nicht auf ".html" endet. Sie endet so, wie oben von mir eingegeben. die url schaut in etwa so aus

    Code
    1. https://www.xxxx.de/yyyy/blablabla/tralala2014/

    und hieran hab ich dann den #Anfang Abschnitt gesetzt, also so:

    Code
    1. <a href="https://www.xxxx.de/yyyy/blablabla/tralala2014/#AnfangAbschnitt">gehe zu</a>

    Das funktionierte nicht und ich kann beim besten Willen keinen Fehler erkennen. Hab das letzte Slash weggelassen, ganz prägnante Textmarkierung gesucht, Einzelwort, mehrere Wörter, getrennt, zusammengeschrieben, nichts geht. Ich schau noch mal bei Wikipedia nach, aber das hab ich gestern auch schon getan. Vielleicht habe ich hier etwas überlesen.


    Hab erst einmal vielen Dank und Gruß von Schippo

    Hallo @all,


    bin am Verzweifeln und benötige ganz dringend Hilfe. Es will mir einfach nicht gelingen, auf eine verlinkte fremde Webseite eine Sprungmarke zu einem ganz bestimmten Abschnitt zu setzen. Bei Verlinkungen zu eigenen HTML-Seiten hab ich das problemlos hinbekommen. Die zahlreichen Tipps aus dem Netz waren leider nicht von Erfolg gekrönt.


    Hier einer meiner zahlreichen Versuche:


    Code
    1. <a href="https://www.xxxx2014/" "#Anfang des Abschnitts">gehe zu</a>

    Sicher gibt es hier jemanden, der mir auf die Sprünge helfen kann und ich bedanke mich schon mal ganz herzlich.


    Viele Grüße von Schippo

    Hallo Surenamba,


    also ich starte die Seite im Browser. Habe das Forum mit fertigem Template und allen Funktionen vor 2 Monaten gemietet. Dann nur noch entsprechend angepaßt und bin nun dabei, es mit Inhalten zu füllen.


    Bin zwischenzeitlich zwar ein ganzes Stück weitergekommen, aber der Wurm ist immer noch irgendwo drin. Bin halt ein Newbie. Ich habe das jetzt einem Profi übergeben, denn gerade das Speichern ist doch recht kompliziert und überfordert mich total. Hier muß sehr viel berücksichtigt werden. Was passiert, wenn mehrere Nutzer gleichzeitig auf dieselbe Position wollen, wie oft darf der Nutzer die Position ändern, Zugriffe von Admin müssen uneingeschränkt sein, usw. usf. Alles Dinge, die man im Vorfeld gar nicht berücksichtigt.


    Trotzdem vielen Dank, daß Du verschiedene Denkanstöße gegeben hast.


    Viele Grüße


    Schippo


    - - - Aktualisiert - - -


    Hallo WebHolz,


    hab's gerade gesehen - habe die Anweisungen im Bodybereich gar nicht mitgesendet. Zwischenzeitlich sieht das Script etwas anders aus, denn ich bin hier ein ganzes Stück weitergekommen. Aber nicht weit genug, deshalb habe ich es jetzt einem Profi übergeben, der die Sache zu Ende bringt. Mit dem Speichern war ich überfordert, alles andere funktionierte recht gut bis auf onmouseover - onmouseout. Aber das wäre das kleinste Übel gewesen.


    Wie sagt man so schön: "Schuster bleib bei Deinen Leisten." Jetzt kümmere ich mich wieder um das, was ich kann - nämlich Häuser bauen. Aber genau genommen ist ja eine Website auch ein Haus - nur ein Virtuelles eben.


    Danke für Dein Interesse und die Hinweise.


    Viele Grüße


    Schippo

    Hallo Surenamba,


    vielen Dank für Deine Tipps.


    Zu 1) Genau, es muß global auf meinem Server gespeichert werden, so daß für jeden Besucher immer der aktuelle Stand ersichtlich ist. Aber jetzt wird noch nicht mal lokal gespeichert. Sobald ich die Seite schließe, ist alles weg.


    Zu 2) Ich denke, daß man es mit containment id gelöst bekommt. Aber wie ich das umsetzen soll, da bin ich momentan überfragt. Hab schon jede Menge gelesen und gegoogelt, aber wirklich weitergebracht hat es mich nicht.


    Ich denke, hier gibt es bestimmt einige fähige Köpfe, aber offensichtlich sind die auch damit überfordert. Wie soll ich als Newbie das dann schaffen?


    Vielleicht hilft es ja, wenn jemand meine Testseite anschaut http://dogs24.xobor.de/page-645566-5.html


    Der html-code sieht so aus


    <div id="verschieben"><img src="http://www.4-wände.de/hpfixseparat_blumenkerze.gif"></div>


    Und hier die Seite, auf der das Ganze später umgesetzt werden soll http://dogs24.xobor.de/page-645566-4.html


    Vielen Dank für Deine Hilfe und Grüße aus dem Tal der Ahnungslosen


    Schippo

    Hallo @all,


    mein Hundeforum steht noch so ziemlich am Anfang, aber vielleicht könnt Ihr ja doch schon eine erste Einschätzung geben. Hier wird noch viel gebastelt, habe aber bereits von anderen gehört, daß es gut ankommt, aber vielleicht wollten die mir auch nur nicht wehtun.


    http://dogs24.xobor.de


    Es gibt auch eine eigene Domain "dogs24.eu", die Weiterleitung ist jedoch noch nicht eingerichtet. Eine Option wäre auch, mit der Domain umzuziehen.


    Danke Euch für jedes Feedback.


    Gruß Schippo

    Hallo @All,


    ich benötige dringend Hilfe bei den vielen Optionen mit "Draggable". Bin noch ein absoluter Newbie und mit der Umsetzung total überfordert. Hätte mir mein Vorhaben nicht so schwierig vorgestellt Ich möchte auf meiner Website ein Hilfsprojekt für mißhandelte Tiere erstellen. Eine Solidaraktion soll das Bilden einer Lichterkette werden. Hierzu befindet sich bereits eine animierte Kerze (Mutterobjekt) an einer fest positionierten Stelle der Seite. Von dieser Kerze werden jetzt beliebig viele Duplikate erzeugt und per Drag+Drop zu einer Lichterkette formiert. Die Mutterkerze bleibt dabei immer an ihrem Platz. Das habe ich soweit auch schon hinbekommen und mein Script im Head-Bereich schaut so aus:


    <script src="http://code.jquery.com/ui/1.11.4/jquery-ui.js"></script>
    <script>
    (function() {
    'use strict';

    $(document).ready(function()
    {
    $("#verschieben").draggable({
    helper: "clone",
    cursor: "move",
    opacity: 0.7,
    scroll: false
    });

    $("#verschieben").bind('dragstop', function(event, ui) { $(this).after($(ui.helper).clone().draggable());});
    });
    })();
    </script>


    Was mir nun große Schwierigkeiten bereitet sind die Koordinaten.


    1. Das globale Speichern der gebildeten Kette. Die Kerzen lassen sich zwar jetzt x-beliebig aneinanderreihen, aber bei Verlassen der Seite und erneutem Aufruf ist die Lichterkette nicht mehr vorhanden, sondern nur noch die Mutterkerze. Es soll eine Solidaraktion werden - Die Besucher sehen Videos von mißhandelten Tieren, können hierzu einen Kommentar abgeben und als Solidaraktion eine Kerze anzünden und damit eine Lichterkette bilden. Es soll nur eine Lichterkette gebildet werden, also eine Gemeinschaftskette, jeder soll sich daran beteiligen können, indem er eine Kerze nimmt und an die Kette reiht, wenn er möchte auch immer wieder. Das Ergebnis soll immer wieder gespeichert werden und die Besucher sollen so die Kette wachsen sehen. Ich hoffe, daß ich es verständlich ausdrücken konnte.


    Der 2. Punkt wäre das Verschieben über einen bestimmten Bereich der Seite hinaus. Jetzt kann man die Kerzen überall positionieren, selbst außerhalb der Seite. Die Seite ist jedoch gerahmt (eine Art Container). Auch innerhalb der Seite sollte schon ein definierter Bereich xy festgelegt werden, über den hinaus nichts positioniert werden kann, denn hierauf befinden sich u. a. eine Kommentarfunktion, Video usw. die natürlich nicht überlagert werden dürfen.


    Mein Problem ist, daß ich hierüber kaum etwas Brauchbares im Internet in deutsch finden kann. Da es sehr kompliziert zu sein scheint, reichen meine Englischkettnisse nicht aus, um das Ganze auch noch zu verstehen, besonders die Zeichensetzung. Übersetzungen sind der reinste Kauderwelsch und selbst bei jQuery ist alles nur auf englisch und ohne Übersetzungsfunktion.


    Kann mir jemand bei der Umsetzung behilflich sein? Ich wäre Euch sehr dankbar. Es ist mein erstes Projekt.


    Viele Grüße
    Schippo