htaccess rewriterule funktioniert, ändert sich aber nicht

  • Hallo zusammen,



    zuerst einmal geht es nicht (direkt) darum das die Umleitung nicht funktioniert.



    Ich habe auf der Seite http://www.mastazone.de im Menü den Punkt "Link1" mit Untermenüpunkten "Link1.1 und "Link1.2".



    Der Link im Menü wird angesteuert mit:


    HTML
    1. <a href="link1.1/" title="Link1.1">Link1.1</a>




    Der eigentliche Aufruf des Links dahinter lautet:

    HTML
    1. ?ausw=link1.1




    Nun leite ich per htaccess die Seite auf einen fiktiven Ordner um.
    (Diesen Codeschinpsel habe ich nach etlichen Versuchen nun stehen lassen)



    Code:


    Code
    1. RewriteEngine On
    2. RewriteBase /
    3. Options +FollowSymlinks
    4. RewriteRule ^link1\.1/$ ?ausw=link1.1
    5. RewriteRule ^link1\.2/$ ?ausw=link1.2 [L]




    Hiermit wird nun beim Aufruf des Links "href="link1.1/" auf die Zeile "?ausw=link1.1" weitergeleitet.



    Soweit so gut. Wenn ich nun z.B. auf den Untermenüpunkt "Link1.1" klicke wird im Hauptteil der Seite (wie gewollt) Der Text "Link1.1" ausgegeben und in Der Adresszeile steht "http://www.mastazone.de/link1.1/". Passt.
    Wenn ich nun allerdings den Link "Link1.2" anklicke, zeigt es in der Statuszeile bereits an, dass dieser nun auf "http://www.mastazone.de/link1.1/link1.2/" verweist.
    Dort kommt dann logischerweise die Meldung "Not Found", da dort natürlich nichts hin verweist.



    Da ich nun schon wirklich lange herumteste und auf keine Lösung kam, nun meine Frage.
    Wie bekomme ich es hin, dass nachdem ich den Menüpunkt "Link1.1" angeklickt habe, der Verweis auf diese Seite wieder zurückgesetzt wird und ich ganz normal auf den Menüpunkt "Link1.2" klicken kann und dieser mit selbigem Text auch geöffnet wird?



    Im Voraus vielen Dank



    Grüße Denis