ul,li Menu bei IE9 kompletter schrott!

  • Mein Problem liegt darin dass ich mit Firefox, Safari und Google Chrome diese Homepage und auch das ul, li Menü optimiert habe.. unter IE 9 findet sich dann dieses Problem (Bilder sagen mehr als Worte)


    IE 9:
    http://img4.fotos-hochladen.ne…reenshot065a6z78vufj1.jpg


    Firefox, Chrome, Safari:
    http://www.fotos-hochladen.net…reenshot0667noi13kd4v.jpg


    Hier mein CSS:


    HTML an dieser Stelle:

    Code
    1. <div id="menu">
    2. <ul>
    3. <li><a href="index.html"><strong>Startseite</strong></a></li>
    4. <li><a href="programm.html"><strong>Programm</strong></a></li>
    5. <li><a href="karten.html"><strong>Karten</strong></a></li>
    6. <li class="current_page_item"><a href="#"><strong>Sponsoren</strong></a></li>
    7. </ul>
    8. </div>
  • Standardkonformer Doctype wie: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">?
    Habe ich nun hinzugefügt - selbes Problem...

  • Standardkonformer Doctype wie: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">?
    Habe ich nun hinzugefügt - selbes Problem...


    - - - Aktualisiert - - -


    Standardkonformer Doctype wie: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">?
    Habe ich nun hinzugefügt - selbes Problem...


    - - - Aktualisiert - - -


    Standardkonformer Doctype wie: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">?
    Habe ich nun hinzugefügt - selbes Problem...


    - - - Aktualisiert - - -


    Standardkonformer Doctype wie: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">?
    Habe ich nun hinzugefügt - selbes Problem...


    - - - Aktualisiert - - -


    Standardkonformer Doctype wie: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">?
    Habe ich nun hinzugefügt - selbes Problem...


    - - - Aktualisiert - - -


    Standardkonformer Doctype wie: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">?
    Habe ich nun hinzugefügt - selbes Problem...


    - - - Aktualisiert - - -


    Sry für doppelpost aber Editieren geht ja nicht :)


    Hattest recht


    XML
    1. <?xml version="1.0" ?>
    2. <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    3. "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">


    war die Lösung ;)