Ergebnis 1 bis 4 von 4

Thema: .htaccess Passwortabfrage will nicht funktionieren

  1. #1
    Gast

    Standard .htaccess Passwortabfrage will nicht funktionieren

    Hi leute vieleicht kann kann mir von euch jemand auf die Sprünge helfen
    Ich habe folgendes Problem.

    Auf meiner HP möchte ich den zugriff auf eine Seite Passwort schützen.
    (Downloadbereich)
    http://daahn.dyndns.org/index.htm oder direkt
    http://daahn.dyndns.org/download/Download.htm

    Als Server läuft Apache/2.0.54 (Win32) PHP/4.4.0
    (Windows XP Prof)
    Server funktioniert da ein PHP Forum auf diesem Server einwandfrei funktioniert und ich den Server durch ein im Web erreichbaren servercheck überprüft habe http://aktuell.de.selfhtml.org/sonst/serverid.htm

    http://daahn.dyndns.org/phpmyforum/

    Installationsdaten:
    Apache unter E:\server\Apache\Apache2
    PHP unter C:\server\php
    und MySQL unter C:\mysql
    Während die eigendliche Website unter E:\web\ zu finden ist.
    Das zu schützenden Verzeichnis E:\web\download\
    (darin enthalten natürlich auch die Seite Download.htm)
    Die Webseiten wurden mit Frontpage 2003 erstellt.

    Um den passwortschutz zu generieren habe ich eine
    .htaccess.txt und eine .passwd.txt erstellt und ins downloadverzeichnis
    E:\web\download\ kopiert

    Die .htaccess.txt habe ich selbst erstellt wie auch durch ein im Web erreichbaren Generator erstellen lassen.

    .htaccess.txt Inhalt:

    AuthUserFile e:/web/download/.htpasswd
    AuthName "Download"
    AuthType Basic
    require valid-user

    die .passwd.txt sieht so aus
    daahn:XXXXXXXXXXXXXXXXXXXXXX

    Ausserdem habe ich in der httpd.conf des Apache alle

    AllowOverride None in 'AllowOverride All umgewandelt und danach den Apache Restartet.

    Leider funktioniert der Passwortschutz aber nicht und ich kann ohne Abfrage sofort auf die Seite.

    Frage wo liegt mein Fehler und wie ist er zu beseitigen ????

    MfG Daahn
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Gast

    Standard

    So das mit der Abfrage habe ich hinbekommen einfach die .haccess.txt in eine .haccess umwandeln und schon funktioniert die abfrage doch leider habe ich nun das problem das der server meine passwörter nicht anerkennt (wenn ich Namen und Passwörter) eingebe und auf OK klicke passiert nichts ausser das Eingabefelder gelöscht werden.

    was ist da Los ?

  3. #3
    Gast

    Standard

    OK da ich meine eigen nachricht nicht löschen kann also so

    Hat alles geklappt nach 1h rumexperimtieren hat es nun geklappt.
    Alles funktioniert so wie ich es will.

    MfG Daahn

  4. #4
    Gast

    Standard

    Es wäre manchmal hilfreich zu wissen, was du geändert hast, damit andere die das gleiche Problem haben, auch hinbekommen!

Ähnliche Themen

  1. Buttons funktionieren nicht :(
    Von hirkammett im Forum HTML & CSS Forum
    Antworten: 3
    Letzter Beitrag: 13.02.2008, 17:24
  2. Browser funktionieren nicht
    Von Dose im Forum Computer - Internet Forum
    Antworten: 17
    Letzter Beitrag: 16.03.2007, 16:23
  3. .htaccess wird nicht zu .htaccess EXPERTEN BITTE MELDEN!
    Von SHADOW im Forum HTML & CSS Forum
    Antworten: 2
    Letzter Beitrag: 08.02.2007, 13:36
  4. TBK Animationen funktionieren nicht!
    Von thorstenf01 im Forum Forum für Grafiken und Bildbearbeitung
    Antworten: 1
    Letzter Beitrag: 13.12.2004, 15:15
  5. CD Laufwerke funktionieren nicht
    Von Andi56 im Forum Computer - Internet Forum
    Antworten: 1
    Letzter Beitrag: 07.10.2004, 12:35

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •