Ergebnis 1 bis 6 von 6

Thema: Problem mit CSS-Navbar und IFrame

  1. #1
    HTML Newbie
    Registriert seit
    01.06.2005
    Beiträge
    3
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard Problem mit CSS-Navbar und IFrame

    Hallo,

    ich habe ein kleines Problemchen. Und zwar möchte ich das Ziel folgender Links aus meiner CSS-Navbar in einen Iframe angeben.

    Code:
    <table border="0" height="240px" width="159px" cellspacing="0" cellpadding="0">
    			  <div align="left">
                  <tr>
                    <td width="100%" onMouseover="LmOver&#40;this, '#C0DCC0'&#41;" onMouseout="LmOut&#40;this, '#8AA07C'&#41;" onMouseDown="LmDown&#40;this, '#C0DCC0'&#41;" onMouseUp="LmUp&#40;'start.htm'&#41;" bgcolor="#8AA07C">
    				<div align="left">HOME</div></td>
    	            </tr>
                  <tr>
                    <td width="100%" onMouseover="LmOver&#40;this, '#C0DCC0'&#41;" onMouseout="LmOut&#40;this, '#8AA07C'&#41;" onMouseDown="LmDown&#40;this, '#C0DCC0'&#41;" onMouseUp="LmUp&#40;'news.htm'&#41;" bgcolor="#8AA07C">
    				<div align="left">NEWS</div></td>
    	            </tr>
                  <tr>
                    <td width="100%" onMouseover="LmOver&#40;this, '#C0DCC0'&#41;" onMouseout="LmOut&#40;this, '#8AA07C'&#41;" onMouseDown="LmDown&#40;this, '#C0DCC0'&#41;" onMouseUp="LmUp&#40;'history.htm'&#41;" bgcolor="#8AA07C">
    				<div align="left">HISTORY</div></td>
    	            </tr>
                  <tr>
                    <td width="100%" onMouseover="LmOver&#40;this, '#C0DCC0'&#41;" onMouseout="LmOut&#40;this, '#8AA07C'&#41;" onMouseDown="LmDown&#40;this, '#C0DCC0'&#41;" onMouseUp="LmUp&#40;'downloads.htm'&#41;" bgcolor="#8AA07C">
    				<div align="left">DOWNLOADS</div></td>
    	            </tr>
                  <tr>
                    <td width="100%" onMouseover="LmOver&#40;this, '#C0DCC0'&#41;" onMouseout="LmOut&#40;this, '#8AA07C'&#41;" onMouseDown="LmDown&#40;this, '#C0DCC0'&#41;" onMouseUp="LmUp&#40;'gallery.htm'&#41;" bgcolor="#8AA07C">
    				<div align="left">GALLERY</div></td>
    	            </tr>
    Dazu kommt noch das Javascript, sodass die Navbar auch funktioniert!

    Code:
    <script language = "javascript">
    <!--
    function LmOver&#40;elem, clr&#41;
    &#123;elem.style.backgroundColor = clr;
    elem.children.tags&#40;'A'&#41;&#91;0&#93;.style.color = "#8B2828";
    elem.style.cursor = 'hand'&#125;
    
    function LmOut&#40;elem, clr&#41;
    &#123;elem.style.backgroundColor = clr;
    elem.children.tags&#40;'A'&#41;&#91;0&#93;.style.color = "#C0DCC0";&#125;
    
    function LmDown&#40;elem, clr&#41;
    &#123;elem.style.backgroundColor = clr;
    elem.children.tags&#40;'A'&#41;&#91;0&#93;.style.color = "#8B2828";&#125;
    
    function LmUp&#40;path&#41;
    &#123;location.href = path;&#125;
    //-->
    </script>
    So, da ich aber auf meiner Seite einen Iframe habe, wo die Links angezeigt werden sollen, besteht nun das Problem darin, dass die Links nicht in dem besagten Iframe angezeigt werden, wenn ich das Ziel des Links auf Mainframe (<iframe name="mainframe"></iframe>), also deklariere.

    Nun meine Frage: Kann mir jemand sagen, wie ich das hinkriege?
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!
    Der Sinn des Lebens ist, dem Leben einen Sinn zu geben!

  2. #2
    Forum Guru
    Registriert seit
    14.06.2004
    Ort
    Schleswig-Holstein
    Beiträge
    5.439
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Moin!

    Vermulich verwendest du eine redirect-URL, dann kann der Begriff "mainframe" bereits vom redirect-Server verwendet sein.

    Gib deinem Iframe mal einen anderen, individuellen Namen und versuche es dann.

    Zum Thema Javascript sage ich besser nix - oder nur so viel: eine gute HP funktioniert auch ohne Javascript.

    G.a.d.M.

    Ronald

  3. #3
    HTML Newbie
    Themenstarter

    Registriert seit
    01.06.2005
    Beiträge
    3
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Also ich hab das jetz mal <iframe name="start"> und <a target="start"> versucht aber das geht ach net.

    Vieleicht muss ich ja noch ne Funktion mit in den Script-Tag einbinden. Nur das ich hab keine Ahnung wie man ne Funktion schreibt.
    Der Sinn des Lebens ist, dem Leben einen Sinn zu geben!

  4. #4
    Forum Guru
    Registriert seit
    14.06.2004
    Ort
    Schleswig-Holstein
    Beiträge
    5.439
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Versuche es mal mit einem Tag im Headbereich:
    Code:
    <base target="start"></base>
    das I-Frame muß dann natürlich auch "start" heißen, wobei ich den Begriff auch für gefährlich halte, da er doppelt vorkommen kann.

    Ich würde das Frame "hubimain" oder so ähnlich nennen.

    G.a.d.M.

    Ronald

  5. #5
    HTML Newbie
    Themenstarter

    Registriert seit
    01.06.2005
    Beiträge
    3
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Leider funktioniert das auch nicht.
    Der Sinn des Lebens ist, dem Leben einen Sinn zu geben!

  6. #6
    Forum Guru
    Registriert seit
    14.06.2004
    Ort
    Schleswig-Holstein
    Beiträge
    5.439
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Poste doch bitte mal den kompleten Quelltext (oder schick ihn mir zu)

Ähnliche Themen

  1. IFrame Problem
    Von Kathi285 im Forum HTML & CSS Forum
    Antworten: 6
    Letzter Beitrag: 30.05.2008, 17:36
  2. Portal Link im Template navbar nicht auffindbar...?
    Von Alienx im Forum Webanwendungen - Webapplikationen
    Antworten: 0
    Letzter Beitrag: 03.10.2007, 15:56
  3. Iframe Problem
    Von 00eraser00 im Forum HTML & CSS Forum
    Antworten: 12
    Letzter Beitrag: 23.08.2007, 13:58
  4. iframe problem
    Von gerd im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 2
    Letzter Beitrag: 10.02.2007, 08:23
  5. Problem mit XML und navbar
    Von Bixas im Forum HTML & CSS Forum
    Antworten: 3
    Letzter Beitrag: 13.10.2003, 19:48

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •