Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: CSS Problem treibt mich in den Wahnsinn

  1. #1
    HTML Newbie
    Registriert seit
    25.08.2003
    Beiträge
    5
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard CSS Problem treibt mich in den Wahnsinn

    Ich wäre jeder Hilfe sehr dankbar.

    Folgendes Problem liegt vor:
    Ich programmiere meine Navigationssleisten immer mit Cascading Style Sheets, doch dieses mal folgendes: nach der Porgrammierung her, müsste ein Link, wenn man mit der Maus über ihn fährt (a:hover), rot werden. Genaus so, wenn er Aktiv ist (a:active). Doch leider passiert nichts der gleichen. Der Link bleibt schwarz. Es tritt also keine Farbänderung ein, wie eigentlich angegeben im CSS. Andererseits werden die Links fett bzw. kursiv, wenn man über sie fährt oder drauf klickt.

    Wenn jemand irgend nen Vorschlag hat, wär super.
    Und wenn es der Fall sein sollte, dass bei euch der "Fehler" oder was das ist, nicht vorliegt, bitte ich auch darum, mir das mitzuteilen.

    Code:
    CSS CODE:
    a:link {
    	font-family: Tahoma, Arial;
    	color: #000000;
    	text-decoration: none;
    	font-size: 12px;
    
    }
    a:hover {
    	font-family: Tahoma, Arial;
    	font-size: 12px;
    	color: #FF0000;
    	text-decoration: none;
    
    
    
    }
    a:active {
    	font-family: Tahoma, Arial;
    	font-size: 12px;
    	font-style: oblique;
    	color: #FF0000;
    	text-decoration: none;
    }
    a:visited {
    	font-family: Tahoma, Arial;
    	font-size: 12px;
    	text-decoration: none;
    	color: #000000;
    }
    
    
    CODE NAVIGATIONSLEISTE:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
    <html>
    <head>
    <title>Untitled Document</title>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    <link href="page.css" rel="stylesheet" type="text/css">
    </head>
    
    <body bgcolor="B2CFDE">
    <table width="80%" border="0" cellspacing="10" cellpadding="0">
      <tr> 
        <td bgcolor="#000000"><table width="100%" border="0" align="center" cellpadding="0" cellspacing="1">
            <tr> 
              <td bgcolor="#3399cc"><div align="center">Startseite</div></td>
            </tr>
          </table></td>
      </tr>
      <tr> 
        <td bgcolor="#000000"><table width="100%" border="0" cellspacing="1" cellpadding="0">
            <tr> 
              <td bgcolor="#3399CC"><div align="center">Dienstleistungen</div></td>
            </tr>
          </table></td>
      </tr>
      <tr> 
        <td><table width="100%" border="0" cellpadding="0" cellspacing="1" bgcolor="000000">
            <tr> 
              <td bgcolor="#3399CC"><div align="center">Kunden</div></td>
            </tr>
          </table></td>
      </tr>
      <tr> 
        <td bgcolor="#000000"><table width="100%" border="0" cellpadding="0" cellspacing="1">
            <tr> 
              <td bgcolor="#3399cc"><div align="center">eCommerce</div></td>
            </tr>
          </table></td>
      </tr>
      <tr> 
        <td bgcolor="#000000"><table width="100%" border="0" cellpadding="0" cellspacing="1">
            <tr> 
              <td bgcolor="#3399CC"><div align="center">Partner</div></td>
            </tr>
          </table></td>
      </tr>
      <tr> 
        <td bgcolor="#000000"><table width="100%" border="0" cellspacing="1" cellpadding="0">
            <tr> 
              <td bgcolor="3399cc"><div align="center">Taxi-Journal</div></td>
            </tr>
          </table></td>
      </tr>
      <tr> 
        <td bgcolor="#000000"><table width="100%" border="0" cellspacing="1" cellpadding="0">
            <tr> 
              <td bgcolor="3399cc"><div align="center">Links</div></td>
            </tr>
          </table></td>
      </tr>
      <tr> 
        <td bgcolor="#000000"><table width="100%" border="0" cellspacing="1" cellpadding="0">
            <tr> 
              <td bgcolor="3399cc"><div align="center">Impressum</div></td>
            </tr>
          </table></td>
      </tr>
    </table>
    </body>
    </html>
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Meister(in) Avatar von Mitch
    Registriert seit
    23.03.2003
    Ort
    Siglingen - Germany
    Alter
    40
    Beiträge
    314
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Und wenn es der Fall sein sollte, dass bei euch der "Fehler" oder was das ist, nicht vorliegt, bitte ich auch darum, mir das mitzuteilen.
    Taj, so leid es mir tut, bei mir tritt der Fehler nicht auf. Alles i.o.

  3. #3
    HTML Newbie
    Themenstarter

    Registriert seit
    25.08.2003
    Beiträge
    5
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Mmh, ich glaub ich hab vergessen zu erwähnen, dass die Links bei mir auch rot werden, wenn man mit der Maus rübergeht, doch sobald man sie einmal angeklickt hat, sind und bleiben sie schwarz. Da liegt das Problem.

    Aber ich werds nochmal versuchen, und Ordnung reinbringen.
    Diese Internetseite hat jetzt nämlich 5 Ordner auf meinem Rechner, und ich hab so ein bisschen das Gefühl, als hätt ich mir da jetzt aus jedem Ordner ne Datei rausgesucht, und dann sone Ordnerübergreifende Seite gebaut, was der PC wohl gar nicht mag.

    ^^EDIT: hat nichts gebracht mit der Ordnung.

    Gemerkt hab ich das übrigens, als ich eben die Seite online stellen wollte =).

  4. #4
    Administrator Avatar von admin
    Registriert seit
    16.01.2003
    Ort
    Karlsruhe
    Beiträge
    12.779
    Danke
    1
    Bekam 4 mal "Danke" in 2 Postings
    Blog-Einträge
    42

    Standard

    Da haste ein paar Fehler drin.
    Der Link ist schwarz und beim darüberfahren wird er Rot.
    beim Anklicken wird er kursiv und bleibt dann schwarz.
    Die Forenregeln und Nutzungsbedingungen sind auch zum lesen da !!!


  5. #5
    Administrator Avatar von admin
    Registriert seit
    16.01.2003
    Ort
    Karlsruhe
    Beiträge
    12.779
    Danke
    1
    Bekam 4 mal "Danke" in 2 Postings
    Blog-Einträge
    42

    Standard

    Nachtrag:
    So sollte es aussehen und auch gehen

    Code:
    <style type="text/css">
    <!--
    a&#58;active &#123;  color&#58; #FF0000; text-decoration&#58; none; font-size&#58; 12px; font-family&#58; Arial, Helvetica, sans-serif&#125;
    a&#58;hover &#123;  color&#58; #FF0000; text-decoration&#58; none; font-size&#58; 12px; font-family&#58; Arial, Helvetica, sans-serif&#125;
    a&#58;link &#123;  color&#58; #000000; text-decoration&#58; none; font-size&#58; 12px; font-family&#58; Arial, Helvetica, sans-serif&#125;
    a&#58;visited &#123;  color&#58; #FF0000; text-decoration&#58; none; font-size&#58; 12px; font-family&#58; Arial, Helvetica, sans-serif&#125;
    -->
    </style>
    Die Forenregeln und Nutzungsbedingungen sind auch zum lesen da !!!


  6. #6
    HTML Newbie
    Themenstarter

    Registriert seit
    25.08.2003
    Beiträge
    5
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Tschuldigung, das hört sich jetzt sicher doof an, aber wo ist da der Unterschied zu meinem CSS?

    Die Schriftart ist anders, aber daran wird es wohl nicht liegen.
    Und du hast es in <style type="text/css"> [...] gesetzt, was ich aber eigentlich nicht brauchen sollte, weil ich die CSS in einer seperaten Datei speicher.

    Übrigens wurden diese CSS mit Dreamweaver erstellt.
    Probleme hatte ich bisher so noch nie.

  7. #7
    Administrator Avatar von admin
    Registriert seit
    16.01.2003
    Ort
    Karlsruhe
    Beiträge
    12.779
    Danke
    1
    Bekam 4 mal "Danke" in 2 Postings
    Blog-Einträge
    42

    Standard

    Die Schrägschrift kommt von der Zeile
    Code:
    font-style&#58; oblique;
    (aktiv)
    Die Schrift spielt keine Rolle, aber die von Dir als erstes gewählte Schriftart ist keine Standartschriftart.Ich selbst habe sie nicht auf meinem Rechner.

    Ja, habe es mit dem DW gemacht
    Kann zwar auch selbst CSS schreiben, aber mit dem DW gehts viel schneller.
    Die Forenregeln und Nutzungsbedingungen sind auch zum lesen da !!!


  8. #8
    HTML Newbie
    Themenstarter

    Registriert seit
    25.08.2003
    Beiträge
    5
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Übrigens meinte ich, dass ich die CSS mit Dreamweaver gemacht habe... aber egal...

    Ich weiß jetzt immer noch nicht, wo der Fehler ist.

    Die Schriftart hab ich geändert, das änderte aber leider nicht das Ergebnis. Genauso hab ich oblique weggenommen, aber auch das half nichts.

  9. #9
    Administrator Avatar von admin
    Registriert seit
    16.01.2003
    Ort
    Karlsruhe
    Beiträge
    12.779
    Danke
    1
    Bekam 4 mal "Danke" in 2 Postings
    Blog-Einträge
    42

    Standard

    Nehme mal bei jedem zum schluß den ; weg, dann gehts.


    Code:
    a&#58;link &#123; 
       font-family&#58; Tahoma, Arial; 
       color&#58; #000000; 
       text-decoration&#58; none; 
       font-size&#58; 12px&#91;color=red&#93;; &#91;/color&#93;
    
    &#125; 
    a&#58;hover &#123; 
       font-family&#58; Tahoma, Arial; 
       font-size&#58; 12px; 
       color&#58; #FF0000; 
       text-decoration&#58; none&#91;color=red&#93;; &#91;/color&#93;
    
    
    
    &#125; 
    a&#58;active &#123; 
       font-family&#58; Tahoma, Arial; 
       font-size&#58; 12px; 
       color&#58; #FF0000; 
       text-decoration&#58; none&#91;color=red&#93;; &#91;/color&#93;
    &#125; 
    a&#58;visited &#123; 
       font-family&#58; Tahoma, Arial; 
       font-size&#58; 12px; 
       text-decoration&#58; none;
       color&#58; #000000&#91;color=red&#93;; &#91;/color&#93;&#125;
    Die Forenregeln und Nutzungsbedingungen sind auch zum lesen da !!!


  10. #10
    Administrator Avatar von admin
    Registriert seit
    16.01.2003
    Ort
    Karlsruhe
    Beiträge
    12.779
    Danke
    1
    Bekam 4 mal "Danke" in 2 Postings
    Blog-Einträge
    42

    Standard

    Nehme mal bei jedem zum schluß den ; weg, dann gehts.


    a:link {
    font-family: Tahoma, Arial;
    color: #000000;
    text-decoration: none;
    font-size: 12px;

    }
    a:hover {
    font-family: Tahoma, Arial;
    font-size: 12px;
    color: #FF0000;
    text-decoration: none;



    }
    a:active {
    font-family: Tahoma, Arial;
    font-size: 12px;
    color: #FF0000;
    text-decoration: none;
    }
    a:visited {
    font-family: Tahoma, Arial;
    font-size: 12px;
    text-decoration: none;
    color: #000000; }



    Danach sollte es so aussehen
    Code:
    a&#58;link &#123; 
       font-family&#58; Tahoma, Arial; 
       color&#58; #000000; 
       text-decoration&#58; none; 
       font-size&#58; 12px 
    
    &#125; 
    a&#58;hover &#123; 
       font-family&#58; Tahoma, Arial; 
       font-size&#58; 12px; 
       color&#58; #FF0000; 
       text-decoration&#58; none 
    
    
    
    &#125; 
    a&#58;active &#123; 
       font-family&#58; Tahoma, Arial; 
       font-size&#58; 12px; 
       color&#58; #FF0000; 
       text-decoration&#58; none 
    &#125; 
    a&#58;visited &#123; 
       font-family&#58; Tahoma, Arial; 
       font-size&#58; 12px; 
       text-decoration&#58; none; 
       color&#58; #FF0000
    &#125;
    Die Forenregeln und Nutzungsbedingungen sind auch zum lesen da !!!


Ähnliche Themen

  1. ...Password Protection - Mein persöhnlicher Wahnsinn, Hilfe!
    Von PC_Dude im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 4
    Letzter Beitrag: 02.05.2006, 23:34
  2. WAHNSINN!!!
    Von CHIEFmaster im Forum Das Forum für Spiele, Fun & Jokes
    Antworten: 6
    Letzter Beitrag: 11.01.2006, 15:27
  3. voll der wahnsinn
    Von topgreen im Forum Link Tipps
    Antworten: 1
    Letzter Beitrag: 17.09.2005, 00:42
  4. Für Profis sicherlich lächerlich für mich ein Problem
    Von Jonathan im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 4
    Letzter Beitrag: 19.04.2005, 20:51
  5. Die Telekom treibt mich in den Wahnsinn !
    Von admin im Forum Off Topic und Quasselbox
    Antworten: 29
    Letzter Beitrag: 20.05.2003, 23:59

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •