Ergebnis 1 bis 4 von 4

Thema: Ebenen gehen verloren bzw. werden gekickt

  1. #1
    NickRivers
    Gast

    Standard Ebenen gehen verloren bzw. werden gekickt

    Hallo
    bei mir hat sich ein kleines Problem ergeben.

    Folgendermaßen siehts aus:

    Mein Flash-Film besteht aus einem MAIN-Frame, von wo aus sich der findige Benutzer mit Hilfe von fünf verschiedenen Buttons zu den jeweiligen anderen Frames bewegen kann.
    Die Buttons heißen zB. WERK, ÜBER, FREUNDE etc..
    Ich habe den Film also so angelegt, dass jedes Frame einem Unterpunkt der Seite entspricht.
    Klickt der Benutzer zB. auf WERK springt der Film zu Frame 2.
    Bei einem Klick auf ÜBER auf Frame 3 usw.
    (Klickt er im Frame 2 wieder auf WERK bzw. im Frame 3 auf ÜBER springt der Film zurück auf Frame 1 das MAIN-Frame.)

    Gut.

    Das MAIN-Frame hat auf der ersten Ebene ein Grafik Symbol - hinter dem sich ein PNG-Bild verbirgt - als Hintergrund liegen.
    Darauf sind die fünf Buttons gelegt - jeder auf eine eigene Ebene.
    (Dazu kommen noch drei weitere Buttons die zur Soundsteuerung dienen)
    Alle Buttons die im MAIN-Frame liegen sollen und müssen, wie oben beschrieben auch in den anderen Frames vorhanden sein.
    Deshalb enthält jedes weitere Frame - wie zB. Frame 2 - alle Buttons plus das Hintergrundbild des MAIN-Frames - also, die komplette Bestückung des ersten Frames.

    Knackpunkt:

    In den Special-Frames (WERK, ÜBER...) kommen zumeist Grafiken (alle verwendeten Grafiken sind PNG mit Transparenten Bereichen) aber auch weitere Buttons oder Filme hinzu (die für sich alleine auch kein Problem mit Transparenz haben da auch aus PNGs aufgebaut).

    Also zB. bei WERK sieht die Zeitleiste so in der Art aus:

    ---------------------------------------------------------------------
    Ebene "Werk-Text" --> enthält ein Grafik-Symbol
    Ebene "Werk-Extra-Button" --> enthält ein Button-Symbol
    .
    -
    -
    Ordner MAIN --> enthält alle Ebenen des MAIN-Frames
    --------------------------------------------------------------------

    Und jetzt kommts:

    Ich veröffentliche den Flash-Film und spiele ihn mit dem Player ab.
    Drücke ich nun z.B. auf den WERK-Button schaltet der Film zwar zum WERK-Frame, jedoch scheinen die zusätzlichen Ebenen des WERK-Frames, Ebenen des MAIN-Ordners zu verdrängen.

    Und zwar verschwindet pro zusätzlicher Ebene (mit Grafik, Button oder Film) jeweils die unterste noch sichtbare Ebene. (Bei Ebenen mit Film verschwinden genau so viele Ebenen, wie der eingegliederte Film Ebenen besitzt)

    Also zuerst mein MAIN-Hintergrundbild(ich sehe dann alle Knöpfe des MAIN-Ordners auf dem Standard Weiß Hintergrund) und dann in der Reihenfolge der Ebenen die einzelnen Knöpfe.


    Jo, so siehts aus. Ist das ein bekanntes Problem? Mache ich etwas grundlegend falsch? Kann mir jemand helfen?

    Auf jeden Fall schonmal danke fürs lesen.


    PS:
    Hochladen könnte ich die Datei momentan höchstens auf meinen GMX Webspace. So oder so heißt das das ich eine E-Mail Adresse bräuchte um jemanden eine GMX-Ordnerfreigabe bzw. gleich die SWF Datei schicken zu können.

    Und... ja genau, um das ganze Problem nochmal kurz darzustellen.

    Ich lege z.B: zehn Ebenen übereinander (diese können jetzt Buttons oder einfach nur Bilder beinhalten - alle PNG-Format - im Prinzip sind das die einzelnen Ebenen des Bildes im Photoshop)

    Soweit, so gut.

    Lege ich jetzt noch eine weitere Ebene mit Inhalt obendrauf( und sei es auch ein komplett transparentes PNG) wird mir der Inhalt der untersten Ebene herausgekickt.
    (bzw. sie ist einfach nicht mehr sichtbar - dafür sehe ich die von mir in den Voreinstellungen eingestellte Standard Hintergrundfarbe für den Flash-Film)
    Lege ich noch eine Ebene obendrauf wird von unten her die nächste gekickt.


    Dabei wird die Anzeige des Flash-Filmes auch merklich langsamer/ruckeliger. Die noch sichtbaren Elemente funktionieren noch, nur sprechen sie langsamer auf Mausaktionen an.

    Nochmal Danke für die Hilfe.
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Gast

    Standard

    Hallo!

    Also du solltest mir das mal schicken(-> alex_[Klammeraffe]chello.at) weil es ist schon schwer sich dein Problem vorzustellen ohne es vor sich zu haben und etwas kompliziert erklärt ist es auch.

    mfg. Alex

  3. #3
    Gast

    Standard

    Den Film kannst du dir bei

    http://de.geocities.com/nickrivers666/mainfilm.swf

    anschauen.


    Der einzige Button der weiterführt ist WERK.
    Alles was bei WERK dazukommt habe ich momentan als eigenen Flash-Film integriert.
    Dieser Film läuft einfach ständig im Repeat durch sobald WERK gedrückt wurde.
    !Wie ich oben schon beschrieben habe wird der Film extrem langsam (zumindest bei mir und meinem PIII 600).
    Man sieht auf jeden Fall wie mehr Ebenen verschwinden, wenn neue Buttons hinzukommen.

    Und hier wäre die Flash(MX2004) Datei dazu:

    http://www.getfrenzy.net/Probe/NEW.fla

    Nun denn

    Vielen Dank auch

  4. #4
    Teeny
    Registriert seit
    28.03.2005
    Beiträge
    38
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Habe mir das jetzt angeschaut und muss sagen, dass ist wirklich extrem langsam.
    Habe mir auch gleich die fla gesaugt und werde sie mir mal anschauen.

    mfg. Alex

Ähnliche Themen

  1. Wie werden in Flash MX Ebenen dupliziert?
    Von toni-s im Forum Flash Forum
    Antworten: 2
    Letzter Beitrag: 12.11.2007, 21:47
  2. Die liebe verloren =(
    Von Explore im Forum Off Topic und Quasselbox
    Antworten: 8
    Letzter Beitrag: 29.05.2007, 23:18
  3. WinXP-Key verloren
    Von Sojo im Forum Computer - Internet Forum
    Antworten: 2
    Letzter Beitrag: 29.04.2007, 15:25
  4. Passwort verloren
    Von Miro81 im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 7
    Letzter Beitrag: 10.07.2006, 13:36
  5. Gedächtnis verloren
    Von emma im Forum Off Topic und Quasselbox
    Antworten: 0
    Letzter Beitrag: 25.04.2005, 21:39

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •