Ergebnis 1 bis 6 von 6

Thema: CSS wird nicht richtig erkannt

  1. #1
    Azubi(ne)
    Registriert seit
    07.04.2018
    Beiträge
    74
    Danke
    4
    Bekam 0 mal "Danke" in 0 Postings

    Standard CSS wird nicht richtig erkannt

    Moin!
    Ich habe das Problem, dass nur einige meiner CSS-Style-Optionen (keine Ahnung wie ich das nennen sollte xD) funktionieren.
    Um es für mich leichter zu machen, habe ich mir alles Dateien auf meinen Rechner gezogen und die an ausprobiert...
    So hat mir alles gefallen und es hat auch alles funktioniert!
    Jetzt habe ich meine Dateien hochgeladen und es fasst nix übernommen worden!

    Probleme:
    - die Seite "news" funktioniert nicht
    - meine Buttons werden entweder falsch angezeigt oder die Maus verändert sich nicht (also der Mauszeiger)
    - meine Navigation verrutscht immer noch, obwohl sie auf dem PC einwandfrei funktionierte!

    Meine idex.html
    HTML-Code:
    <!DOCKTYPE html><html lang="de">	<head>		<meta charset="utf-8">		<title>SimuUndQuex</title>		<link rel="stylesheet" type="text/css" href="stylesheet.css">		<link rel="shortcut icon" href="/Bilder/server-icon.ico" type="image/x-icon">	</head>	<body>	<link rel="stylesheet" type="txt/css" href="style.css">		<nav>			<ul>				<li><a href="index.html">Start</a></li>				<li><a href="news.html">News</a>				<li><a href="clans.html">Clans</a>				<li><a href="range.html">Ränge</a>				<li><a href="games.html">Games</a>			</ul>		</nav>				<div>			<div>			<h1>Herzlich Willkommen</h1>			</div>			<div id="Banner">			<img src="/Bilder/ts3banner_märz_2018_neu.png" alt="Das Bild konnte nicht geladen werden...">			</div>		</div>		<div>			<div id="willkommenstext">			<p>Hallo,			<br>Wir sind SimuUndQuex also Simuletsplay und minimiquex.			<br>Daher auch unser Name.			<br>Aktuell besitzen wir einen Teamspeak und einen Minecraft-Server.			<br>Wir hoffen, dass du viel Spaß auf allen unseren Servern hast!			<br>			<br>Mit freundlichen Grüßen			<br>SimuUndQuex-ServerTeam</p>			</div>            <div id="button">            <button type="button" id="tsbutton" onclick="location.href='ts3server://simuundquex.de'">Verbinde dich auf unseren Teamspeak</button>            </div>        </div>    </body></html>    
    Meine CSS datei:
    Code:
    body{
    	margin: 0;
    	padding: 0;
    	font-family: verdana;
    }
    nav
    {
    	width: 100%;
    	background: lightblue;
    }
    ul
    {
    	width: 80%;
    	margin: 0 auto;
    	padding: 0;
    }
    ul li
    {
    	list-style: none;
    	display: inline-block;
    }
    ul li :hover
    {
    	background: orange;
    }
    ul li a
    {
    	color: #fff;
    	text-decoration: none;
        display:block;
        padding:20px;
    }
    h1
    {
    	font-size: 50px;
    	color: grey;
    	text-align: center;	
    }
    #Banner
    {
    	display: flex;
    	align-items: center;
    	justify-content: center;
    	padding-bottom: 20px;
    }
    #willkommenstext
    {
    	display: flex;
    	align-items: center;
    	justify-content: center;
    	margin: auto;
    	margin-bottom: 20px;
    	border: #000000 1px solid;
    	width: 1024px;
    }
    #ranktext
    {
    	display: flex;
    	align-items: center;
    	justify-content: center;
    	margin: auto;
    	border: #000000 1px solid;
    	width: 1024px;
    }
    #lsbanner
    {
    	margin-top: 50px;
    	display: flex;
    	align-items: center;
    	justify-content: center;
    }
    #fortnitebanner
    {
    	margin-top: 8px;
    	display: flex;
    	align-items: center;
    	justify-content: center;
    }
    #mcbanner
    {
    	margin-top: 8px;
    	margin-bottom: 100px;
    	display: flex;
    	align-items: center;
    	justify-content: center;
    }
    #button
    {
    	display: flex;
    	align-items: center;
    	justify-content: center;
    }
    #createclan
    {
    	background-color: mediumseagreen;
    	border: none;
        color: white;
        padding: 15px 32px;
        text-align: center;
        text-decoration: none;
        font-size: 16px;
        cursor: pointer;
    }
    #createclan:hover
    {
        background-color: seagreen;
    }
    #tsbutton
    {
        background: #009933;
        border: none;
        color: white;
        padding: 15px 32px;
        text-align: center;
        text-decoration: none;
        font-size: 16px;
        cursor: pointer;
    }
    #tsbutton:hover 
    {
        background-color: #FF6600
    }
    
    
    #tsbutton:active 
    {
      background-color: #FF6600;
      box-shadow: 0 5px #666;
      transform: translateY(4px);
    }
    #gameslist
    {
        display: flex;
    	align-items: center;
    	justify-content: center;
    }
    #newsbutton
    {
        height: 250px;
        width: 500px;
        background: #FFFFFF;
        border: 2px solid grey;
        color: black;
        padding: 15px 32px;
        text-align: center;
        text-decoration: none;
        font-size: 16px;
        cursor: pointer;
        
    }
    #newsbutton:hover
    {
        background-color: #FFCC99;
    }
    #newsbutton:active
    {
      background-color: #FF6600;
      box-shadow: 0 5px #666;
      transform: translateY(4px);
    }
    #newsbuttondiv
    {
        display: flex;
    	align-items: center;
    	justify-content: center;
        margin-top: 50px;
    }
    Meine News-Datei (dort wird nix angezeigt)
    HTML-Code:
    <!doctype html><html>	<head>		<meta charset="utf-8">		<title>SimuUndQuex</title>		<link rel="stylesheet" href="stylesheet.css">		<link rel="shortcut icon" href="server-icon.ico" type="image/x-icon">	</head>	<body>		<nav>			<ul>				<li><a href="index.html">Start</a></li>				<li><a href="news.html">News</a>				<li><a href="clans.html">Clans</a>				<li><a href="range.html">Ränge</a>				<li><a href="games.html">Games</a>			</ul>		</nav>        <div>			<h1>News</h1>			</div>		<div>            <div id="newsbuttondiv"> 			            <a href="news/teamspeak-upgrade.html"><img src="news_tsupgrade.png" alt="Das Bild konnte nicht geladen werden..." /></a>            </div>		</div>	</body></html>

    Ich bitte um dringende Hilfe
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Meister(in)
    Registriert seit
    27.07.2015
    Ort
    Nordseeküste
    Beiträge
    300
    Danke
    0
    Bekam 63 mal "Danke" in 63 Postings

    Standard AW: CSS wird nicht richtig erkannt

    Könntest du bitte deinen Code in einem 'lesbaren' Format posten? ... oder besser gleich einen Link zur Seite.
    In der Form, wie es oben angezeigt wird, blickt ja keiner durch!
    PHP-Code:
    if(!sleep)
      {
    $sheep++;}
    else
      {
    $status="zzzz";} 

  3. #3
    Azubi(ne)
    Themenstarter

    Registriert seit
    07.04.2018
    Beiträge
    74
    Danke
    4
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: CSS wird nicht richtig erkannt

    Sorry


    Webseite: http://simuundquex.de

    html (ohne code)
    <!doctype html>
    <html>
    <head>
    <meta charset="utf-8">
    <title>SimuUndQuex</title>
    <link rel="stylesheet" href="stylesheet.css">
    <link rel="shortcut icon" href="server-icon.ico" type="image/x-icon">
    </head>
    <body>
    <nav>
    <ul>
    <li><a href="index.html">Start</a></li>
    <li><a href="news.html">News</a>
    <li><a href="clans.html">Clans</a>
    <li><a href="range.html">Ränge</a>
    <li><a href="games.html">Games</a>
    </ul>
    </nav>
    <div>
    <h1>News</h1>
    </div>
    <div>
    <div id="newsbuttondiv">
    <a href="news/teamspeak-upgrade.html"><img src="news_tsupgrade.png" alt="Das Bild konnte nicht geladen werden..." /></a>
    </div>
    </div>
    </body>
    </html>

  4. #4
    Meister(in)
    Registriert seit
    27.07.2015
    Ort
    Nordseeküste
    Beiträge
    300
    Danke
    0
    Bekam 63 mal "Danke" in 63 Postings

    Standard AW: CSS wird nicht richtig erkannt

    3 Dinge fallen mir auf:
    1. du solltest <!DOCTYPE html> schreiben und nicht <!DOCKTYPE html>
    2. du solltest, auch wenn es gemäß Spezifikation nicht zwingend vorgeschrieben ist, dein HTML Tags schließen... hier fehlen 4 von 5 </li>'s
    3. lösche aus deinem CSS die Formatierung
    HTML-Code:
    ul li:active
    {
            color: #fff;
            text-decoration: none;
        display:block;
        padding:20px;
    }
    die Pseudoklasse :active gibt es nicht für <li> Elemente, sondern nur für Hyperlinks <a>

    Ansonsten macht das CSS, soweit ich das sehen kann, genau das, was drin steht!

    Sollte mit diesen Änderungen keine Verbesserung eintreten, melde dich wieder.
    PHP-Code:
    if(!sleep)
      {
    $sheep++;}
    else
      {
    $status="zzzz";} 

  5. #5
    Youngster
    Registriert seit
    13.04.2018
    Beiträge
    12
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: CSS wird nicht richtig erkannt

    Hi,

    ich denke das ein Problem auf der Software liegt.

    Viele Grüße
    Katarina1246

  6. #6
    König(in)
    Registriert seit
    13.06.2012
    Beiträge
    1.279
    Danke
    17
    Bekam 70 mal "Danke" in 68 Postings

    Standard AW: CSS wird nicht richtig erkannt

    Zitat Zitat von Katarina1246
    ich denke das ein Problem auf der Software liegt.
    Es ist immer eine Kombination aus Soft- und Hardwareproblem vor der Tastatur.
    Gegen Mods kommt man nicht an, die haben immer Recht. Sind scheinbar nicht kritikfähig.

Ähnliche Themen

  1. Webcam problem. Wird nicht richtig erkannt
    Von KA123 im Forum Computer - Internet Forum
    Antworten: 5
    Letzter Beitrag: 05.01.2011, 18:30
  2. Feldname wird nicht erkannt
    Von OliverN im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 6
    Letzter Beitrag: 24.02.2010, 16:24
  3. S-ATA Platten werden nicht (richtig) erkannt?
    Von -TS-design im Forum Computer - Internet Forum
    Antworten: 1
    Letzter Beitrag: 01.09.2007, 09:21
  4. USB Driver wird nicht erkannt
    Von K.L.22 im Forum Computer - Internet Forum
    Antworten: 1
    Letzter Beitrag: 22.06.2007, 18:45
  5. [PHP] \n wird nicht erkannt
    Von DarkSyranus im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 0
    Letzter Beitrag: 12.04.2007, 14:14

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •