Ergebnis 1 bis 2 von 2

Thema: Selektoren funktionieren nicht

  1. #1
    HTML Newbie
    Registriert seit
    18.07.2015
    Beiträge
    1
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard Selektoren funktionieren nicht

    Hallo,

    bei einer bestehenden Webseite möchte ich eine Filter-Funktion einbauen.
    Hierbei sollen die Bilder nach "RED", "GREEN", "BLUE" gefiltert werden.

    Der unten stehenden Code funktioniert.
    Sobald ich jedoch in dem ersten DIV-Kontainer die Zeilen <article class="small-1"> und </article> einfüge (also, die Auskommentierung entferne), funktionieren die Filter nicht mehr.
    Wahrscheinlich muss ich im CSS nur einen anderen Selektor benutzen.

    Ich habe mir den Code von dieser Webseite kopiert und entsprechen umgebaut: http://jsfiddle.net/joshvogt/UybPY/



    Kann mir jemand einen Tipp geben, was ich ändern muss, ohne gleich die vorhandene Struktur zu verändern?

    Vielen Dank!



    -----------------------------

    <style type="text/css">

    a[data-filter="red"]:focus ~ article:not([data-filter="red"])
    { display:none;}

    a[data-filter="green"]:focus ~ article:not([data-filter="green"])
    { display:none;}

    a[data-filter="blue"]:focus ~ article:not([data-filter="blue"])
    { display:none;}

    </style>

    ...

    <div class="content">
    <!--<article class="small-1">-->
    <h1>Headline</h1>
    <a href="#" data-filter="all">ALL</a>
    <a href="#" data-filter="red">RED</a>
    <a href="#" data-filter="green">GREEN</a>
    <a href="#" data-filter="blue">BLUE</a>
    <!--</article>-->

    <article class="small-2" data-filter="red">
    <a href="#"><img src="http://placehold.it/350x150.jpg&text=RED" class="thubnail-bilder_slideshow"/>
    </article>

    <article class="small-2" data-filter="blue">
    <a href="#"><img src="http://placehold.it/350x150.jpg&text=BLUE" class="thubnail-bilder_slideshow"/>
    </article>

    <article class="small-2" data-filter="green">
    <a href="#"><img src="http://placehold.it/350x150.jpg&text=GREEN" class="thubnail-bilder_slideshow"/>
    </article>
    </div>
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Großmeister(in)
    Registriert seit
    04.08.2009
    Beiträge
    574
    Danke
    0
    Bekam 67 mal "Danke" in 65 Postings

    Standard AW: Selektoren funktionieren nicht

    Hallo,

    ich wüßte nicht das "data-filter" zu HTML oder CSS gehören. Von daher wird es schwierig dir zu helfen.

    Gruss

    MrMurphy

Ähnliche Themen

  1. Metatags funktionieren nicht
    Von Markus K im Forum HTML & CSS Forum
    Antworten: 5
    Letzter Beitrag: 01.01.2009, 23:31
  2. Browser funktionieren nicht
    Von Dose im Forum Computer - Internet Forum
    Antworten: 17
    Letzter Beitrag: 16.03.2007, 16:23
  3. Banner funktionieren nicht!
    Von im Forum HTML & CSS Forum
    Antworten: 10
    Letzter Beitrag: 07.05.2005, 10:55
  4. TBK Animationen funktionieren nicht!
    Von thorstenf01 im Forum Forum für Grafiken und Bildbearbeitung
    Antworten: 1
    Letzter Beitrag: 13.12.2004, 15:15
  5. Links Funktionieren nicht
    Von nobody im Forum HTML & CSS Forum
    Antworten: 3
    Letzter Beitrag: 09.03.2004, 13:10

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •