Ergebnis 1 bis 2 von 2

Thema: Probleme mit Pythong / https / Produkten

  1. #1
    HTML Newbie
    Registriert seit
    15.02.2010
    Beiträge
    9
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard Probleme mit Pythong / https / Produkten

    Hallo,

    ich versuche mein altes Webprojekt (war auf einem debian 6 Rechner) auf einen debian 7 Rechner zu übertragen.
    Die Plone version ist 3.3.5. Auf eine höhere Version migrieren ist nach vielen Versuchen gescheitert. Dennoch, zumindest den Umzug möchte ich hinbekommen.
    Soweit klappt alles ganz gut. Seite steht.
    Leider hapert es noch an der Installation der Produkte. Als Beispiel "PloneFormGen".
    Ich habe dieses Produkt in meine buildout.cfg eingetragen.

    Wenn ich bin/buildout durchführe erhalte ich folgende Fehlermeldung:
    Download error: unknown url type: https -- Some packages may not be found!
    Couldn't find index page for 'Products.PloneFormGen' (maybe dispelled?)
    Download error: unknown url type: https -- Some packages may not be found!
    Getting distribution for 'Products.PloneFormGen==1.6.3'.
    While:
    Installing instance.
    Gettring distribution for 'Products.PloneFormGen==1.6.3'.
    Error: Couldn't find a distribution for 'Products.PloneFormGen==1.6.3'.
    Wenn ich das richtig sehe ist also Python nicht mit ssl installiert worden(?). Zumindest entnehme ich das so mehr oder minder dieser Seite:
    http://developer.plone.org/troublesh...url-type-https

    Ich habe nun auch das folgende Paket installiert:

    sudo apt-get install libssl-dev

    Aber leider funktioniert das ganze immernoch nicht. Wenn ich die configure Option aus obigem Link ausprobiere erhalte ich:
    Configuring Zope installation

    Testing for an acceptable Python interpreter

    Python version 2.7.3 found at /usr/bin/python

    No suitable Python version found. You should install Python version 2.4.6 before constinuing.
    Versions 2.4.5, 2.4.4 also work, but not as optimally.
    Ok... ich bin mir nun nicht sicher OB das Problem wirklich an der falschen Python version liegt. Falls ja bin ich mir nicht sicher OB ich überhaupt python 2.4.6 gegen 2.7 austauschen kann? Habe gelesen, dass das zumindest unter ubunute zu großen Problemen führen kann.
    Und grundsätzlich dachte ich, dass Python 2.4. automatisch von Plone installiert wird? Kann es sein, dass die Version auf neueren Debian versionen einfach nicht mehr läuft?
    Das wäre ja ungünstig. In dem Fall MÜSSTE ich ja fast schon auf debian 6 umsteigen oder nicht?

    Also bin für jede Hilfe dankbar. Im Endeffekt möchte ich nur, dass meine Produkete ordentlich installiert werden was im Moment noch nicht der Fall ist.
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Interessierte/r Avatar von derstappenit
    Registriert seit
    04.09.2006
    Ort
    Leipzig
    Beiträge
    132
    Danke
    0
    Bekam 3 mal "Danke" in 3 Postings

    Standard AW: Probleme mit Pythong / https / Produkten

    Hallo,

    nein Du kannst nicht einfach mit Python2.7 arbeiten, dazu muss Plone vorher aktualisiert werden.
    Du brauchst also ein Python 2.4 was der Plone installer eigentlich mit bringt. Den Installer für Plone 3.3.5 kannst Du Dir von plone.org ziehen.
    Der installierst dann alles.
    Eine Migration sollte in der Regel auch möglich sein, wenn auch manchmal etwas nachgeholfen werden muss .

    Python2.4 habe ich glaube ich nur auf Squeese laufen, was bekommst Du denn für einen Fehler?
    Geändert von derstappenit (11.11.2013 um 19:16 Uhr)

Ähnliche Themen

  1. Mail Dokument?? Probleme,probleme,probleme.........
    Von typisch-design im Forum HTML & CSS Forum
    Antworten: 3
    Letzter Beitrag: 10.02.2010, 13:36
  2. test auf https mit php
    Von jojo87 im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 0
    Letzter Beitrag: 22.01.2009, 17:34
  3. HTTPS in HTTP (Apache Proxy)
    Von driver im Forum Computer - Internet Forum
    Antworten: 2
    Letzter Beitrag: 15.11.2007, 14:46
  4. Probleme mit TFT
    Von ludolf86 im Forum Computer - Internet Forum
    Antworten: 0
    Letzter Beitrag: 13.10.2007, 13:32
  5. dns-probleme
    Von Rocco im Forum Computer - Internet Forum
    Antworten: 2
    Letzter Beitrag: 02.02.2005, 20:03

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •