Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 22

Thema: Kollation Problem nach Serverumzug - leider keine Lösung gefunden

  1. #1
    Youngster Avatar von Freak2012
    Registriert seit
    21.02.2012
    Ort
    Erde
    Beiträge
    12
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Frage [gelöst] Kollation Problem nach Serverumzug - leider keine Lösung gefunden

    Hallo liebe Community,

    ich möchte eine Forensoftware wbb2 (woltlab burning board) auf einen anderen Server übertragen.
    Die Datenbank ist etwas größer, sodass ich diese mit einem mysql dumper gesichert habe.

    Datenimport über mysql dumper funktioniert einwandfrei, dass Forum kann auf dem neuen Server aufgerufen werden.
    Soweit okay, jedoch gibt es Probleme mit der Umsetzung der Umlaute (äÄüÜöÖ etc.)
    Ich habe herausgefunden das es an der Kollation liegt, jedoch habe ich einiges versucht und ich habe bisher keine Lösung gefunden.
    Erfahrungen in Sql und php sind sehr begrenzt.

    Im Internet finde ich dieses Problem sehr oft, wie Sand am Meer.
    Antworten und Lösungen gibt es keine konkrete, die auf mein Problem passt.
    Ich erhoffe mir einen Lösungsweg, auch wenn er mit etwas Arbeit verbunden ist.

    Folgende Informationen:

    MySQL Datenbank beim alten Provider bzw. die zu importierende Datenbank:
    phpMyAdmin - 2.11.10.1
    MySQL-Client-Version: 3.23.49
    Sprache - language: Deutsch - German (iso-8859-1)


    Sobald ich diese auf der neuen Datenbank importiert habe, wird folgende Kollation angezeigt: latin1_bin

    Das Forum möchte ich auf meinem VPS hosten.
    Hier sind die Daten meiner MySQL Datenbank:


    • Server: Localhost via UNIX socket
    • Server Version: 5.1.41-3ubuntu12.10
    • Protokoll-Version: 10
    • MySQL-Zeichensatz: UTF-8 Unicode ( utf8 )


    Ich habe root Zugriff und kann evtl. Einstellungen ändern, wenn es für einzelne Datenbanken möglich ist.
    UTF-8 ist und soll auch für meine anderen Projekte auf dem VPS Standard bleiben.
    Es wäre super, wenn ich eine Datenbank so umstellen kann, wie die bei dem anderen Provider ist, sodass die Inhalte der Tabellen korrekt ausgelesen werden.

    Die Inhalte der Tabellen sind z.B.: "Das Wetter ist schön."
    Die Umlaute sind in der Datenbank korrekt.

    Wenn ich die Kollation der einzelnen Tabellen verändere geschieht auch nichts, dass sollen auch zwei verschiedene Paar Schuhe sein.
    Einmal die Tabellen Kollation und einmal das Mysql zeichensatz der Datenbank.

    Bin ich mit meiner Vermutung richtig, wenn ich das MySQL Zeichensatz von UTF-8 auf "Deutsch - German (iso-8859-1)" umstellen könnte, würden die Inhalte einwandfrei angezeigt werden?
    Ich würde mich über jede Hilfe freuen.
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!
    Angehängte Grafiken Angehängte Grafiken
    Geändert von Freak2012 (26.02.2012 um 18:07 Uhr)

  2. #2
    Bandit
    Gast

    Standard AW: Kollation Problem nach Serverumzug - leider keine Lösung gefunden

    Wenn du an den alten Server noch dran kommst, dann gebe mal z.B. mit phpMyAdmin folgendes ein:
    Code:
    show create database datenbankname
    Auf dem neuen Server erzeugst du die Datenbank genau mit dieser Ausgabe

  3. #3
    Youngster
    Themenstarter
    Avatar von Freak2012
    Registriert seit
    21.02.2012
    Ort
    Erde
    Beiträge
    12
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: Kollation Problem nach Serverumzug - leider keine Lösung gefunden

    Hallo Bandit,

    ich komme an die Datenbank, noch ist der Webspace online.
    Ich bin über das phpMyAdmin und in die Sql Konsole gegangen.
    Leider ohne erfolg, ich bekomme folgende Meldung:

    Code:
    Fehler
    
    SQL-Befehl: 
    SHOW CREATE DATABASE usr_web14_1 
    MySQL meldet: 
    #1064 - You have an error in your SQL syntax near 'database usr_web14_1' at line 1 
    
    Vielleicht ist der Befehl falsch eingegeben?
    localhost anstatt Database hat auch nicht weiter geholfen.

  4. #4
    Bandit
    Gast

    Standard AW: Kollation Problem nach Serverumzug - leider keine Lösung gefunden

    Siehe http://dev.mysql.com/doc/refman/5.1/...rset-show.html

    An "show create database datenbankname" ist eigentlich nichts dran auszusetzen.

    Bei mir kommt z.B.

    CREATE DATABASE `dbname` /*!40100 DEFAULT CHARACTER SET utf8 COLLATE utf8_unicode_ci */

  5. #5
    Youngster
    Themenstarter
    Avatar von Freak2012
    Registriert seit
    21.02.2012
    Ort
    Erde
    Beiträge
    12
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: Kollation Problem nach Serverumzug - leider keine Lösung gefunden

    Leider funktioniert das nicht, ich zweifel auch nicht an die richtigkeit des Befehls, eher an dem Server.
    Was musst du genau wissen? Gibt es einen anderen Weg die Information herauszufinden? Evtl. per php code auslesen?

  6. #6
    Bandit
    Gast

    Standard AW: Kollation Problem nach Serverumzug - leider keine Lösung gefunden

    Wenn du auf den alten Server root-Zugriff hast, dann siehe mal in das MySQL-Data-Verzeichnis der Datenbank. Dort sollte man eine Datei db.opt finden, in dieser stehen Informationen, die du verwenden kannst.

  7. #7
    Youngster
    Themenstarter
    Avatar von Freak2012
    Registriert seit
    21.02.2012
    Ort
    Erde
    Beiträge
    12
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: Kollation Problem nach Serverumzug - leider keine Lösung gefunden

    Nein, der alte Webspace ist von einem Freund von mir.
    Er zahlt dafür viel zu viel, hat Zugriff auf seinen Webspace mit 600 MB Speicherplatz und auf phpMyAdmin (2 Datenbanken).
    Das ist ein uralter Vertrag, extrem teuer, jeden Abend down / überlastet und root Zugriff gibt es nicht.

  8. #8
    Bandit
    Gast

    Standard AW: Kollation Problem nach Serverumzug - leider keine Lösung gefunden

    Dann hast du noch die Möglichkeit, in die exportierte Datei reinzusehen. Wenn oben was von

    /*!40101 SET NAMES utf8 */;

    steht und am Ende eines Create table

    ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci;

    steht, dann sollte die DB natürlich auch als UTF-8 angelegt werden

  9. #9
    Youngster
    Themenstarter
    Avatar von Freak2012
    Registriert seit
    21.02.2012
    Ort
    Erde
    Beiträge
    12
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: Kollation Problem nach Serverumzug - leider keine Lösung gefunden

    Leider habe ich keinen Zugriff auf die Sicherung, die befindet sich auf meinem anderen Rechner und von diesem Rechner kann die Datenbank von meinem mysql dumper nicht herunterladen werden, per FTP komme ich jetzt nicht dran.
    In der Sicherung steht etwas von latin1, soweit ich mich erinnern kann.
    utf8 wird zudem von der alten Datenbank nicht unterstützt, sodass ein backup nur in latin1 möglich ist.

  10. #10
    Bandit
    Gast

    Standard AW: Kollation Problem nach Serverumzug - leider keine Lösung gefunden

    Wenn du an die Informationen, mit welchen Zeichensätzen die alte DB arbeitete, nicht dran kommst, dann kannst du nur exprimentieren.

Ähnliche Themen

  1. Gericom Mobile P4 3060 - keine HDD gefunden
    Von DarkSyranus im Forum Computer - Internet Forum
    Antworten: 2
    Letzter Beitrag: 21.09.2008, 11:16
  2. Nach Serverumzug - Scriptfehler
    Von Unregistriert im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 14
    Letzter Beitrag: 16.09.2008, 09:49
  3. Mousover mit CSS - ich find hier keine Lösung
    Von freesy im Forum HTML & CSS Forum
    Antworten: 0
    Letzter Beitrag: 22.04.2007, 17:10
  4. Antworten: 6
    Letzter Beitrag: 10.01.2006, 09:48
  5. suche nach einer Lösung
    Von michalex32 im Forum HTML & CSS Forum
    Antworten: 1
    Letzter Beitrag: 22.09.2004, 21:16

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •