Ergebnis 1 bis 8 von 8

Thema: Span in Link wird online nicht dargestellt

  1. #1
    HTML Newbie
    Registriert seit
    25.08.2011
    Beiträge
    4
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard Span in Link wird online nicht dargestellt

    Hi,

    seit etwa vier Monaten arbeite ich mich in HTML etc. ein.
    Jetzt ist ein Problem aufgetaucht, zudem ich keine Lösung finde:

    Ich habe eine Galerie auf HTML-Basis nachgebaut/kopiert, die bei der DW-Vorschau einwandfrei funktioniert.
    Sobald ich diese zu Test zwecken Online setzte, werden alle CSS-Befehle ignoriert.

    (Ich bin mir bewusst, dass diese Galerie nicht mein Geistiges Eigentum ist, dennoch möchte ich doch gerne verstehen warum das ganze Online einfach keine Wirkung zeigt.)

    Falls jemand erkennt ob etwas fehlt oder sonst irgendeine Idee hat, bedanke mich schon einmal im Vorraus für die Hilfe.

    Gruß
    Juschi



    Hier der HTML-Code
    HTML-Code:
    <div class="galerie-folder">
        <a class="frame1" href="http://www.xxx.de/galerie/2011.html" tabindex="-1" name="Mai 2011" style="">
            <span class="frame2">    <i style="background-image: url(http://www.xxx.de/top.jpg);" class="frame3"></i>        </span>
        </a>
       <div align="center" class="folder-jahr"><a class="none" href="2011.html">Mai 2011</a><br /><br /></div>
            </div>

    Hier die dazugehörigen CSS-Befehle
    Code:
    .galerie-folder {
        height: auto;
        width: 180px;
        border-collapse: collapse;
        border-spacing: 0;
        padding-left: 40px;
        float: left;
    }
    
    .folder-jahr {
        font-family: Georgia, "Times New Roman", Times, serif;
        font-size: 18px;
        color: #333;
        height: 20px;
        width: 180px;
        padding-top: 10px;
    }
    
    .frame1    {
        border: thin groove #CCC;
        height: 125px;
        width: 160px;
        background-color: #FFF;
        padding-top: 5px;
        padding-left: 5px;
        display:block;
        margin-bottom: 4px;
        margin-right: 4px;
    }
    
    a.frame1:hover, .frame1:hover .frame2, a.frame1:active, .frame1:active .frame2, a.frame1:focus, .frame1:focus .frame2 {
        border: thin groove ;
        border-color: #3B5998;
        border-top-color: #3B5998;
        border-left-color: #3B5998;
        border-right-color: #3B5998;
    }
    
    .frame2    {
        border: thin groove #999;
        height: 125px;
        width: 160px;
        background-color: #FFF;
        padding-top: 5px;
        padding-left: 5px;
        display:block;
        -moz-border-bottom-colors: none;
        -moz-border-image: none;
        -moz-border-left-colors: none;
        -moz-border-right-colors: none;
        -moz-border-top-colors: none;
        background-attachment: scroll;
        background-clip: border-box;
        background-color: #FFF;
        background-image: none;
        background-origin: padding-box;
        background-position: 0 0;
        background-repeat: repeat;
        background-size: auto auto;
        border-bottom-color: #CCCCCC;
        border-bottom-style: solid;
        border-bottom-width: 1px;
        border-left-color-ltr-source: physical;
        border-left-color-rtl-source: physical;
        border-left-color-value: #CCCCCC;
        border-left-style-ltr-source: physical;
        border-left-style-rtl-source: physical;
        border-left-style-value: solid;
        border-left-width-ltr-source: physical;
        border-left-width-rtl-source: physical;
        border-left-width-value: 1px;
        border-right-color-ltr-source: physical;
        border-right-color-rtl-source: physical;
        border-right-color-value: #CCCCCC;
        border-right-style-ltr-source: physical;
        border-right-style-rtl-source: physical;
        border-right-style-value: solid;
        border-right-width-ltr-source: physical;
        border-right-width-rtl-source: physical;
        border-right-width-value: 1px;
        border-top-color: #CCCCCC;
        border-top-style: solid;
        border-top-width: 1px;
        padding-bottom: 4px;
        padding-left: 4px;
        padding-right: 4px;
        padding-top: 4px;
        top: 486px;
        left: 182px;
        }
    
    .frame3 {
        height: 115px;
        width: 150px;
        background-color: #CCC;
        padding-top: 5px;
        padding-left: 5px;
        padding-bottom: 5px;
        padding-right: 5px;
        display:block;
    }
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Unregistriert
    Gast

    Standard AW: Span in Link wird online nicht dargestellt

    Ein Link zur Seite wäre nicht schlecht

  3. #3
    HTML Newbie
    Registriert seit
    25.08.2011
    Ort
    Bayern
    Beiträge
    1
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: Span in Link wird online nicht dargestellt

    Hallo

    probiere mal folgendes:

    mit Firebug das Element auswählen, welches die CSS-Eigenschaften nicht annimmt, dann Rechtsklick -> CSS-Pfad kopieren.

    Den Pfad schreibst du dann im CSS vor die jeweilige Klasse. Sollte es dann funktionieren, gibt es irgendeinen übergeordneten DIV-Container etc., der daran schuld sein könnte.

  4. #4
    HTML Newbie
    Themenstarter

    Registriert seit
    25.08.2011
    Beiträge
    4
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: Span in Link wird online nicht dargestellt

    Zum Gast:

    Die Test-Version der Seite läuft unter folgender Adresse: www.maigesellschaft-schophoven.de
    Unter "Galerie" kann man sehen das lediglich die Namen der Ordner zu sehen sind

    Auf dem folgenden Bild ist das eigentliche Design zu sehen:
    www.maigesellschaft-schophoven.de/galerie.jpg


    Zu Oxi:
    Ich teste jetzt einmal die FB Sache und zum 2. Tipp:

    Die Galerie bzw. Ordner sind wiefolgt aufgebaut:

    1. div (Content) *für jede Seite gleich
    1.1 div (galerie) *
    1.2 div (ordner)
    1.3 Link (Frame1)
    1.4 Span (Frame2)
    1.5 i-Tag (Bild)


    Melde mich gleich nochmal mit news...

  5. #5
    Unregistriert
    Gast

    Standard AW: Span in Link wird online nicht dargestellt

    Dat Bild gibbet: http://maigesellschaft-schophoven.de...ai2011/top.jpg
    Dat Bild gibbet nich: http://maigesellschaft-schophoven.de...ai2010/top.jpg
    Wat soll er da auch anzeigen?

  6. #6
    HTML Newbie
    Themenstarter

    Registriert seit
    25.08.2011
    Beiträge
    4
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: Span in Link wird online nicht dargestellt

    Ich war gerade eine halbe Stunde afk...

    Das kuriose an dieser Geschichte ist, als ich gerade mit der Fehlersuche fortfahren wollte, gab es keinen Fehler mehr...

    Deshalb hast du natürlich recht Gast(2), was nicht da ist kann nicht angezeigt werden, das eigentliche Problem bezog sich aber darauf, dass gar nichts angezeigt wurde.

    Zum Veranschaulichen hier zwei Bilder:

    Fehlerhafte Version der Galerie:
    http://www.maigesellschaft-schophove...rie-fehler.jpg

    Korrekte Version (mit kleineren formatierungs fehlern):
    http://www.maigesellschaft-schophove...ie-korrekt.jpg


    Ich schätze, dass es beim Upload zu verzögerungen kam... anders ist es für mich gerade nicht zu erklären.
    Deswegen kann ich gerade nicht 100% sagen was die Fehler verursacht hat.


    Vielen Dank an die Beteiligten und schön' Tag noch
    Juschi

  7. #7
    Unregistriert
    Gast

    Standard AW: Span in Link wird online nicht dargestellt


  8. #8
    HTML Newbie
    Themenstarter

    Registriert seit
    25.08.2011
    Beiträge
    4
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: Span in Link wird online nicht dargestellt

    Ok,

    gut das du mir das gezeigt hast bisher hab ich keine Validation der Seite vorgenommen...

    Zur 1. Warnung hab ich allerdings keine Änderung vorgenommen
    Zur 3. Warnung: ich denke das ich statt einem div-tag ein span nehmen sollte

Ähnliche Themen

  1. CSS wird in Firefox nicht dargestellt
    Von chantal im Forum HTML & CSS Forum
    Antworten: 13
    Letzter Beitrag: 05.06.2011, 11:06
  2. Tabelle wird im Firefox nicht dargestellt (CSS)
    Von WinniPuh im Forum HTML & CSS Forum
    Antworten: 2
    Letzter Beitrag: 21.09.2008, 13:14
  3. Website wird online nicht dargestellt
    Von 00eraser00 im Forum HTML & CSS Forum
    Antworten: 12
    Letzter Beitrag: 13.08.2007, 13:04
  4. Hintergrundbild wird im Gästebuch nicht dargestellt
    Von Metaltubbie im Forum Forum-Hilfe.de intern
    Antworten: 3
    Letzter Beitrag: 08.04.2007, 11:23
  5. HIIILLLLFFFEEEE!!! HP wird nicht richtig dargestellt!
    Von Toschi. im Forum HTML & CSS Forum
    Antworten: 15
    Letzter Beitrag: 29.02.2004, 17:37

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •