Ergebnis 1 bis 5 von 5

Thema: Probleme mit Rewrite Engine, htaccess, keine Bilder werden geladen

  1. #1
    Unregistriert
    Gast

    Unglücklich Probleme mit Rewrite Engine, htaccess, keine Bilder werden geladen

    Hallo.
    Ich wollte eine einfache URL-Maskierung schreiben. Die geht so:

    Options +FollowSymlinks
    RewriteEngine on
    RewriteRule ^([a-zA-Z0-9&=\-]+)\/([a-zA-Z0-9&=\-]+)$ index.php?w=$1&x=$2
    RewriteRule ^([a-zA-Z0-9&=\-]+)$ index.php?w=$1

    Also die Adressen wie www.blabla.de/abc werden zu www.blabla.de/index.php?w=abc und
    www.blabla.de/abc/def zu www.blabla.de/index.php?w=abc&x=def.

    Die Variablen werden tatsächlich richtig übermittelt. Das Problem ist nur, dass in dem 2. Fall (mit 2 Variablen) wird NUR die Datei index.php, ganz ohne Bilder und ohne die CSS Datei, geladen. Vielleicht werden auch die Dateinamen in den HTML-Tags überschrieben? Wenn ja, wie umgeht man das?

    Ich möchte eine URL-Maskierung haben, die maximal 4 Variablen enthalten kann (w, x, y und z) in folgender Form: /w/x/y/z, wobei die Reihenfolge festgelegt ist, es müssen aber nicht immer alle 4 Variablen auftreten (z.B. /w/x). Ich möchte auch, dass die Adresse unabhängig davon funktioniert, ob am Ende ein Slash steht oder nicht (/w/x funktioniert genauso gut wie /w/x/).

    Kann jemand helfen?
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Unregistriert
    Gast

    Standard AW: Probleme mit Rewrite Engine, htaccess, keine Bilder werden geladen

    Hab vergessen zu schreiben, ich benutze einen Free-Hosting-Service von kilu.de, vielleicht ist es von Bedeutung, oder auch nicht, weil es auf meinem PC mit XAMPP genauso läuft.

  3. #3
    Pion
    Gast

    Standard AW: Probleme mit Rewrite Engine, htaccess, keine Bilder werden geladen

    Ist doch klar das es nicht mehr geht wenn du in einen Ordner alla www.blabla.de/abc/def reingehst

    Man umgeht das Problem indem man anständige Urls macht...

    Nehme Absolute Urls und du hast damit keine Problem

    Solltest dich auf eins einigen, entweder mit / oder ohne / nicht beides....

  4. #4
    der/die Göttliche Avatar von jojo87
    Registriert seit
    23.03.2007
    Ort
    Leipzig
    Alter
    30
    Beiträge
    3.131
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: Probleme mit Rewrite Engine, htaccess, keine Bilder werden geladen

    man nehme base

  5. #5
    Unregistriert
    Gast

    Standard AW: Probleme mit Rewrite Engine, htaccess, keine Bilder werden geladen

    Das mit dem "base" funktioniert tatsächlich! Danke Mann!

Ähnliche Themen

  1. Mod Rewrite in .htaccess
    Von MyXoToD im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 2
    Letzter Beitrag: 24.10.2009, 15:53
  2. .htaccess Mod Rewrite Domainumleitung
    Von 1234d1 im Forum HTML & CSS Forum
    Antworten: 0
    Letzter Beitrag: 19.10.2009, 13:16
  3. Webseiten werden nicht komplett geladen!
    Von fred_ferkel im Forum Computer - Internet Forum
    Antworten: 2
    Letzter Beitrag: 29.05.2006, 08:46
  4. Probleme mit meinem Auktionshaus-DRINGEND!!! Bilder werden .
    Von Das-Auktionshaus.net im Forum HTML & CSS Forum
    Antworten: 2
    Letzter Beitrag: 13.02.2006, 11:37
  5. Frames werden kurz weiß bevor sie geladen werden.
    Von potter im Forum HTML & CSS Forum
    Antworten: 4
    Letzter Beitrag: 15.05.2005, 22:07

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •