Ergebnis 1 bis 7 von 7

Thema: Frage zu /Problem mit phpMailer (AddEmbeddedImage)

  1. #1
    Teeny
    Registriert seit
    06.03.2008
    Beiträge
    41
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard Frage zu /Problem mit phpMailer (AddEmbeddedImage)

    Hallo,

    ich habe ein Problem mit dem phpMailer von http://phpmailer.worxware.com/ .

    Grundsätzlich funktioniert das Ganze. Nun würde ich gerne eine Grafik einbinden. Das funktioniert aber leider nicht so ganz.

    Ich binde die Grafik wie folgt ein:
    PHP-Code:
    $imgpfad "http://www.domain.de/images/"
    $mail->AddEmbeddedImage("$imgpfad,"header.jpg","header","header.jpg",'base64','application/octet-stream');

    $nachricht=".........<img src=\"cid:header\" alt=\"....\" ";

    $mail->MsgHTML($nachricht); 
    Die Grafik wird in der Mail dann allerdings nicht angezeigt. Ich mabe mal folgendes ausgeben lassen:

    Code:
    if(!$mail->AddEmbeddedImage)
                echo"false";
    Dabei wird immer false ausgegeben. Das sollte doch ein Zeichen dafür sein, dass beimEinbinden schon was nicht geklappt hat!?

    Der Pfad der Grafik stimmt auf jeden Fall, den die wird anderweitig schon verwendet, existiert und auch unter dem Pfad.

    Hat jemand eine Idee, woran das liegen könnte?

    Beste Grüße
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Bandit
    Gast

    Standard AW: Frage zu /Problem mit phpMailer (AddEmbeddedImage)

    1. Das gehört ins "Forum für PHP - Apache - CGI - Perl - JavaScript und Co", mit HTML/XHTML/CSS hat das nix zu tun.
    2. Wie kommst du darauf, dass der Pfad eine URL sein darf?

  3. #3
    Teeny
    Themenstarter

    Registriert seit
    06.03.2008
    Beiträge
    41
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: Frage zu /Problem mit phpMailer (AddEmbeddedImage)

    Hallo,

    ich habe es auch schon mit einem Pfad zu der Grafik versucht, aber das funktionierte leider auch nicht.

    Mit folgendem funktioniert es:
    PHP-Code:
    $mail->AddEmbeddedImage("../../images/header.jpg","header","header.jpg",'base64','application/octet-stream'); 
    Also nicht Pfad und Grafikname getrennt angeben, sondern beides zusammen, damit funktioniert es.

    Beste Grüße
    Geändert von sven77 (03.09.2010 um 12:11 Uhr)

  4. #4
    Bandit
    Gast

    Standard AW: Frage zu /Problem mit phpMailer (AddEmbeddedImage)

    Vielleicht postest du das nächste mal deinen originalen Quellcode. Denn der Quellcode hier hat einige Parse-Errors und ich habe keine Lust, irgendeinen fiktiven Quellcode zu korrigieren.

    Zitat Zitat von sven77 Beitrag anzeigen
    Also nicht Pfad und Grafikname getrennt angeben, sondern beides zusammen, damit funktioniert es.
    Quatsch! Man muss es nur richtig machen!
    Geändert von bandit600 (03.09.2010 um 12:22 Uhr)

  5. #5
    Teeny
    Themenstarter

    Registriert seit
    06.03.2008
    Beiträge
    41
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: Frage zu /Problem mit phpMailer (AddEmbeddedImage)

    Hallo,

    aha OK, aber wie wäre denn dann richtig?


    Beste Grüße

  6. #6
    Bandit
    Gast

    Standard AW: Frage zu /Problem mit phpMailer (AddEmbeddedImage)

    PHP-Code:
    $path '../../images/'
    $mail->AddEmbeddedImage($path 'header.jpg''header''header.jpg''base64','application/octet-stream'); 

  7. #7
    Teeny
    Themenstarter

    Registriert seit
    06.03.2008
    Beiträge
    41
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: Frage zu /Problem mit phpMailer (AddEmbeddedImage)

    Vielen Dank!

Ähnliche Themen

  1. phpmailer
    Von visitor im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 51
    Letzter Beitrag: 29.05.2009, 14:11
  2. PHPMailer - E-Mailversand funktioniert nicht?
    Von Darkxor im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 39
    Letzter Beitrag: 08.04.2009, 11:08
  3. Charset Joomla+phpmailer
    Von jojo87 im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 0
    Letzter Beitrag: 28.02.2008, 03:31
  4. Upload Frage / Problem
    Von PHPDummy im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 13
    Letzter Beitrag: 03.09.2007, 23:37
  5. MySpace Frage & Problem.
    Von taktlos. im Forum HTML & CSS Forum
    Antworten: 5
    Letzter Beitrag: 07.02.2007, 19:27

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •