Ergebnis 1 bis 2 von 2

Thema: Smarty - section - Wird durchlaufen aber Werte nicht belegt

  1. #1
    Großmeister(in)
    Registriert seit
    09.12.2008
    Ort
    Berlin
    Alter
    38
    Beiträge
    666
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings
    Blog-Einträge
    1

    Standard Smarty - section - Wird durchlaufen aber Werte nicht belegt

    Nutze momentan zum ersten mal Smarty, eigentlich ganz nette Sache, jetzt habe ich aber ein kleines Problem.
    Ich habe eine section durch die geloopt wird, wird auch durchlaufen, aber die Werte in der Section werden nicht belegt.

    Der Template-Bereich:
    HTML-Code:
    {section name=auftragsliste loop=$auftraege}
    {strip}
        <tr bgcolor="{cycle values="#ffffff,#eeeeee"}">
        <td>{$auftraege[auftragsliste].nr}</td>
        <td>{$auftraege[auftragsliste].projektnr}</td>
        <td>{$auftraege[auftragsliste].foto}</td>
        <td><a href='./?firma={$auftraege[auftragsliste].firma}&auftrag={$auftraege[auftragsliste].id}'>{$auftraege[auftragsliste].name}{$auftraege[auftragsliste].genres}</a></td>
        <td>{$auftraege[auftragsliste].kunde}</td>
        <td>{$auftraege[auftragsliste].adatum}</td>
        <td>{$auftraege[auftragsliste].edatum}</td>
        <td>{$auftraege[auftragsliste].ansprechpartner}</td>
        <td style='{$auftraege[auftragsliste].st_br}'>{$auftraege[auftragsliste].status}</td>
        <td>{$auftraege[auftragsliste].betreuung}</td>
        <td>{$auftraege[auftragsliste].bezahlt}</td>
        </tr>
    {/strip}
    {/section}
    Übermittelt wird halte per
    PHP-Code:
    $tpl->assign('auftraege',$auftraege); 
    print_r-Ausgabe von $auftraege:
    Code:
    Array
    (
        [1] => Array
            (
                [nr] => 01
                [projektnr] => 001-0001
                [foto] => 
                [firma] => 1
                [id] => 179
                [name] => test
                [genres] => 
                [kunde] => Universal
                [adatum] => offen
                [edatum] => offen
                [ansprechpartner] => 
                [status] => 0
                [betreuung] => ff
                [bezahlt] => icons/sign_warning.png
                [st_br] => 
            )
     )
    Der section-Bereich im Template wird einmal durchlaufen, es wird also eine Zeile eingefügt. Aber die Zellen bleiben alle leer.


    Habe mich an dem section Beispiel weiter unten orientiert auf http://www.smarty.net/crashcourse.php
    Ich kann da beim besten Willen keinen Unterschied zu meinem Code feststellen.




    Hat jemand eine Idee wo das Problem liegen könnte?
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!
    "Programming today is a race between software engineers
    striving to build bigger and better idiot-proof programs,
    and the universe trying to build bigger and better idiots.
    So far, the universe is winning."
    Rick Cook

  2. #2
    Großmeister(in)
    Themenstarter

    Registriert seit
    09.12.2008
    Ort
    Berlin
    Alter
    38
    Beiträge
    666
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings
    Blog-Einträge
    1

    Standard AW: Smarty - section - Wird durchlaufen aber Werte nicht belegt

    1,5 Stunden hab ich den Fehler schon gesucht, an den verschiedensten Stellen. Aber kaum poste ich hier, finde ich ihn... ^^

    Der an eine Smarty-section übergebene array (in meinem Fall $auftraege) muss mit dem Index 0 beginnen. Meiner begann mit dem Index 1.
    Auf 0 gesetzt und alles klappt...

    Ich liebe solche Fehler. ^^
    "Programming today is a race between software engineers
    striving to build bigger and better idiot-proof programs,
    and the universe trying to build bigger and better idiots.
    So far, the universe is winning."
    Rick Cook

Ähnliche Themen

  1. For Schleife wird nicht durchlaufen
    Von anki im Forum Forum für alle anderen Programmiersprachen
    Antworten: 8
    Letzter Beitrag: 20.12.2007, 18:50
  2. Applet Werte übergeben und Werte zurückgeben
    Von martin80 im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 0
    Letzter Beitrag: 08.03.2007, 19:11
  3. php problem übergabe der werte an db klappt nicht
    Von LowRydeR im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 3
    Letzter Beitrag: 30.01.2006, 15:11
  4. Bild wird per JS geladen aber manchmal im IE nicht angezeigt
    Von mikune im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 3
    Letzter Beitrag: 30.11.2005, 11:48
  5. Festplatte eingebaut | Wird erkannt, aber nicht sichtbar ...
    Von yngvar im Forum Computer - Internet Forum
    Antworten: 12
    Letzter Beitrag: 23.10.2005, 03:54

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •