Ergebnis 1 bis 9 von 9

Thema: Umlaute nach upload nicht richtig dargestellt

  1. #1
    HTML Newbie
    Registriert seit
    17.10.2009
    Beiträge
    2
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard Umlaute nach upload nicht richtig dargestellt

    Hallo Leute,

    brauche dringend Hilfe:

    Habe neue Website hochgeladen, die meines Wissens korrekt gebaut worden ist. Nur das jetzt die Umlaute nicht richtig dargestellt werden.
    Habe die Site auf einem anderen Server getestet. Dort war alles in Ordnung.
    Mit komplizierten Workaraound habe ich die index.html irgendwie hinbekommen, alles andere wird falsch dargestellt und ich habe keine Ahnung warum. Vielleicht Server-seitiges Problem? Oder seht Ihr was anderes?
    http://www.berlin-timebandits.de

    Freue mich sehr über feedback

    Pete
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Forum Guru Avatar von synaptic
    Registriert seit
    20.06.2007
    Ort
    Butzbach-Wiesental
    Beiträge
    10.901
    Danke
    45
    Bekam 48 mal "Danke" in 46 Postings
    Blog-Einträge
    1

    Standard AW: Umlaute nach upload nicht richtig dargestellt

    besorg dir notepad++ und speicher mal die dateien als utf-8 (ohne bom) konvertiert..
    du hast ne datei mit iso 8859-1 und sagst mit nem metatag dein content wäre utf-8, das muss doch knallen...
    KEIN support via pn, email, messenger oder falsch geposteten threads
    Futter für deine Schnuffelzwerge gibts bei den Schnuffelzwergen TOP Qualität, also klicken und kaufen

  3. #3
    HTML Newbie
    Themenstarter

    Registriert seit
    17.10.2009
    Beiträge
    2
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: Umlaute nach upload nicht richtig dargestellt

    das ist eigentlich alles utf-8, denke ich jedenfalls
    Hatte nur auf der Suche nach Fehler getestet.
    Habe mit dreamweaver gebaut, alles W3C zertifiziert und auf 1und1 Server lief alles richtig.
    Was heißt "ohne bom"?

    LG
    P

  4. #4
    Bandit
    Gast

    Standard AW: Umlaute nach upload nicht richtig dargestellt

    Ein BOM ist nicht in der Datei, ich gehe mal davon aus, dass du per (dämlichen) DreamWeaver die Daten auf den Server schiebst. Benutze besser einen FTP-Client w.z.B. Filezilla
    Zitat Zitat von Pikay09 Beitrag anzeigen
    alles W3C zertifiziert
    The character encoding specified in the HTTP header (iso-8859-1) is different from the value in the <meta> element (utf-8 ) I will use the value from the HTTP header (iso-8859-1) for this validation.
    Geändert von bandit600 (17.10.2009 um 19:16 Uhr)

  5. #5
    Unregistriert
    Gast

    Standard AW: Umlaute nach upload nicht richtig dargestellt

    Nee, lade mit WS-FTP hoch

    Aber was ist ein BOM?

    "The character encoding specified in the HTTP header (iso-8859-1) is different from the value in the <meta> element (utf-8 ) I will use the value from the HTTP header (iso-8859-1) for this validation."

    Verstehe ich nicht - das ist doch richtig, oder?:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

    Wo ist die Diskrepanz zw. iso-8859-1 und utf-8?
    Wie ändere ich das?

    Auf einem anderen Server hat auch alles funktioniert.
    Wie kann das sein?


    LG Pete

  6. #6
    Shogun Avatar von DarkSyranus
    Registriert seit
    28.03.2006
    Ort
    ::1/128
    Alter
    25
    Beiträge
    3.446
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings
    Blog-Einträge
    1

    Standard AW: Umlaute nach upload nicht richtig dargestellt

    Es dreht sich nicht darum, dass du UTF-8 nicht angegeben hast, sondern das die Datei nicht im UTF-8 Format gespeichert ist.
    ! Klick mich !.
    Öffne deine Datein nochmal und speichere diese als UTF-8.
    Wie das geht hängt vom Editor ab, muss du mal ein wenig suchen.

  7. #7
    Forum Guru Avatar von synaptic
    Registriert seit
    20.06.2007
    Ort
    Butzbach-Wiesental
    Beiträge
    10.901
    Danke
    45
    Bekam 48 mal "Danke" in 46 Postings
    Blog-Einträge
    1

    Standard AW: Umlaute nach upload nicht richtig dargestellt

    also der dark syranus hat ein weiteres mal das geschrieben, was ich dir von anfang an gesagt habe, wäre evtl mal an der zeit den vorschlag umzusetzen, um zu erueirenopb das des problems lösung ist..
    BOM = Byte Order Mark
    ich mein, du kannst natürlich auch weiter "jammern" und die umlaute bleiben so wie derzeit...
    KEIN support via pn, email, messenger oder falsch geposteten threads
    Futter für deine Schnuffelzwerge gibts bei den Schnuffelzwergen TOP Qualität, also klicken und kaufen

  8. #8
    Unregistriert
    Gast

    Standard AW: Umlaute nach upload nicht richtig dargestellt

    Bei meinem DW ist als Standard-Kodierung utf-8 eingestellt.

    Und bleibt immer noch die Frage, warum es bei einem Server läuft, beim anderen nicht.

    Kann es nicht tatsächlich auch ein Server-seitiges Problem sein?


    LG P

  9. #9
    Forum Guru Avatar von synaptic
    Registriert seit
    20.06.2007
    Ort
    Butzbach-Wiesental
    Beiträge
    10.901
    Danke
    45
    Bekam 48 mal "Danke" in 46 Postings
    Blog-Einträge
    1

    Standard AW: Umlaute nach upload nicht richtig dargestellt

    also nochmal langsam
    ein rechtsklick auf die von dir verlinkte page zeigt eine kodierung von iso 8859-1 und ein metatag von utf-8!
    was dein dreamweaver sagt is in diesem falle mal völlig aussen vor.
    notepad++ is kostenlos, open source und nen verdammt guter editor.
    wenn du den von mir gebrachten vorschlag nicht probieren möchtest, dann lass es, nimm es aber auch hin, dass ich mich dann hier ausklinke auf der suche nach weiteren ursachen...

    edit:
    übrigens, wenn du tatsächlich meinem vorschlag folgst wirst du alle umlaute in den dateien nochmal ersetzen müssen, da du beim konvertieren nicht automatisch "rück-encodest"
    hab grad eine datei von dir runtergalden und sie war/ist auf ANSI

    edit2: und du vermischt in den metatags auch deinen content-type... entscheide dich doch mal für einevariante und du wirst erfolg haben!
    Geändert von synaptic (18.10.2009 um 00:45 Uhr)
    KEIN support via pn, email, messenger oder falsch geposteten threads
    Futter für deine Schnuffelzwerge gibts bei den Schnuffelzwergen TOP Qualität, also klicken und kaufen

Ähnliche Themen

  1. Längerer Text wird im IE nicht richtig dargestellt?!
    Von Coulan im Forum HTML & CSS Forum
    Antworten: 10
    Letzter Beitrag: 10.06.2007, 00:31
  2. mein myspace wird mit dem IE nicht richtig dargestellt
    Von weißgradnix im Forum HTML & CSS Forum
    Antworten: 9
    Letzter Beitrag: 27.05.2007, 15:52
  3. Homepage wird im iE nicht richtig dargestellt
    Von Thommes im Forum HTML & CSS Forum
    Antworten: 2
    Letzter Beitrag: 02.03.2007, 00:35
  4. Tabellen größen werden von IE nicht richtig dargestellt
    Von pbc-a im Forum HTML & CSS Forum
    Antworten: 1
    Letzter Beitrag: 11.09.2006, 13:03
  5. HIIILLLLFFFEEEE!!! HP wird nicht richtig dargestellt!
    Von Toschi. im Forum HTML & CSS Forum
    Antworten: 15
    Letzter Beitrag: 29.02.2004, 17:37

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •