Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11

Thema: Verlinkte div box funktioniert im InternetExplorer nicht!?

  1. #1
    Teeny
    Registriert seit
    11.08.2009
    Beiträge
    25
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Frage Verlinkte div box funktioniert im InternetExplorer nicht!?

    Hallo,

    gerade arbeite ich an einem kleinen Internetauftritt: http://xxxxx.bplaced.net/website/index.html

    auf dieser Seite habe ich mehrere Fotos angeordnet, die man verschieben kann und dessen Bildunterschrift ein Hyperlink darstellt. Foto und Hyperlink sind in einer div box.

    Nach mehreren Tests habe ich die Objekte "Poster" und "Street Art" so editiert, dass man das Bild nur an den oberen 20px des Bildes verschieben kann und der Rest des Bildes durch eine darübergelegte div box als Hyperlink dient.

    In Firefox funktioniert das optimal. Beim Internet Explorer funktioniert der Hyperlink auf dem Bild leider nicht. Ist es möglich den Code so umzuschreiben, dass die Seite sowohl im Firefox als auch im Internet Explorer funktioniert?


    Vielen Dank!
    Michael

    ps: stört euch nicht an dem unaufgeräumten Code - die Seite ist noch in der Entstehungsphase.
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    König(in) Avatar von Grevas
    Registriert seit
    20.04.2009
    Ort
    In meiner Wohnung.
    Alter
    30
    Beiträge
    1.039
    Danke
    0
    Bekam 5 mal "Danke" in 5 Postings

    Standard AW: Verlinkte div box funktioniert im InternetExplorer nicht!?

    /edit:
    der Text im Grün war vorher, aber es geht auch einfacher...
    1.
    die höhe/breite beim Poster stimmen nicht so ganz
    2. das wäre das <div> für den Link beim Poster:
    HTML-Code:
    <div style="position: absolute; left: 0px; top: 20px; width: 100px; height: 80px; background: blue; opacity: 0.0; filter: Alpha(opacity=0);"> </div>
    Statt eines Bildes, reicht ein background + opacity (erste angabe für alle browser, 2te angabe extra für den IE...)

    Nimm ein transparentes Bild und stell es als Background des Divs das als link dienen soll, hab das ganze mal getestet - mit einem background-color tuts im IE, sollte also helfen... Wirst allerdings noch ein IE PNG fix brauchen, einfach googlen
    Geändert von Grevas (08.10.2009 um 01:14 Uhr)

  3. #3
    Teeny
    Themenstarter

    Registriert seit
    11.08.2009
    Beiträge
    25
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: Verlinkte div box funktioniert im InternetExplorer nicht!?

    Vielen Dank für Deine schnelle Hilfe. Habe jetzt einfach ein transparentes .gif als Hintergrund verwendet. Allerdings gibts noch ein kleines Problem: Im Internet Explorer wird über der DivBox mit dem transparenten Hintergrund trotz des funktionierenden Hyperlinks keine Hand sondern nur ein normaler Mauszeiger angezeigt. Wie bekomme ich den Hyperlink durch eine Hand als Mauszeiger gekennzeichnet? Oder macht es einen Unterschied, wenn ich eine .png als Hintergrund verwende?

  4. #4
    Teeny
    Themenstarter

    Registriert seit
    11.08.2009
    Beiträge
    25
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: Verlinkte div box funktioniert im InternetExplorer nicht!?

    ok, habe deinen editierten Beitrag noch nicht gelesen. Probiere ich gleich mal aus!

    Vielen Dank

  5. #5
    Teeny
    Themenstarter

    Registriert seit
    11.08.2009
    Beiträge
    25
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: Verlinkte div box funktioniert im InternetExplorer nicht!?

    so, habe beide Möglichkeiten ausprobiert. Beides funktioniert! Danke hierfür!

    Einen Schönheitsfehler gibt´s allerdings noch: Bei beiden Möglichkeiten (Poster - opacity; Street Art - transparentes.gif) erscheint über der verlinkten Fläche keine Hand als Mauszeiger. Kann man das noch hinbekommen?

    hier die aktualisierte seite:
    http://xxxxx.bplaced.net/website/index.html
    Geändert von mxxxx (08.10.2009 um 01:31 Uhr)

  6. #6
    König(in) Avatar von Grevas
    Registriert seit
    20.04.2009
    Ort
    In meiner Wohnung.
    Alter
    30
    Beiträge
    1.039
    Danke
    0
    Bekam 5 mal "Danke" in 5 Postings

    Standard AW: Verlinkte div box funktioniert im InternetExplorer nicht!?

    Klar kann man das, musst den cursor wieder ändern bei deinem link-div ;D

    /das ich an .gif nicht gedacht hab *kopfschüttel*

    cursor: pointer;

    da der isses *g*

  7. #7
    Teeny
    Themenstarter

    Registriert seit
    11.08.2009
    Beiträge
    25
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: Verlinkte div box funktioniert im InternetExplorer nicht!?

    jetzt klappt´s perfekt

    danke

  8. #8
    Meister(in)
    Registriert seit
    27.03.2009
    Ort
    Berlin
    Beiträge
    278
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: Verlinkte div box funktioniert im InternetExplorer nicht!?

    Nimm doch einfach ein a-tag und setze ein bild in diesen rein.
    Bsp:
    Code:
    <a href="" title=""><img alt=""></a>
    Geändert von thilda (12.10.2009 um 14:31 Uhr)

  9. #9
    König(in) Avatar von Grevas
    Registriert seit
    20.04.2009
    Ort
    In meiner Wohnung.
    Alter
    30
    Beiträge
    1.039
    Danke
    0
    Bekam 5 mal "Danke" in 5 Postings

    Standard AW: Verlinkte div box funktioniert im InternetExplorer nicht!?

    Zitat Zitat von thilda Beitrag anzeigen
    Nimm doch einfach ein a-tag und setze ein bild in diesen rein.
    Bsp:
    Code:
    <a href="" alt="" title=""><img></a>
    das hatten wir schon siehe transparentes bild...

  10. #10
    Meister(in)
    Registriert seit
    27.03.2009
    Ort
    Berlin
    Beiträge
    278
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: Verlinkte div box funktioniert im InternetExplorer nicht!?

    Nicht ganz... ihr legt immer ein Div über das Bild. Warum verlinkt ihr es nicht gleich komplett. Ein extra Container darüber zu stülpen der dann ein Link-attribut hat ist in meinen Augen zu viel des guten.

Ähnliche Themen

  1. Antworten: 6
    Letzter Beitrag: 12.09.2009, 21:02
  2. Verlinkte Dateien nicht anzeigen lassen
    Von Kwiboo im Forum HTML & CSS Forum
    Antworten: 2
    Letzter Beitrag: 18.12.2008, 16:29
  3. html code funkt. nicht mit dem internetexplorer
    Von marching drums im Forum HTML & CSS Forum
    Antworten: 6
    Letzter Beitrag: 25.06.2008, 20:30
  4. Durchpausung wird im Internetexplorer nicht angezeigt
    Von Jonas im Forum HTML & CSS Forum
    Antworten: 2
    Letzter Beitrag: 10.04.2007, 22:01
  5. internetexplorer lädt bild nicht
    Von furby im Forum HTML & CSS Forum
    Antworten: 1
    Letzter Beitrag: 10.09.2005, 16:54

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •