Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: ...encoding...probleme W3C...

  1. #1
    Meister(in) Avatar von rammstein
    Registriert seit
    21.05.2009
    Beiträge
    293
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard ...encoding...probleme W3C...

    Hallo,

    kann z.Z. meine Seite nicht über W3C validieren,
    sagt mir none encoding!

    Habe in <head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    muß da statt charset encoding rein und was ändert sich??? DANKE!!!
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Thonixx
    Gast

    Standard AW: ...encoding...probleme W3C...

    Hast du per PHP einen Header mitgeschickt?
    Welche Codierung hat dein File?
    Ich rate dir zu utf-8...

    Hier der PHP Header:
    PHP-Code:
    header("Content-Type: text/html; charset=utf-8"); 

  3. #3
    Interessierte/r
    Registriert seit
    09.08.2009
    Beiträge
    121
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: ...encoding...probleme W3C...

    Fürs senden davon hab ich vor kurzem übrigens was tolles gelesen, damit erspart man sich das einbauen in die PHP-Datei als header.

    Einfach eine .htaccess mit dem Inhalt
    Code:
    AddDefaultCharset UTF-8
    (für UTF-8 )

  4. #4
    Meister(in)
    Themenstarter
    Avatar von rammstein
    Registriert seit
    21.05.2009
    Beiträge
    293
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: ...encoding...probleme W3C...

    Hallo,

    ich hatte bißlang utf-8, bin aber wg. Schwierigkeiten Umlaute
    umgestiegen auf iso, und die Probleme waren behoben.
    Soll ich jetzt für Test umbauen oder gibt es anderen Check,
    wo ich auf iso bleiben kann???Danke!!!

    W3C nimmt ja im Grunde alles, kann es auch einstellen, wundert mich schon...

  5. #5
    König(in)
    Registriert seit
    07.02.2009
    Ort
    Leipzig
    Beiträge
    1.391
    Danke
    2
    Bekam 21 mal "Danke" in 20 Postings

    Standard AW: ...encoding...probleme W3C...

    Dem Test ist egal welchen Charset zu verwendest. Du musst nur auch die Zeichen passend zum im header angegebenen Zeichensatz verwenden. Wenn Du iso verwendest muss alles iso sein, wenn utf-8 dann utf-8.

    Im übrigen würde ich sagen, dass Du bei utf-8 genau das falsch gemacht hast: deine Umlaute und Sonderzeichen sind nicht utf-8 kodiert. Wenn Du die Umlaute in einem Texteditor schreibst stell in diesem Texteditor den Zeichensatz um. Für php gibt es auch entsprechende Funktionen zum kodieren in utf-8.

  6. #6
    Meister(in)
    Themenstarter
    Avatar von rammstein
    Registriert seit
    21.05.2009
    Beiträge
    293
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: ...encoding...probleme W3C...

    Ja, kapiert, gerade nachgeschaut, ich habe vor geraumer Zeit Zeichensatz
    in(bitte nicht auslachen) webspace php oder sql auf utf-8 gesetzt.
    iso gibt es da nicht, seiten sind aber alle iso??? Deßhalb wohl Probleme,
    möchte aber iso behalten??? stress...

  7. #7
    König(in)
    Registriert seit
    07.02.2009
    Ort
    Leipzig
    Beiträge
    1.391
    Danke
    2
    Bekam 21 mal "Danke" in 20 Postings

    Standard AW: ...encoding...probleme W3C...

    Dann musst Du diese Einstellungen wieder rückgängig machen. Wobei das bei sql durchaus aufwändig sein kann. Ich würde dir zu utf-8 raten.

  8. #8
    Meister(in)
    Themenstarter
    Avatar von rammstein
    Registriert seit
    21.05.2009
    Beiträge
    293
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: ...encoding...probleme W3C...

    Hi, habe jetzt Seite auf UTF-8 umgestellt,
    checkt Seite dennoch nicht...Fehler none encoding...
    PS: Habe kleinen Befehl in Seite, daß Quelltext nicht angezeigt wird, daran
    kanns doch wohl nicht liegen???
    Oder soll ich statt charset encoding setzen? danke...

  9. #9
    Interessierte/r
    Registriert seit
    09.08.2009
    Beiträge
    121
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: ...encoding...probleme W3C...

    Kopier mal die gesamte Fehlermeldung rein.

  10. #10
    Meister(in)
    Themenstarter
    Avatar von rammstein
    Registriert seit
    21.05.2009
    Beiträge
    293
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: ...encoding...probleme W3C...

    Hi, habe jetzt mit anderem Programm gecheckt-
    Fehler ist charset:none im http header
    Blöde Frage...wo finde ich den? Ist doch nicht <head>, weil da stimmt alles...
    also gegoogelt, hatte mire firefox schon gesagt...
    header, irgendwie nachrichtenübermittlung server-client,
    aber ich weiß nicht, wo...sorry(dummheit ist erblich, mein opa)
    Geändert von rammstein (30.08.2009 um 22:36 Uhr)

Ähnliche Themen

  1. mal wieder ein encoding-problem
    Von synaptic im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 9
    Letzter Beitrag: 30.08.2009, 14:12
  2. Encoding Probleme bei Gästen
    Von ::RMB:: im Forum Forum-Hilfe.de intern
    Antworten: 3
    Letzter Beitrag: 05.07.2008, 22:43
  3. css-probleme
    Von mattis_1 im Forum HTML & CSS Forum
    Antworten: 10
    Letzter Beitrag: 17.03.2008, 21:12
  4. UTF-8 Encoding Problem
    Von Mir nicht im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 0
    Letzter Beitrag: 02.05.2007, 17:43
  5. encoding
    Von Schwabsi im Forum HTML & CSS Forum
    Antworten: 2
    Letzter Beitrag: 21.04.2004, 13:18

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •