Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: kupu Installations Problem

  1. #1
    Martina
    Gast

    Standard kupu Installations Problem

    Halloechen,

    ich moechte kupu als WYWSIWYG editor fuer HTML Dokumente unter Zope 2 (kein Plone) verwenden.

    Zope Version (Zope 2.11.1-final, python 2.4.5, linux2)
    Python Version (2.4.5 (#1, Oct 13 2008, 13:47:2 [GCC 4.1.2 20070115
    (prerelease) (SUSE Linux)]
    System Platform linux2

    Ich habe FileSystemSite 2.1 und Kupu 1.3.5 in meinem Products Directory installiert. Nach Restart der Zope Instance habe ich einen neuen Punkt beim Add-Menu: 'kupu editor'. Wenn ich dann aber z.B. in meinem Wiki Folder das 'Add kupu editor' ausfuehre, bekomme ich folgende Meldung:


    Site Error

    An error was encountered while publishing this resource.

    ValueError
    Sorry, a site error occurred.

    Traceback (innermost last):

    * Module ZPublisher.Publish, line 202, in publish_module_standard
    * Module ZPublisher.Publish, line 150, in publish
    * Module Zope2.App.startup, line 252, in __call__
    * Module ZPublisher.Publish, line 119, in publish
    * Module ZPublisher.mapply, line 88, in mapply
    * Module ZPublisher.Publish, line 42, in call_object
    * Module Products.kupu.zope2, line 89, in manage_addKupuEditor
    * Module Products.kupu.zope2, line 77, in createKupuEditor

    ValueError

    Was mache ich falsch? Hat jemand eine Idee?

    Vielen Dank,
    Martina
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Meister(in)
    Registriert seit
    14.02.2008
    Ort
    München
    Beiträge
    456
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: kupu Installations Problem

    Kurze Gegenfrage,

    Kupu ist seit einiger Zeit eine Python-Libary, es als Zope2 Produkt im Produktsfolder zu installieren kann schon der Fehler sein.

    Wie hast du dein Zope Installiert? von Hand? via. Buildout?

    Durch die Libary kann es sein das du Abhängigkeiten nicht mitinstalliert hast die du für Kupu benötigst, die im Buildout automatisch mitgezogen werden.

    Gruss Pumukel
    Die beste Informationsquelle sind Leute, die versprochen haben, nichts weiterzuerzählen.

    Marcel Mart
    frz. Schriftsteller

  3. #3
    Martina
    Gast

    Standard AW: kupu Installations Problem

    Ich habe von Hand installiert. Hier sind die Kommandos zur Installation von Zope:


    Building Zope:
    --------------
    ./configure --prefix=/usr/users/cbb/zope-2.11.1
    --with-python=/usr/users/cbb/python/bin/python
    make
    make install

    Creating Zope Instance:
    -----------------------
    /usr/users/cbb/zope-2.11.1/bin/mkzopeinstance.py


    Starting Zope:
    --------------
    /usr/users/cbb/zope-2.11.1/instance/bin/runzope
    Configuration: /usr/users/cbb/zope-2.11.1/instance/etc/zope.conf



    Gruss,
    Martina

  4. #4
    Meister(in)
    Registriert seit
    14.02.2008
    Ort
    München
    Beiträge
    456
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: kupu Installations Problem

    Probier es doch mal mit buildout

    Code:
    easy_install ZopeSkel
    paster create -t plone3_buildout zope2.buildout
    Ja ich weiss du willst pures Zope 2 keine Plone


    lass mit deinem Python
    Code:
    /usr/users/cbb/python/bin/python bootstrap.py
    laufen
    pass die buildout.cfg an auf:
    Code:
    [buildout]
    
    parts =
        plone
        zope2
        productdistros
        instance
        zopepy
        
    develop =
    
    find-links =
        http://dist.plone.org
        http://dist.plone.org/thirdparty  
        http://download.zope.org/ppix/
        http://download.zope.org/distribution/
        http://effbot.org/downloads
    
    # Add additional egg download sources here. dist.plone.org contains archives
    # of Plone packages.
    eggs =
        elementtree
        Products.kupu.zope2
    
        
    [zope2]
    recipe = plone.recipe.zope2install
    url = http://www.zope.org/Products/Zope/2....11.2-final.tgz
    
    [productdistros]
    recipe = plone.recipe.distros
    urls =
    nested-packages =
    version-suffix-packages =
    
    [instance]
    recipe = plone.recipe.zope2instance
    zope2-location = ${zope2:location}
    user = admin:password
    http-address = 8080
    debug-mode = on
    verbose-security = on
    
    # If you want Zope to know about any additional eggs, list them here.
    # This should include any development eggs you listed in develop-eggs above,
    # e.g. eggs = ${buildout:eggs} my.package
    eggs =
        ${buildout:eggs}
    
    # If you want to register ZCML slugs for any packages, list them here.
    # e.g. zcml = my.package my.other.package
    zcml = Products.kupu.zope2
    
    products =
        ${buildout:directory}/products
        ${productdistros:location}
    
    [zopepy]
    recipe = zc.recipe.egg
    eggs = ${instance:eggs}
    interpreter = zopepy
    extra-paths = ${zope2:location}/lib/python
    scripts = zopepy
    zum Schluss das buildout laufen lassen:
    Code:
    ./bin/buildout
    und Zope mit dem Befehl:
    Code:
    ./bin/instance fg
    das ist ein Link auf zopectl

    Schau mal ob es dann funktioniert. Ich hoffe es für dich.

    Gruss Pumukel
    Geändert von Pumukel (03.11.2008 um 15:08 Uhr)
    Die beste Informationsquelle sind Leute, die versprochen haben, nichts weiterzuerzählen.

    Marcel Mart
    frz. Schriftsteller

  5. #5
    Martina
    Gast

    Standard AW: kupu Installations Problem

    Sorry, bin erst jetzt dazu gekommen, mir Deinen Tipp anzuschauen.

    Dazu habe ich dann auch direket Fragen:

    Welches bootstrap.py soll ich nehmen. Ich habe da mehrere:

    linux:~/test/Zope-2.11.1-final> find . -name bootstrap.py
    ./lib/python/zope/session/bootstrap.py
    ./lib/python/zope/app/appsetup/bootstrap.py
    ./lib/python/zope/app/principalannotation/bootstrap.py
    ./lib/python/zope/error/bootstrap.py


    Ich habe mir die Installation mit buildout angesehen. Das hoert sich aber nach einer Windows-Installation an (zumindest laut README). Ich habe aber ein SuSE Linux.

    Gruesse,
    Martina

  6. #6
    Meister(in)
    Registriert seit
    14.02.2008
    Ort
    München
    Beiträge
    456
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: kupu Installations Problem

    Hallo,

    ok ich habe eine Zeile vergessen, mein Fehler. Man muss natürlich nach dem erstellen der Buildouts-Sekletons erstmal ins Buildout verzeichnis wechseln. hier also
    Code:
    cd zope2.buildout
    Buildout ist eigentlich Plattformunabhängig, bloss habe ich selber bisher die besten erfahrungen in einem Unix/Linux basierten System gemacht, nutze selber primär Debian GNU/Linux oder Solaris.

    Dein Suse/Linux ist also sehr gut passend. Ich weiss leider nicht ob easy_install bei dir schon installiert ist.

    ggf. muss man das noch vorher tun.

    Code:
    wget -q http://peak.telecommunity.com/dist/ez_setup.py
    /usr/users/cbb/python/bin/python ez_setup.py
    Danach hast du easy_install verfügbar und kannst alles recht einfach in Python installieren.

    der befehl
    Code:
    paster create -t plone3_buildout zope2.buildout
    legt dir ein unterberzeichnis zope2.buildout in dem Verzeichnis an wo du im Moment bist.
    Das Buildoutverzeichnis beinhaltet dann drei Verzeichnisse src, products und var, sowie die dateien buildout.cfg, bootstrap.py sowie mehrere README.txt .

    Also dort das bootstrap.py laufen lassen, ansonsten der Anweisung von oben folgen.

    Gruss Pumukel
    Die beste Informationsquelle sind Leute, die versprochen haben, nichts weiterzuerzählen.

    Marcel Mart
    frz. Schriftsteller

  7. #7
    Martina
    Gast

    Standard AW: kupu Installations Problem

    Sorry, ich war heute frueh auch noch nicht auf geistiger Hoehe. In der Zwischenzeit habe ich grob verstanden wie das mit dem Buildout funktioniert. ez_setup hatte ich mir gerade schon geholt und installiert. Jetzt versuch ich mal mein Glueck.

    Mehr spaeter ....

    Martina

  8. #8
    Martina
    Gast

    Standard AW: kupu Installations Problem

    Sieht schon fast gut aus, aber irgendetwas fehlt mir noch:


    .....
    Installing productdistros.
    Installing instance.
    Getting distribution for 'elementtree'.
    zip_safe flag not set; analyzing archive contents...
    Got elementtree 1.2.7-20070827-preview.
    Couldn't find index page for 'Products.kupu.zope2' (maybe misspelled?)
    Getting distribution for 'Products.kupu.zope2'.
    While:
    Installing instance.
    Getting distribution for 'Products.kupu.zope2'.
    Error: Couldn't find a distribution for 'Products.kupu.zope2'.


    Du hast sicher noch einen guten Tipp, damit das auch noch klappt.

    Gruesse,
    Martina

  9. #9
    Meister(in)
    Registriert seit
    14.02.2008
    Ort
    München
    Beiträge
    456
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard AW: kupu Installations Problem

    Ja habe ich, weil ich es verbockt habe, Entschuldigung

    Ich habe einfach aufgrund deiner anfänglichen Posting den Traceback genommen und den Packetnamen von Kupu geraten. der ist natürlich nicht Products.Kupu.zope2 sondern nur Products.kupu
    was du dir noch ansehen kannst sind die anderen WYSIWYG Editoren:
    Products.FCKeditor Products.TinyMCE
    einfach jeweils in eggs und zcml eintragen.

    Gruss Pumukel
    Die beste Informationsquelle sind Leute, die versprochen haben, nichts weiterzuerzählen.

    Marcel Mart
    frz. Schriftsteller

  10. #10
    Martina
    Gast

    Standard AW: kupu Installations Problem

    So, ein Stueck weiter. Kupu ist jetzt gefunden worden.

    ABER, es gibt unterwegs ganz viele Fehlermeldungen dieser Art:

    ........
    File "build/bdist.linux-i686/egg/Products/CMFTopic/skins/zpt_topic/topic_edit_control.py", line 9
    return context.setStatus(True, _(u'Topic changed.'))
    SyntaxError: 'return' outside function
    File "build/bdist.linux-i686/egg/Products/CMFTopic/skins/zpt_topic/topic_edit_form.py", line 10
    return
    SyntaxError: 'return' outside function
    File "build/bdist.linux-i686/egg/Products/CMFTopic/skins/zpt_topic/topic_view.py", line 33
    return context.topic_view_template(**decode(options, script))
    SyntaxError: 'return' outside function
    File "/usr/users/cbb/zope2.buildout/eggs/tmppl8Hom/Products.CMFTopic-2.1.2-py2.4.egg/Products/CMFTopic/skins/zpt_topic/topic_edit_control.py", line 9
    return context.setStatus(True, _(u'Topic changed.'))
    SyntaxError: 'return' outside function
    File "/usr/users/cbb/zope2.buildout/eggs/tmppl8Hom/Products.CMFTopic-2.1.2-py2.4.egg/Products/CMFTopic/skins/zpt_topic/topic_edit_form.py", line 10
    return
    SyntaxError: 'return' outside function
    File "/usr/users/cbb/zope2.buildout/eggs/tmppl8Hom/Products.CMFTopic-2.1.2-py2.4.egg/Products/CMFTopic/skins/zpt_topic/topic_view.py", line 33
    return context.topic_view_template(**decode(options, script))
    SyntaxError: 'return' outside function
    Got Products.CMFTopic 2.1.2.
    .........



    Kann man die ignorieren???


    Ausserdem laufe ich auf einen Versionskonflikt. Kann man da noch irgendwie nachhelfen?

    .......
    Getting distribution for 'zope.app.publisher'.
    Got zope.app.publisher 3.5.1.
    While:
    Installing instance.
    Error: There is a version conflict.
    We already have: zope.component 3.5.1
    but five.localsitemanager 1.0c1 requires 'zope.component<3.5dev'.

    Wie heisst der nette Spruch: Muehsam ernaehrt sich das Eichhoernchen!!!

    Schon mal vielen Dank fuer Deine Hilfe,
    Martina

Ähnliche Themen

  1. Kupu Problem mit Bildern und internen Links
    Von Kreativling im Forum Zope & Plone - das deutsche Hilfeforum
    Antworten: 0
    Letzter Beitrag: 11.03.2008, 15:12
  2. Installations Problem ?!
    Von silentsystem im Forum Computer - Internet Forum
    Antworten: 7
    Letzter Beitrag: 28.11.2007, 14:13
  3. FORUMS-INSTALLATIONS PROBLEM
    Von EDK im Forum Computer - Internet Forum
    Antworten: 6
    Letzter Beitrag: 09.06.2007, 11:14
  4. Plugin Installations-Aufforderung
    Von speedo im Forum HTML & CSS Forum
    Antworten: 0
    Letzter Beitrag: 30.09.2006, 15:32
  5. Windows Installations Problem
    Von yannic91 im Forum Computer - Internet Forum
    Antworten: 2
    Letzter Beitrag: 17.09.2006, 19:27

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •