Ergebnis 1 bis 2 von 2

Thema: RewriteRule funktioniert nicht.

  1. #1
    Interessierte/r
    Registriert seit
    18.08.2007
    Beiträge
    112
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard RewriteRule funktioniert nicht.

    Hi,

    ich habe folgendes Problem ich würde gerne auf meiner Seite
    folgenden Link aufrufen http://www.xyz.de/test/newsletter
    (ohne Dateiendung) diese soll auch in der Adressleiste des Browsers stehen
    intern soll aber auf http://www.xyz.de/test/newsletter.php geleitet werden.

    Ich hatte dazu folgendes in die htaccess geschrieben:

    Code:
    RewriteEngine On
    
    RewriteBase /
    
    RewriteRule ^newsletter$ newsletter.php [L]
    Wenn ich nun im Browser
    http://www.xyz.de/test/newsletter.php eingebe kommt aber
    "Objekt nicht gefunden Error 404" ...

    Was habe ich falsch gemacht? (Die newsletter.php existiert natürlich)

    Vielen Dank schonmal


    €dit:

    Sorry Leute lag an der RewriteBase
    Admin bitte Thread löschen.
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!
    Geändert von VivaLosTioz (30.09.2008 um 17:39 Uhr)

  2. #2
    Jedi Ritter Avatar von Dodo
    Registriert seit
    26.04.2008
    Ort
    Wien
    Alter
    27
    Beiträge
    3.774
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings
    Blog-Einträge
    1

    Standard

    Code:
    RewriteEngine On
    RewriteRule /([-a-z0-9A-Z_]+)$ $1.php
    Dein Fehler liegt daran, dass du / als startpunkt nimmst.
    Slash heißt jedoch der ursprung des Servers. also nicht www.xyz.de/test/ sondern www.xyz.de
    Something big is coming. And there will be pirates and ninjas and unicorns...

Ähnliche Themen

  1. modrewrite - rewriterule
    Von FaFoo im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 4
    Letzter Beitrag: 16.05.2008, 22:59
  2. DNS funktioniert nicht!
    Von incendium im Forum Webhoster - Provider - (free) Webspace - Server - Domain
    Antworten: 4
    Letzter Beitrag: 29.03.2008, 12:02
  3. Mic-In funktioniert nicht
    Von Knüps im Forum Computer - Internet Forum
    Antworten: 1
    Letzter Beitrag: 06.02.2008, 20:19
  4. GIF funktioniert in IE nicht
    Von arnim im Forum HTML & CSS Forum
    Antworten: 5
    Letzter Beitrag: 28.06.2007, 20:57
  5. dtd und css in php funktioniert im IE nicht!!!
    Von im Forum HTML & CSS Forum
    Antworten: 1
    Letzter Beitrag: 09.06.2007, 16:33

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •