Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 15

Thema: Nach Serverumzug - Scriptfehler

  1. #1
    Unregistriert
    Gast

    Standard Nach Serverumzug - Scriptfehler

    Hallo,

    Ich bin Kunde bei Hosteurope, und habe da vom Webspace auf einen VServer gewechselt, Ich habe alle Daten vom Webspace runtergeladen und danach wieder auf den Server geuppdt, das gleiche mit den sql datenbanken, und sonst nichts verändert. Als ich eines meiner Scripte danach öffnete, sah ich das irgendwie so komisch Zeichen da jezt drin sind, das Layout gesprengt, und anscheinend werden keine Umlaute mehr richtig angezeigt.

    Ich hoffe ich darf den Link zum Ansehen posten, damit Ihr euch ein Bild davon machen könnt:

    http://www.love4people.eu

    Weiß da vielleicht jemand weiter=?
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    König(in) Avatar von sudeki05
    Registriert seit
    04.05.2006
    Ort
    Hamburg
    Alter
    28
    Beiträge
    1.435
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Du solltest erstmal ein richtigen Doctype einbauen, GANZ OBEN auf der Seite:

    HTML-Code:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
    "http://www.w3.org/TR/html4/loose.dtd">
    Dann könntest du dein Charset umstellen im header:
    HTML-Code:
    <meta http-equiv="content-type" content="text/html; charset=ISO-8859-1">
    Dann sollten die Umlaute auch wieder richtig angezeigt werden

    Problems with Windows? - Reboot
    Problems with UNIX? - Be Root

  3. #3
    Bandit
    Gast

    Standard

    Doctype ist drin, aber an der falschen Stelle.

  4. #4
    Unregistriert
    Gast

    Standard

    Ich habe das jezt mal soweit bereinigt, wie ihr gesagt hab, aber verändert hat sich leider nichts.

  5. #5
    Bandit
    Gast

    Standard

    Wo kommen die ganzen Daten her? Aus der DB? Wenn ja, Zeichensatz/Kollation richtig eingestellt?

  6. #6
    Unregistriert
    Gast

    Standard

    hey, ich glaube das ist es!
    am webspace ist der Zeichensatz auf utf8_unicode_ci
    am server ist er auf utf8_general_ci , eingestellt,

    sorry die frage aber wie ändere ich den Zeichensatz? wenn ich im Dropdownmenü einen anderen wähle, springt er immer wieder zurück.

  7. #7
    Bandit
    Gast

    Standard

    Zitat Zitat von Unregistriert Beitrag anzeigen
    wenn ich im Dropdownmenü einen anderen wähle, springt er immer wieder zurück.
    Wovon redest du?

  8. #8
    Unregistriert
    Gast

    Standard

    ah sorry,

    ich meinte im phpmyadmin menü!

    dort ist bei "Zeichensatz / Kollation der MySQL-Verbindung:"
    beim Webspace utf8_unicode_ci und beim server utf8_general_ci eingestellt, ich hoffe jezt ist es verständlicher.

  9. #9
    Bandit
    Gast

    Standard

    Lösche die DB und lege sie neu an, das sollte gehen.

  10. #10
    Unregistriert
    Gast

    Standard

    so, habe nun eine DB angelegt, den Zeichencode geändert, aber leida bleibt das Ergebniss gleich....

Ähnliche Themen

  1. php nach mp3
    Von ichundwir im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 2
    Letzter Beitrag: 23.02.2007, 21:10
  2. Hompage nach up. erst nach Aktualisieren auf dem Laufenden
    Von mad-byte im Forum HTML & CSS Forum
    Antworten: 4
    Letzter Beitrag: 06.01.2007, 12:25
  3. Automatisches Abmelden nach Programmende, bz nach Zeitablauf
    Von der bastler im Forum Computer - Internet Forum
    Antworten: 6
    Letzter Beitrag: 13.11.2006, 15:35
  4. Serverumzug vom Webhoster und nun das...
    Von andwo im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 3
    Letzter Beitrag: 07.09.2006, 18:07
  5. Scriptfehler!?!
    Von AAY1976 im Forum HTML & CSS Forum
    Antworten: 7
    Letzter Beitrag: 16.05.2006, 11:08

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •