Ergebnis 1 bis 6 von 6

Thema: UTF-8 wird vollkommen ignoriert

  1. #1
    Forum Guru Avatar von synaptic
    Registriert seit
    20.06.2007
    Ort
    Butzbach-Wiesental
    Beiträge
    10.901
    Danke
    45
    Bekam 48 mal "Danke" in 46 Postings
    Blog-Einträge
    1

    Standard UTF-8 wird vollkommen ignoriert

    http://kkw-forum.de/array/index.php

    das is die array-übung mit der ich mich heute beschäftigt habe.. das ding war vorher ein javascript und ich habs umgesetzt zu php

    Code:
    <?php
    header&#40;"content-type&#58; text/html;charset=utf-8"&#41;;
    ?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http&#58;//www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http&#58;//www.w3.org/1999/xhtml" xml&#58;lang="en" lang="en">
    <head>
    	<title>Arrays in PHP</title>
    </head>
    eigentlich sollte damit doch utf-8 als encoding funktionieren oder nicht?
    ich habs auch schon mit nem metatag probiert... der firefox zeigt auch an dass ich im utf-8 modus bin, jedoch werden umlaute als "?" in einer schwarzen raute dargestellt..

    weiß da jemand abhilfe?

    also bei manchen umlauten die statisch sind hab ich entities benutzt...
    gebt mal das wort "ülälölß" ein, kodiert und dekodiert dann seht ihr das ergebnis
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!
    KEIN support via pn, email, messenger oder falsch geposteten threads
    Futter für deine Schnuffelzwerge gibts bei den Schnuffelzwergen TOP Qualität, also klicken und kaufen

  2. #2
    Shogun Avatar von DarkSyranus
    Registriert seit
    28.03.2006
    Ort
    ::1/128
    Alter
    25
    Beiträge
    3.446
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings
    Blog-Einträge
    1

    Standard

    Nur mal so als Frage, speicherst du dei Datei auch als UFT8 ab?

  3. #3
    Forum Guru
    Themenstarter
    Avatar von synaptic
    Registriert seit
    20.06.2007
    Ort
    Butzbach-Wiesental
    Beiträge
    10.901
    Danke
    45
    Bekam 48 mal "Danke" in 46 Postings
    Blog-Einträge
    1

    Standard

    öhhm da frgaste was.. ich check das mal und schreib nen edit

    edit: nee war/is auf ANSI .

    jedoch wenn ich das ding umschalte auf utf-8 dann hab ich das problem, dass meine chiffrierung nicht mehr funktioniert...

    hab hier mal ne alternative: http://badadmin.hopto.org/others/index.php

    ich kann den anderen link nur mit ner komplett funktionierenden version updaten...
    KEIN support via pn, email, messenger oder falsch geposteten threads
    Futter für deine Schnuffelzwerge gibts bei den Schnuffelzwergen TOP Qualität, also klicken und kaufen

  4. #4
    Azubi(ne)
    Registriert seit
    20.06.2008
    Ort
    Paderborn
    Beiträge
    81
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    "Heute ist: Donnerstag, der 07. September 2008"
    Hoffentlich nicht!

    hast du auf utf-8 ohne bom geändert? bei utf-8 mit bom dürfte der header("content-type: text/html;charset=utf-8"); nicht funktionieren, weil vorher schon eine ausgabe an den browser kommt. allerdings solltest du dann auch eine entsprechende fehlermeldung kriege.

  5. #5
    Forum Guru
    Themenstarter
    Avatar von synaptic
    Registriert seit
    20.06.2007
    Ort
    Butzbach-Wiesental
    Beiträge
    10.901
    Danke
    45
    Bekam 48 mal "Danke" in 46 Postings
    Blog-Einträge
    1

    Standard

    näh ich habs eigentlich dann ohne BOM
    und joa des mit dem Datum war nur so hingefrickelt
    wollt des chiffrier-dings richtig haben.. jedoch klappt das mit den umlauten gar nich mehr, sobald utf-8 funzt..hab also via notepad++ des encoding geändert.. werd mich wohl nichmal damit auseinandersetzen müssen.
    ich mag php einfach nich, will und muss es dennoch können -.-
    selbst das
    Code:
    mb_strtoupper
    funktioniert bei den umlauten und utf-8 nich mehr...

    naja der link badadmin..bla is erstma tot bis ich morgen wieder on bin
    KEIN support via pn, email, messenger oder falsch geposteten threads
    Futter für deine Schnuffelzwerge gibts bei den Schnuffelzwergen TOP Qualität, also klicken und kaufen

  6. #6
    Forum Guru
    Themenstarter
    Avatar von synaptic
    Registriert seit
    20.06.2007
    Ort
    Butzbach-Wiesental
    Beiträge
    10.901
    Danke
    45
    Bekam 48 mal "Danke" in 46 Postings
    Blog-Einträge
    1

    Standard

    also ich hab heute mal jemanden aus der firma über die übung drübergucken lassen und nach zwei std kam auch er zu keinem ergebnis (er arbeitet seit 7 jahren mit php)

    aber evtl findet sich ja hier jemand, der plan, ne idee oder sowas hat..
    unter http://kkw-forum.de/array/ findet sich die im ansi-encoding gespeicherte version, die eigentlich soweit richtig funktioniert, jedoch bei der ausgabe utf-8 ignoriert!!

    ich hab dann mal das ganze konvertiert, gespeichert und ausprobiert, jedoch wurd da nichts mehr chiffriert oder dechiffriert, was umlaute beinhaltet hat!

    im anhang findet ihr eine rar-file, in der die ansiversion, die utf-8-version und auch eine test.php zu finden ist (die test.php hatte mein arbeitskollege angelegt)

    wäre schön, wenn jemand die zeit findet um sich das ganze mal anzugucken


    DANKE
    Angehängte Dateien Angehängte Dateien
    KEIN support via pn, email, messenger oder falsch geposteten threads
    Futter für deine Schnuffelzwerge gibts bei den Schnuffelzwergen TOP Qualität, also klicken und kaufen

Ähnliche Themen

  1. Else Anweisung wird ignoriert? (Anfängerfrage)
    Von SniperWolf im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 15
    Letzter Beitrag: 02.01.2008, 18:24
  2. IE7 ignoriert page-break-before
    Von jogisarge im Forum HTML & CSS Forum
    Antworten: 0
    Letzter Beitrag: 16.02.2007, 21:35
  3. Safari (Mac) ignoriert Zeilenlänge bei Text
    Von bjilton0 im Forum HTML & CSS Forum
    Antworten: 0
    Letzter Beitrag: 15.01.2007, 20:48
  4. FF ignoriert Div Container
    Von im Forum HTML & CSS Forum
    Antworten: 2
    Letzter Beitrag: 17.04.2006, 22:09
  5. feste bereite von td wird ignoriert!
    Von jacko im Forum HTML & CSS Forum
    Antworten: 1
    Letzter Beitrag: 25.12.2004, 19:28

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •