Ergebnis 1 bis 4 von 4

Thema: <div> Probleme mit z-index und FF

  1. #1
    LoLeedo
    Gast

    Standard <div> Probleme mit z-index und FF

    hallo liebe gemeinde =)

    vor kurzem habe ich angefangen in HTML eine kleine HP zu basteln doch mittlerweile bin ich an einem punkt angekommen an dem ich nichtmehr weiter komme!
    meine Homepage möchte ich auf grund barriere freier programmierung und einer leichten abneiging gegen frames aus div-elementen aufbauen.

    Wenn man meine seite mit Opera aufruft ist alles top, menu funktioniert (soweit ziele der buttons angegeben) und sieht auch "gut" aus, öffnet man das ganze im IE gehts damit los das der mit meinen z-index angaben nicht klar zu kommen schein! Im FF siehts auch gut aus, doch sofern ich meinen inhalt, der vor dem hintergrundbild angezeigt werden soll, über css ein position attribut zuweise ist das menu nichtmehr bedienbar. Ich hab jetz alles mir bekannte versucht und bin am verzweifeln!

    plsHelp mfg

    hier der code:
    Code:
    <html>
    <body scroll="no">
    	
    	<style type="text/css">
    			
    			body &#123;
    				
    				background-color&#58; black;
    				overflow&#58; hidden;
    					
    								&#125;
    			
    			#hintergrund &#123;
    				
    				position&#58; absolute;
    				margin-top&#58; 2%;
    				margin-right&#58; 15%;
    				margin-bottom&#58; 10%;
    				margin-left&#58; 15%;
    				height&#58; 100%;
    				width&#58; 70%;
    				z-index&#58; 1;
    				&#125;
    			
    			#menu &#123;
    				
    				position&#58; absolute;
    				
    				margin-top&#58; 15%;
    				margin-left&#58; 1%;
    				z-index&#58; -7;				
    								
    				&#125;
    			
    			#logo &#123;
    				
    				text-align&#58; center;
    				margin-top&#58; 2%;
    				z-index&#58; 2;
    				
    				&#125;
    			
    			#inhalt &#123;
    				
    				position&#58; fixed;
    				overflow&#58; auto;
    				color&#58; white; 
    				padding&#58; 100px 100px 100px 300px;
    				z-index&#58; 3;
    				height&#58; 100%;
    				width&#58;100%;
    				&#125;
    						
    			</style>
    			
    	
    	<div id="logo">
    		[img]../PICTURE/CoD2_2.jpg[/img]
    	</div>
    		
    		<div>
    			[img]../PICTURE/bg2.gif[/img]</p>
    		</div>
    		
    		<div>
    			<OBJECT id="menu" classid="clsid&#58;D27CDB6E-AE6D-11cf-96B8-444553540000"
     codebase="http&#58;//download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0"
     WIDTH=125 HEIGHT=370>
    <PARAM NAME=movie VALUE="../MENU/menu.swf?tarframe=_self&exbackground=00FF00&makenavfield0=Home&makenavurl0=../HTML/kontakt.html&makenavfield1=About&makenavurl1=../HTML/clan.html&makenavfield2=Member&makenavurl2=../HTML/member.html&makenavfield3=ClanWars&makenavurl3=../HTML/cw.html&makenavfield4=Kontakt&makenavurl4=../HTML/kontakt.html&makenavfield5=Gallerie&makenavurl5=../HTML/gallerie.html&makenavfield6=Downloads&makenavurl6=../HTML/downloads.html&makenavfield7=Guestbook&makenavurl7=../HTML/guestbook.html&makenavfield8=Forum&makenavurl8=../HTML/forum.html&makenavfield9=Games&makenavurl9=../HTML/games.html">
    <PARAM NAME=loop VALUE=false>
    <PARAM NAME=menu VALUE=false>
    <PARAM NAME=quality VALUE=high>
    <PARAM NAME=scale VALUE=noborder>
    <PARAM NAME=salign VALUE=LT>
    <PARAM NAME=wmode VALUE=transparent>
    <PARAM NAME=bgcolor VALUE=#000000>
    
    <EMBED src="../MENU/menu.swf?tarframe=unten&exbackground=00FF00&makenavfield0=Home&makenavurl0=../HTML/news.html&makenavfield1=About&makenavurl1=../HTML/clan.html&makenavfield2=Member&makenavurl2=../HTML/member.html&makenavfield3=ClanWars&makenavurl3=../HTML/cw.html&makenavfield4=Kontakt&makenavurl4=../HTML/kontakt.html&makenavfield5=Gallerie&makenavurl5=../HTML/gallerie.html&makenavfield6=Downloads&makenavurl6=../HTML/downloads.html&makenavfield7=Guestbook&makenavurl7=../HTML/guestbook.html&makenavfield8=Forum&makenavurl8=../HTML/forum.html&makenavfield9=Games&makenavurl9=../HTML/games.html" loop=false menu=false quality=high scale=noborder salign=LT wmode=transparent bgcolor=#000000  WIDTH=125 HEIGHT=370 TYPE="application/x-shockwave-flash" PLUGINSPAGE="http&#58;//www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash"></EMBED>
    
    </OBJECT>
    		</div>
    	
    	<div id="inhalt" >
    		
    		blablablabla
    		
    
    		blablablabla
    		
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    blablablabla
    		
    </div>
    	
    </body>
    </html>
    [/code]
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Interessierte/r
    Registriert seit
    04.12.2005
    Beiträge
    133
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    moin ...

    du solltest nicht nur barrierefrei sondern auch etwas standardkonformer arbeiten. So sind die Fehler schon vorprogrammiert

    gruß ...

  3. #3
    LoLeedo
    Gast

    Standard

    Ich weiß das das nicht standartkonform ist, doch ich bin kein sonderlicher profi was das angeht -.- ... die seite sollte erstmal nur funktionieren (ich hoffe auf den guten geist der parser ) das validieren und entruempeln des codes wollte ich nach moeglichkeit auf später verschieben

  4. #4
    Azubi(ne)
    Registriert seit
    20.06.2008
    Beiträge
    64
    Danke
    2
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Zitat Zitat von LoLeedo
    das validieren und entruempeln des codes wollte ich nach moeglichkeit auf später verschieben
    Wieviele Fehler willst Du noch einbauen?

    Übrigens ist ein Flash-Menü keinesfalls Barrierefrei. Wer keinen Flashplayer installiert hat, so wie ich zur Zeit, wird mit deiner HP nix anfangen können.

    Was gültige HTML-Dokumente angeht, vielleicht hilft dir das hier weiter:
    http://webmasterbuch.de/html-seiten-...-schreiben.htm

    Setze erstmal nen gültigen Doctype (das ist das mindeste was sein muss) und dann mal sehen ob schon einige Darstellungsfehler sich erübrigt haben.

Ähnliche Themen

  1. z-index IE7
    Von FaFoo im Forum HTML & CSS Forum
    Antworten: 4
    Letzter Beitrag: 06.01.2008, 17:27
  2. z-Index Probleme mit Netscape
    Von Chris1505 im Forum HTML & CSS Forum
    Antworten: 3
    Letzter Beitrag: 08.08.2007, 16:34
  3. Index of
    Von Herny im Forum HTML & CSS Forum
    Antworten: 1
    Letzter Beitrag: 15.12.2004, 23:40
  4. index.html die auf index.php verweist?
    Von mondeo im Forum HTML & CSS Forum
    Antworten: 1
    Letzter Beitrag: 10.11.2004, 22:17
  5. index.php , wieder probleme.....
    Von gelöschter User im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 6
    Letzter Beitrag: 06.11.2004, 11:59

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •