Ergebnis 1 bis 7 von 7

Thema: MySQL-Befehl wird nicht korrekt ausgeführt

  1. #1
    Anthony
    Gast

    Standard MySQL-Befehl wird nicht korrekt ausgeführt

    Hallo,
    ich bin noch sehr neu was MySQL mit PHP anbelangt, und hoffe das mit jemand helfen kann. Kürzlich machte ich diesen Code, doch leider zeigt er einfach nicht das richtige an... Was habe ich daran falsch gemacht?
    Code:
    <?php
    mysql_connect&#40;"localhost", "web1", "xxx"&#41;or die&#40;"Fehler!"&#41;;
    mysql_select_db&#40;"test"&#41;or die&#40;"Fehler!"&#41;;
    
    $sql="SELECT * FROM artikel_inhalt WHERE title='$title'";
    $result=mysql_query&#40;$sql&#41;;
    
    while&#40;$rows=mysql_fetch_array&#40;$result&#41;&#41;&#123;
    
    $title=$_GET&#91;'title'&#93;;
    ?>
    <? echo $rows&#91;'inhalt'&#93;; ?>
    <?
    &#125;
    
    mysql_close&#40;&#41;;
    ?>
    Herzlichen Dank!
    Gruss[/code]
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    der/die Göttliche Avatar von jojo87
    Registriert seit
    23.03.2007
    Ort
    Leipzig
    Alter
    30
    Beiträge
    3.131
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Was soll er denn anzeigen bzw. was passiert denn genau? schalte mal error_reporting an.

    Gruß,
    Jojo

  3. #3
    Kaiserliche Hoheit Avatar von No0ob
    Registriert seit
    02.01.2006
    Ort
    Nähe Frankfurt
    Beiträge
    1.500
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    $title wird erst in der while-Schleife deklariert, wo es total falsch ist.
    Dadurch hat es in der Query keinen Wert.

  4. #4
    Gast

    Standard

    Ach so - also muss ich das vor die Schleife setzen.
    Herzlichen Dank, für deine schnelle und prägnante Antwort.

  5. #5
    Gast

    Standard

    Hallo, ich nochmals

    Es funktioniert immer noch nicht richtig.
    Also, das Ziel ist folgendes:
    Man gibt die Domain ein (http://www.amg.li/news/artikel_inhal...title=artikel1)
    und es kommt der artikel, welcher von der datenbank abgerufen wird. Das passiert aber auch nicht, nachdem man $title vor die Schleife setzte. Was muss ich da denn noch machen?

  6. #6
    Bandit
    Gast

    Standard

    Code:
    <?php
      if &#40;isset&#40;$_GET&#91;'title'&#93;&#41;&#41;
      &#123;
         mysql_connect&#40;"localhost", "web1", "xxx"&#41; or 
            die&#40;"Fehler!"&#41;;
            
         mysql_select_db&#40;"test"&#41; or 
           die&#40;"Fehler!"&#41;;
           
         $title = mysql_real_escape_string&#40;$_GET&#91;'title'&#93;&#41;;
         
         $sql = "SELECT 
                   inhalt
                 FROM 
                   artikel_inhalt 
                 WHERE 
                   title='$title'";
                   
         $result = mysql_query&#40;$sql&#41; or
            die &#40;"MySQL-Fehler&#58; " . mysql_error&#40;&#41;&#41;;
    
         if &#40;mysql_num_rows&#40;$result&#41;&#41;
         &#123;
            while&#40; $rows = mysql_fetch_array&#40;$result&#41;&#41;
            &#123;
               echo $rows&#91;'inhalt'&#93;;
            &#125;
         &#125;
         else
           echo "Keine Treffer vorhanden";
    
         mysql_close&#40;&#41;;
      &#125;
      else
      &#123;
          echo "Kein Parameter vorhanden";
      &#125;
    ?>

  7. #7
    Gast

    Standard

    Vielen, vielen herzlichen Dank! Diesen Code wer'd ich einmal genau anschauen - da kann ich sicher viel lernen.

Ähnliche Themen

  1. MySQL-Befehl wird nicht ausgeführt
    Von im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 8
    Letzter Beitrag: 02.07.2008, 18:34
  2. UPDATE wird nicht korrekt ausgefhührt
    Von Alfons Reinbühl im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 2
    Letzter Beitrag: 31.05.2008, 20:26
  3. PHP Website wird von IE nicht korrekt angezeigt
    Von klsa12 im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 4
    Letzter Beitrag: 23.11.2007, 13:10
  4. Iframe wird nicht korrekt angezeigt
    Von gurisingh im Forum HTML & CSS Forum
    Antworten: 4
    Letzter Beitrag: 08.05.2007, 02:56
  5. Mysql Query wird nicht ausgeführt??
    Von JDF1976 im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 26
    Letzter Beitrag: 18.01.2007, 19:23

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •