Ergebnis 1 bis 6 von 6

Thema: Uhrzeit läuft nicht richtig

  1. #1
    Teeny
    Registriert seit
    31.08.2007
    Ort
    Oberhausen
    Beiträge
    42
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard Uhrzeit läuft nicht richtig

    Hallo, wollte letztens die Uhrzeit anzeigen lassen.
    Eigentlich ganz Simple dachte ich mir.

    Code:

    Code:
      $timestamp = time();
      $date = date("d.m.Y",$timestamp);
      $time = date("H:i",$timestamp);
    Aufjeden fall zeigt er mir zwar das richtige Datum an,
    aber die Uhrzeit läuft 2 Stunden hinterher.
    Also wenn wir 12 Uhr haben, wird 10 Uhr angezeigt.

    Hat jemand ne lösung ?
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Forum Guru Avatar von driver
    Registriert seit
    10.04.2006
    Alter
    34
    Beiträge
    20.729
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    sollte so passen...

    läuft evtl die uhrzeit auf deinem webserver falsch ?
    >> die icq-schreiberlinge bitte dies hier beachten



    1679 entdeckte Gottfried Wilhelm Leibniz das Binärsystem, bei einem Gespräch mit seiner Mutter: "Ja..., Nein..., Nein..., Nein..., Ja..., Ja..., Nein..."

  3. #3
    Teeny
    Themenstarter

    Registriert seit
    31.08.2007
    Ort
    Oberhausen
    Beiträge
    42
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Müsste ich meinen Anbieter mal nachfragen,
    außer ich kann das irgendwo nachgucken

  4. #4
    Bandit
    Gast

    Standard

    time() liefert die uhrzeit des servers. Entweder stimmt die zeit auf dem server nicht oder der server steht irgendwo, wo die zeitzone 2 stunden versetzt ist.

  5. #5
    der/die Göttliche Avatar von jojo87
    Registriert seit
    23.03.2007
    Ort
    Leipzig
    Alter
    30
    Beiträge
    3.131
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Scheint die falsche Zeitzone eingestellt zu sein.
    Code:
    $date = date("GMT+2", $timestamp);
    Näheres siehe hier: www.php.net/date

    Gruß,
    Jojo

  6. #6
    Teeny
    Themenstarter

    Registriert seit
    31.08.2007
    Ort
    Oberhausen
    Beiträge
    42
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    hmm wenn ich das eingebe würd sich maximal das Datum ändern,
    und dass sieht dann so aus:

    10AprUTC+2

    Am besten ich red mal meinen Anbieter drauf an,
    ist die einfachste Lösung.

Ähnliche Themen

  1. film läuft nicht...
    Von Flowi81 im Forum Flash Forum
    Antworten: 0
    Letzter Beitrag: 01.11.2007, 10:20
  2. Irgendwie läuft es nicht?
    Von Sepp im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 2
    Letzter Beitrag: 30.11.2006, 17:16
  3. cmfboard läuft nicht und seite nicht erreichbar...
    Von Xmasman im Forum Zope & Plone - das deutsche Hilfeforum
    Antworten: 3
    Letzter Beitrag: 05.05.2006, 23:20
  4. Video läuft nicht
    Von wirr im Forum HTML & CSS Forum
    Antworten: 4
    Letzter Beitrag: 14.09.2005, 22:44
  5. Antworten: 14
    Letzter Beitrag: 14.09.2004, 22:50

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •