Ergebnis 1 bis 4 von 4

Thema: Problem bei PDF-Konvertierung mit SmartPrintNG

  1. #1
    Teeny
    Registriert seit
    01.07.2007
    Ort
    Erzgebirge
    Beiträge
    30
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard Problem bei PDF-Konvertierung mit SmartPrintNG

    Hallo zusammen,

    ich habe zum Testen mal das SmartPrintNG in meiner PLONE-Instanz installiert (unter Nutzung von zopyx-convert mit FOP). Die Installation hat auch nach einigen Anläufen geklappt, leider bekomme ich nun aber folgenden Fehler, wenn ich eine Seite in PDF konvertieren möchte:

    Anfrage URL
    http://localhost/front-page/smartPrintDeliver/deliver Fehlertyp
    OSError Fehlerwert
    [Errno 2] No such file or directory: 'c:\\windows\\temp\\tmpodvspj.pdf' Traceback (innermost last):

    Module ZPublisher.Publish, line 115, in publish
    Module ZPublisher.mapply, line 88, in mapply
    Module ZPublisher.Publish, line 41, in call_object
    Module Products.SmartPrintNG.browser, line 108, in deliver
    OSError: [Errno 2] No such file or directory: 'c:\\windows\\temp\\tmpodvspj.pdf'

    Anfrageformfilename 'c:\\windows\\temp\\tmpodvspj.pdf'
    cookiesareYourCookiesEnabled ''
    __ac 'YWRtaW46YTFzMmQz'
    lazy itemsSESSION <bound method SessionDataManager.getSessionData of <SessionDataManager at /session_data_manager>>
    otherTraversalRequestNameStack []
    AUTHENTICATED_USER <PropertiedUser 'admin'>
    URL 'http://localhost/front-page/smartPrintDeliver/deliver'
    VirtualRootPhysicalPath ('', 'Plone')
    SiteRootPATH '/'
    SERVER_URL 'http://localhost'
    AUTHENTICATION_PATH ''
    __ac 'YWRtaW46YTFzMmQz'
    PUBLISHED <bound method SmartPrintView.deliver of <Products.Five.metaclass.SmartPrintView object at 0x05422150>>
    filename 'c:\\windows\\temp\\tmpodvspj.pdf'
    ACTUAL_URL 'http://localhost/front-page/smartPrintDeliver'
    URL0 http://localhost/front-page/smartPrintDeliver/deliver
    URL1 http://localhost/front-page/smartPrintDeliver
    URL2 http://localhost/front-page
    URL3 http://localhost
    BASE0 http://localhost
    BASE1 http://localhost
    BASE2 http://localhost/front-page
    BASE3 http://localhost/front-page/smartPrintDeliver
    BASE4 http://localhost/front-page/smartPrintDeliver/deliver
    environHTTP_ACCEPT 'image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, */*'
    CONNECTION_TYPE 'Keep-Alive'
    HTTP_USER_AGENT 'Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)'
    HTTP_COOKIE 'areYourCookiesEnabled=; __ac="YWRtaW46YTFzMmQz"'
    GATEWAY_INTERFACE 'CGI/1.1'
    SERVER_SOFTWARE 'Zope/(Zope 2.9.8-final, python 2.4.4, win32) ZServer/1.1 Plone/2.5.5'
    REMOTE_ADDR '127.0.0.1'
    HTTP_ACCEPT_LANGUAGE 'de'
    SCRIPT_NAME ''
    REQUEST_METHOD 'GET'
    HTTP_HOST 'localhost'
    PATH_INFO '/front-page/smartPrintDeliver'
    SERVER_PORT '80'
    SERVER_PROTOCOL 'HTTP/1.1'
    QUERY_STRING 'filename=c:\\windows\\temp\\tmpodvspj.pdf'
    channel.creation_time 1203955257
    HTTP_ACCEPT_ENCODING 'gzip, deflate'
    PATH_TRANSLATED '\\front-page\\smartPrintDeliver'
    Könnt Ihr anhand des Fehlers mir auf die Sprünge helfen, was ich falsch gemacht habe?
    Danke&Greets, Moerz
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Meister(in)
    Registriert seit
    08.12.2007
    Ort
    Tübingen
    Beiträge
    266
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    SmartPrintNG läuft auf Windows...keine Ahnung war nicht bei Dir. Im Zweifelsfalle musst Du dich mit dem Python Debugger ans Werk machen oder zumindest mal in die Logfiles reinschauen oder auf Console Meldungen.
    Sorry aber Windows supporte ich nur sehr eingeschränkt.

  3. #3
    Teeny
    Themenstarter

    Registriert seit
    01.07.2007
    Ort
    Erzgebirge
    Beiträge
    30
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Nachdem ich SmartPrintNG noch einmal auf einer frischen Plone-Instanz installiert hab funktionierte es auf einmal problemlos, keine Ahnung was da vorher falsch lief.

    Aber ich hab noch ne Frage. Gibt es irgendwo eine Anleitung, wie man SmartPrintNG für eigene ContentTypes anpasst?
    Letztendlich muss doch der jeweilige CT in der configure.zcml mit aufgenommen werden, richtig? Nur weiß ich z.B. nicht, was ich dann bei Interfaces angeben muss.

    Danke&Greets, Moerz

  4. #4
    Meister(in)
    Registriert seit
    08.12.2007
    Ort
    Tübingen
    Beiträge
    266
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Zitat Zitat von Moerz
    Aber ich hab noch ne Frage. Gibt es irgendwo eine Anleitung, wie man SmartPrintNG für eigene ContentTypes anpasst?
    Nein - außer Sourcecode lesen und verstehen.

    Zitat Zitat von Moerz
    Letztendlich muss doch der jeweilige CT in der configure.zcml mit aufgenommen werden, richtig? Nur weiß ich z.B. nicht, was ich dann bei Interfaces angeben muss.
    Eben _die_ Interfaces, die das gewünschte Objekt _implementiert_ Studium des Sourcecode hilft hier weiter, z.b. ATContentTypes.

Ähnliche Themen

  1. konvertierung C# String[] returned to c++ managed Code
    Von essi im Forum Forum für alle anderen Programmiersprachen
    Antworten: 0
    Letzter Beitrag: 05.05.2008, 14:46
  2. SmartPrintNG - wie richtig installieren?
    Von Seawolf-371 im Forum Zope & Plone - das deutsche Hilfeforum
    Antworten: 3
    Letzter Beitrag: 08.12.2007, 10:26

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •