Ergebnis 1 bis 6 von 6

Thema: categorization->Verweise->hinzufügen->manchmalFehle

  1. #1
    HTML Newbie
    Registriert seit
    29.01.2008
    Beiträge
    5
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard categorization->Verweise->hinzufügen->manchmalFehle

    Möchte ich für ein zu verschlagwortendes Dokument unter Plone 3.02 einen Verweis auf ein anderes Dokument setzen und gebe im Pop-up-Fenster einen Suchbegriff ein, um dieses Dokument zu finden, kommt selten bei bestimmten, nicht nachvollziehbaren Suchbegriffen folgende Fehlermeldung:

    Error Type: AttributeError
    Error Value: 'NoneType' object has no attribute 'Title'

    Ein resync unter ZMI->portal_catalog->Advanced->Update catalog brachte nicht den gewünschten Erfolg.

    Bin vollkommen ratlos.
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Meister(in)
    Registriert seit
    08.12.2007
    Ort
    Tübingen
    Beiträge
    266
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Ohne vollständige Fehlerinformation in Form eines Python Tracebacks (error_log im ZMI) ist jeder Leser auch vollkommen ratlos.

  3. #3
    HTML Newbie
    Themenstarter

    Registriert seit
    29.01.2008
    Beiträge
    5
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Zitat Zitat von ajung
    Ohne vollständige Fehlerinformation in Form eines Python Tracebacks (error_log im ZMI) ist jeder Leser auch vollkommen ratlos.
    Sorry, das war überstürzt von mir.

    2008-01-30T08:22:09 ERROR Zope.SiteErrorLog http://xxxx:8080/Plone/pdf/ZopeBook-...ebrowser_popup
    Traceback (innermost last):
    Module ZPublisher.Publish, line 119, in publish
    Module ZPublisher.mapply, line 88, in mapply
    Module ZPublisher.Publish, line 42, in call_object
    Module Shared.DC.Scripts.Bindings, line 313, in __call__
    Module Shared.DC.Scripts.Bindings, line 350, in _bindAndExec
    Module Products.CMFCore.FSPageTemplate, line 216, in _exec
    Module Products.CacheSetup.patch_cmf, line 48, in FSPT_pt_render
    Module Products.CacheSetup.patch_cmf, line 123, in PT_pt_render
    Module zope.tal.talinterpreter, line 271, in __call__
    Module zope.tal.talinterpreter, line 346, in interpret
    Module zope.tal.talinterpreter, line 536, in do_optTag_tal
    Module zope.tal.talinterpreter, line 521, in do_optTag
    Module zope.tal.talinterpreter, line 516, in no_tag
    Module zope.tal.talinterpreter, line 346, in interpret
    Module zope.tal.talinterpreter, line 536, in do_optTag_tal
    Module zope.tal.talinterpreter, line 521, in do_optTag
    Module zope.tal.talinterpreter, line 516, in no_tag
    Module zope.tal.talinterpreter, line 346, in interpret
    Module zope.tal.talinterpreter, line 855, in do_condition
    Module zope.tal.talinterpreter, line 346, in interpret
    Module zope.tal.talinterpreter, line 824, in do_loop_tal
    Module zope.tal.talinterpreter, line 346, in interpret
    Module zope.tal.talinterpreter, line 536, in do_optTag_tal
    Module zope.tal.talinterpreter, line 521, in do_optTag
    Module zope.tal.talinterpreter, line 516, in no_tag
    Module zope.tal.talinterpreter, line 346, in interpret
    Module zope.tal.talinterpreter, line 536, in do_optTag_tal
    Module zope.tal.talinterpreter, line 521, in do_optTag
    Module zope.tal.talinterpreter, line 516, in no_tag
    Module zope.tal.talinterpreter, line 346, in interpret
    Module zope.tal.talinterpreter, line 636, in do_insertI18nText_tal
    Module Products.PageTemplates.Expressions, line 224, in evaluateText
    Module zope.tales.tales, line 696, in evaluate
    - URL: file:/xxx/Plone-3.0.2/zeocluster/client1/Products/ATReferenceBrowserWidget/skins/ATReferenceBrowserWidget/referencebrowser_popup.pt
    - Line 294, Column 36
    - Expression: <PythonExpr item.getTypeInfo().Title()>
    - Names:
    {'container': <PloneSite at /Plone>,
    'context': <ATFile at /Plone/pdf/ZopeBook-2_6.pdf>,
    'default': <object object at 0x2aaaaab17200>,
    'here': <ATFile at /Plone/pdf/ZopeBook-2_6.pdf>,
    'loop': {u'item': <Products.PageTemplates.Expressions.PathIterator object at 0x2aaab4904350>},
    'nothing': None,
    'options': {'args': ()},
    'repeat': <Products.PageTemplates.Expressions.SafeMapping object at 0x2aaab4ad2cb0>,
    'request': <HTTPRequest, URL=http://xxx:8080/Plone/pdf/ZopeBook-2_6.pdf/referencebrowser_popup>,
    'root': <Application at >,
    'template': <FSPageTemplate at /Plone/referencebrowser_popup used for /Plone/pdf/ZopeBook-2_6.pdf>,
    'traverse_subpath': [],
    'user': <PropertiedUser 'admin'>}
    Module Products.PageTemplates.ZRPythonExpr, line 49, in __call__
    - __traceback_info__: item.getTypeInfo().Title()
    Module PythonExpr, line 1, in <expression>
    AttributeError: 'NoneType' object has no attribute 'Title'
    -------------------------------------------------------------------------------------
    Komischerweise tritt dies nur bei bisher zwei Suchbegriffen auf, um ein Doku zu finden, auf das ich einen Verweis setzen möchte: einer davon ist 'Linux'. Sonst kommt die Meldung nicht! D.h. ich bin nur durch Zufall auf dieses Problem gestoßen.

  4. #4
    HTML Newbie
    Themenstarter

    Registriert seit
    29.01.2008
    Beiträge
    5
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Komischerweise tritt dies nur bei bisher zwei Suchbegriffen auf, um ein Doku zu finden, auf das ich einen Verweis setzen möchte: einer davon ist 'Linux'. Sonst kommt die Meldung nicht! D.h. ich bin nur durch Zufall auf dieses Problem gestoßen.
    Ich wollte noch hinzufügen, dass es egal ist, welches Doku ich auf ein anderes verlinken möchte. Die Fehlermeldung kommt ausschließlich bei Eingabe des ominösen Suchbegriffs, auch wenn ich den Verweis in einem völlig anderen Ordner durchführe, der beispielsweise nur Bilder enthält.

  5. #5
    HTML Newbie
    Themenstarter

    Registriert seit
    29.01.2008
    Beiträge
    5
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Zitat Zitat von tresco
    Komischerweise tritt dies nur bei bisher zwei Suchbegriffen auf, um ein Doku zu finden, auf das ich einen Verweis setzen möchte: einer davon ist 'Linux'. Sonst kommt die Meldung nicht! D.h. ich bin nur durch Zufall auf dieses Problem gestoßen.
    Ich wollte noch hinzufügen, dass es egal ist, welches Doku ich auf ein anderes verlinken möchte. Die Fehlermeldung kommt ausschließlich bei Eingabe des ominösen Suchbegriffs, auch wenn ich den Verweis in einem völlig anderen Ordner durchführe, der beispielsweise nur Bilder enthält.
    Noch präziser: Wenn ich den vollständigen Titel des Dokus mit 'Linux' eingebe, kommt die Fehlermeldung nicht. Es wird gefunden. Ich kann den Verweis setzen. Gebe ich nur 'Linux' ein, dann kommt die Meldung.

  6. #6
    HTML Newbie
    Themenstarter

    Registriert seit
    29.01.2008
    Beiträge
    5
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard Re: categorization->Verweise->hinzufügen->manchmalF

    Zitat Zitat von tresco
    Möchte ich für ein zu verschlagwortendes Dokument unter Plone 3.02 einen Verweis auf ein anderes Dokument setzen und gebe im Pop-up-Fenster einen Suchbegriff ein, um dieses Dokument zu finden, kommt selten bei bestimmten, nicht nachvollziehbaren Suchbegriffen folgende Fehlermeldung:

    Error Type: AttributeError
    Error Value: 'NoneType' object has no attribute 'Title'
    'NoneType' object has no attribute 'Title' hieß in diesem Fall, dass ich tatsächlich einen inkonsisten Datenstamm hatte: ich hatte von Plone 2.5.4 auf 3.0.2 migriert. Die AT-Mediapage ist nicht mit der letzten Version kompatibel. Es gelang mir nicht vollständig, das Modul anzupassen. So sind Bilder bei der Migration dieser Mediapage "entrissen" und als AT-Images ohne 'Titel' abgespeichert worden.

    So musste ich Sie kurz neu einlesen und alles funktioniert wieder.

Ähnliche Themen

  1. Google Verweise
    Von im Forum HTML & CSS Forum
    Antworten: 4
    Letzter Beitrag: 07.08.2008, 17:07
  2. Verweise
    Von sailralf im Forum HTML & CSS Forum
    Antworten: 3
    Letzter Beitrag: 18.02.2006, 15:12
  3. xml Datei Verweise
    Von sailralf im Forum HTML & CSS Forum
    Antworten: 0
    Letzter Beitrag: 18.02.2006, 15:08
  4. Verweise deifinieren
    Von xnoelx im Forum HTML & CSS Forum
    Antworten: 6
    Letzter Beitrag: 07.02.2006, 15:18
  5. Verweise gestalten
    Von xnoelx im Forum HTML & CSS Forum
    Antworten: 2
    Letzter Beitrag: 30.01.2006, 21:12

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •