Ergebnis 1 bis 4 von 4

Thema: [gelöst] Tooltip Skript mit einem Bug

  1. #1
    Fortgeschrittene/r
    Registriert seit
    26.09.2005
    Ort
    Nürnberg
    Beiträge
    169
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard [gelöst] Tooltip Skript mit einem Bug

    Hallo Folks,

    also ich muss erstmal zugeben das ich nicht sehr bewandert in Javascript bin. Habe ein Tooltip Skript geschrieben, welches aber einen Bug hat und einfach nicht klappen will.

    Folgendes soll funktionieren (siehe Beispielcode):
    Wenn ich über das "muh" div Element fahre, sollte ein neben meiner Maus das div Element auftauchen mit der Id "tooltip". Es wird zwar dargestellt und auch wieder ausgeblendet, aber leider unter dem ersten div-Element.

    Irgendwie scheint die Funktion updateTT() nicht so zu klappen.

    Code:
    <html>
      <head>
        <script type="text/javascript">
        tt = null;
    
        document.onmousemove = updateTT;
    
        function updateTT&#40;e&#41; &#123;
          x = &#40;document.all&#41; ? window.event.x + document.body.scrollLeft &#58; e.pageX;
          y = &#40;document.all&#41; ? window.event.y + document.body.scrollTop  &#58; e.pageY;
          if &#40;tt != null&#41; &#123;
              tt.style.left = &#40;x + 20&#41; + "px";
              tt.style.top = &#40;y + 20&#41; + "px";
          &#125;
        &#125;
    
        function showTT&#40;&#41; &#123;
            tt = document.getElementById&#40;"tooltip"&#41;;
            tt.style.display = "block";
        &#125;
    
        function hideTT&#40;&#41; &#123;
            tt.style.display = "none";
        &#125;
        </script>
      </head>
      <body>
        <div onmouseover="showTT&#40;&#41;" onmouseout="hideTT&#40;&#41;" style="width&#58; 100px; height&#58; 100px">muh</div>
        <div id="tooltip" style="display&#58;none;">[img]picture.jpg[/img]</div>
      </body>
    </html>
    Der Code ist natürlich nur ein Schnippsel, aber der Fehler tritt hier auch auf.

    Irgendwelche Ideen warum tt.style.left und tt.style.top nicht richtig funktionieren?

    Schonmal vielen Dank!
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Fortgeschrittene/r
    Themenstarter

    Registriert seit
    26.09.2005
    Ort
    Nürnberg
    Beiträge
    169
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    So, ich Volltrottel habs selber gelöst:

    Es hat einfach nur ein "position: absolute;" für den TooltipContainer gefehlt. Ist ja auch logisch, aber ich habs einfach übersehen.

    Egal, hat sich also erledigt...

  3. #3
    Kaiserliche Hoheit Avatar von No0ob
    Registriert seit
    02.01.2006
    Ort
    Nähe Frankfurt
    Beiträge
    1.500
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Den Code hast du übrigens nicht selbst geschrieben

  4. #4
    Fortgeschrittene/r
    Themenstarter

    Registriert seit
    26.09.2005
    Ort
    Nürnberg
    Beiträge
    169
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Das ist richtig, dieser Teil ist nicht von mir. Mein Skript beschränkt sich allerdings nicht auf diese paar Zeilen.
    War allerdings in diesem Zusammenhang falsch zu sagen das ich das Skript geschrieben habe.

    Der Vollständigkeit halber hier der Link zum Author.

Ähnliche Themen

  1. Antworten: 3
    Letzter Beitrag: 31.08.2007, 15:26
  2. .TXT [gelöst]
    Von Stubi im Forum HTML & CSS Forum
    Antworten: 2
    Letzter Beitrag: 01.09.2006, 18:34
  3. Tooltip Script Fehlerhaft
    Von Phase8421 im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 7
    Letzter Beitrag: 24.03.2006, 12:10
  4. problem gelöst --
    Von don-golione im Forum HTML & CSS Forum
    Antworten: 6
    Letzter Beitrag: 17.01.2006, 22:02
  5. Für jede Ausgabe eigenes Tooltip...
    Von DVDFreak im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 15
    Letzter Beitrag: 01.12.2005, 16:20

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •