Ergebnis 1 bis 5 von 5

Thema: richtiges doctype?

  1. #1
    imaginärer User
    Registriert seit
    21.05.2007
    Beiträge
    141
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard richtiges doctype?

    nabend

    es ist ja seltsam...ewig lang hat mein doctype gestimmt und jetzt auf einmal nicht mehr!?

    kann mir da jemand helfen?

    wäre diese website http://tigpl.ti.funpic.de

    wäre fein wenn mir jemand sagen könnte welches doctype nun das richtige is..hab schon einige durchprobiert..i komm aber auf keinen grünen zweig

    danke
    lg tigpl
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Prinz(essin) Avatar von Lizzard
    Registriert seit
    19.02.2006
    Ort
    München
    Beiträge
    788
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Es gibt doch keinen "richtigen" oder "falschen" Doctype? Welches Problem ergibt sich denn bei deinen verwendeten Doctypes?
    Sometimes you have a programming problem and it seems like the best solution is to use regular expressions; now you have two problems.

  3. #3
    imaginärer User
    Themenstarter

    Registriert seit
    21.05.2007
    Beiträge
    141
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    beim validieren sagt er mir das zeichen beim doctype falsch sind...war früher aber nicht so

    hier die fehler:

    Code:
    #  Error  Line 24, Column 2: "DOCTYPE" declaration not allowed in instance.
    
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    
    ✉
    # Error Line 26, Column 56&#58; document type does not allow element "html" here.
    
    <html xmlns="http&#58;//www.w3.org/1999/xhtml" xml&#58;lang="de">
    
    ✉
    
    The element named above was found in a context where it is not allowed. This could mean that you have incorrectly nested elements -- such as a "style" element in the "body" section instead of inside "head" -- or two elements that overlap &#40;which is not allowed&#41;.
    
    One common cause for this error is the use of XHTML syntax in HTML documents. Due to HTML's rules of implicitly closed elements, this error can create cascading effects. For instance, using XHTML's "self-closing" tags for "meta" and "link" in the "head" section of a HTML document may cause the parser to infer the end of the "head" section and the beginning of the "body" section &#40;where "link" and "meta" are not allowed; hence the reported error&#41;.

    und mein doctype:

    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http&#58;//www.w3.org/TR/xhtml1/xhtml1-transitional.dtd">
    <html xmlns="http&#58;//www.w3.org/1999/xhtml" xml&#58;lang="de">

  4. #4
    Kaiser(in) Avatar von Elvis
    Registriert seit
    09.05.2006
    Ort
    Hamburg
    Beiträge
    2.537
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings
    Blog-Einträge
    2

    Standard

    Wenn der Doctype zweimal auf der Seite ist, sollte man sich auch nicht wundern. Manchmal hilft es auch einen Blick in den eigenen Quelltext zu werfen.

    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http&#58;//www.w3.org/TR/xhtml1/xhtml1-transitional.dtd">
    <html xmlns="http&#58;//www.w3.org/1999/xhtml" xml&#58;lang="de">
    <head>
    <link href="css.css" rel="stylesheet" type="text/css" />
    
    
    
    <title> Tigpl - Willkommen </title>
    </head>
    <body>
    
    <center>
    
    <div id="wrap">
    
    
    
    
    
    <div class="men1">
    
    
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http&#58;//www.w3.org/TR/xhtml1/xhtml1-transitional.dtd">
    <html xmlns="http&#58;//www.w3.org/1999/xhtml" xml&#58;lang="de">
    <head>
    <link href="cssmenu.css" rel="stylesheet" type="text/css" />
    
    
    
    <title> Tigpl - Willkommen </title>
    </head>
    <body>

  5. #5
    imaginärer User
    Themenstarter

    Registriert seit
    21.05.2007
    Beiträge
    141
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    danke +gg*

    das kommt von der html datei (das menü) die ich an der stelle einfüge +gg* ...werd mi da mal spieln das des wieder passt

    danke für den hinweis, da wär i selbst wohl nie draufgekommen!

Ähnliche Themen

  1. HTML->richtiges Ausrichten ? BEENDET
    Von DoneOne im Forum HTML & CSS Forum
    Antworten: 33
    Letzter Beitrag: 01.04.2008, 01:53
  2. Richtiges Netzwerkkabel ?
    Von 634322 im Forum Computer - Internet Forum
    Antworten: 4
    Letzter Beitrag: 23.12.2007, 19:23
  3. richtiges Deutsch?
    Von sazuka85 im Forum Off Topic und Quasselbox
    Antworten: 4
    Letzter Beitrag: 02.05.2007, 08:11
  4. Problem Datum auf richtiges Format zu prüfen
    Von Jens im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 1
    Letzter Beitrag: 11.02.2006, 17:29
  5. Mein erstes richtiges Forum *freu*
    Von Dirk im Forum Eure Homepages und Foren - Vorstellung und Bewertungen
    Antworten: 1
    Letzter Beitrag: 07.01.2005, 22:35

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •