Ergebnis 1 bis 2 von 2

Thema: active x-elemente im internet explorer 7

  1. #1
    Flowi81
    Gast

    Standard active x-elemente im internet explorer 7

    guten morgen,
    ich mache momentan die Seite für unser Unternehmen neu. Ich habe kleine Flashfilme
    eingebunden. Meine Chefin hat nun das Problem, das sie immmer die Meldung
    "AktiveX-Steuerelemente initialisieren und ausführen, die nciht sicher sind"
    und das ausführen von scripts wurde aus sicherheitsgründen eingeschränkt... bekommt, wenn sie eine Seite aufmacht, wo so ein Film eingebunden ist (IE 7).
    Ich habe das auf "aktivieren" in meinem Browser gestellt und habe so kein Problem
    damit. Aber wie kann man diese Meldung umgehen?
    Bei dieser Seite http://www.liedeco.de/ hat sie das Problem nicht und das ist ja
    auch Flash. Gibts da irgendn Trick oder hab ich was falsch gemacht? Man kann ja nicht erwarten, dass die Kunden erst in ihren Sicherheitseinstellungen rumfummeln.
    hab es schon mit dem js probiert,a ber die meldung erscheint bei ihr immer noch.
    hilfe! die seite soll bald hoch und ich finde keine lösung....*heul*
    mein code:
    Code:
    <script type="text/javascript" src="swfobject.js"></script> 
    <link href="style.css" rel="stylesheet" type="text/css"> 
    
    </head> 
    <body> 
    
    <div id="main"> 
    <div id="head"> 
    
    <div id="logobild">[img]bilder/head_jalousie.jpg[/img] 
        
    <div id="film"> 
    [img]movies/jalousie.jpg[/img] <!--hier wird das alternativbild angezeigt 
    und wenn flash installiert ist wird hier der film automatsich angezeigt!--> 
    </div> 
    
    <script type="text/javascript"> 
       var so = new SWFObject&#40;"movies/jalousie.swf", "mymovie", "345", "250", "6", "#336699"&#41;; 
       so.write&#40;"film"&#41;; 
    </script> 
    
    
    </div> 
    
    </div> 
    
    <div id="footer"> 
      Impressum<span style="padding-left&#58;4px;">|</span> 
      Kontakt 
    </div> 
    
    </div> 
    
    </body> 
    
    </html>
    die css-beschreibung für den film:

    #film
    {position:absolute;padding:0px;margin:0px;left:415 px;top:0px;
    width:345px; height:250px;}
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Gast

    Standard

    hallo, ich habe jetzt was geändert und den flashfilm mit js eingebettet, damit das mit den activexsteuerelementen übergangen wird.
    Aber der film läuft nicht. im ie7 sieht man ein weißes rechteck wo der film sein
    soll und im ff gar nichts. was ist hier falsch???

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
    "http://www.w3.org/TR/html4/loose.dtd">
    <html>
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    <title>Untitled Document</title>
    <script src="AC_RunActiveContent.js" type="text/javascript"></script>
    <link href="style.css" rel="stylesheet" type="text/css">
    </head>

    <body>
    <div id="logobild">[img]bilder/head_schiene.jpg[/img]
    <script type="text/javascript">
    AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0',
    'width','345','height','250','src','movies/schiene.swf','quality','high','pluginspage',
    'http://www.macromedia.com/go/getflashplayer','movie','movies/schiene.swf' ); //end AC code
    </script>
    <noscript>
    <object classid="clsid27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0"
    width="345" height="250">
    <param name="movie" value="movies/schiene.swf">
    <param name="quality" value="high">
    <embed src="movies/schiene.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="345" height="250"></embed>
    </object>
    </noscript>
    </div>
    </body>
    </html>

    die AC_RunActiveContent.js - datei habe ich so gelassen.

    Quelle: http://www.adobe.com/devnet/activeco...devletter.html

Ähnliche Themen

  1. Internet Explorer und Firefox Explorer tauglich
    Von forummx im Forum HTML & CSS Forum
    Antworten: 5
    Letzter Beitrag: 21.11.2009, 22:13
  2. Internet Explorer Meldung umgehen "AktiveX Elemente akt
    Von Peter4you im Forum Script-Archiv
    Antworten: 5
    Letzter Beitrag: 31.03.2009, 17:36
  3. Internet Explorer
    Von im Forum Computer - Internet Forum
    Antworten: 8
    Letzter Beitrag: 05.09.2007, 14:12
  4. Internet Explorer 7.0
    Von Frank Klaus im Forum Computer - Internet Forum
    Antworten: 2
    Letzter Beitrag: 19.12.2006, 19:48
  5. Internet Explorer
    Von Fabi im Forum Computer - Internet Forum
    Antworten: 19
    Letzter Beitrag: 08.03.2006, 09:04

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •