Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 15

Thema: IE 7 gibt einen Syntaxfehler aus (Problem hat sich erledigt)

  1. #1
    Youngster
    Registriert seit
    19.10.2007
    Ort
    Bendorf
    Beiträge
    10
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard IE 7 gibt einen Syntaxfehler aus (Problem hat sich erledigt)

    Oh man... wenn die Welt nur noch mit Firefox-Browsern gespeist würde, hätte ich es wesentlich leichter... Damit funktioniert eigentlich alles. Mit dem IE 7 habe ich immer meine Probleme!

    Und zwar folgendes: Ich habe ein Blog auf blogspot.com gehostet, mich für einen Template entschieden, und den dann (learning by doing) komplett an meine Bedürfnisse angepasst. Ich habe also im HTML-Code hunderte von Veränderungen vorgenommen usw. Da hat man ja schon Sorge, dass man sich mal irgendwo verrennen könnte.

    Jedenfalls ist alles wunderbar: Im Firefox. Die Seite wird absolut optimal und richtig angezeigt. Im IE 7 ist allerdings alles ein bisschen anders. Die Zeilenabstände sind viel viel größer. Und wenn ich sie dort anpasse (was sehr schwierig ist), passen sie nicht mehr im Firefox... Aber an dieses Problem habe ich mich ja schon gewöhnt. Also eigentlich wird die Seite also so gesehen auch im IE 7 richtig dargestellt.

    Bloss erscheint beim Laden der Seite im IE 7 immer die Meldung "Es sind Fehler auf der Seite aufgetreten." Bloß welche??? Es wird doch alles richtig angezeigt! In den Details heißt es, der Fehler würde in Zeile 2 im 8 Zeichen liegen (Syntaxfehler).

    Nun gut, um dem Phänomen auf die Spur zu kommen, habe ich ein Testblog mit dem Ur-Original-Template angelegt. Das habe ich stufenweise wieder an das jetzt neue Layout angepasst, um herauszufinden wo der Fehler liegt. Das ging soweit, dass ich jetzt einfach den kompletten HTML-Code und die Widgets auf dieses Testblog kopiert habe.

    Und der Witz: Läd man das Testblog zeigt IE keinen Fehler an! Obwohl dort doch nun der selbe HTML-Code zugrundeliegt! Außerdem soll der Fehler ja in Zeile 2 sein, also am Anfang vom Code. Klar, im Testblog fehlen die Beiträge... Aber die HTML-Köpfe sind im Quelltext völlig identisch!

    Und jetzt bin ich mal gespannt, ob hier jemand von euch mir weiterhelfen kann?

    Das Blog, wo der Fehler angezeigt wird, findet ihr hier: http://munterwegs.blogspot.com

    Das nahezu identische Testblog (ohne Fehleranzeige) findet ihr hier: http://html-test-blog.blogspot.com

    Ich hoffe auf Antworten!

    Und danke im vorraus!

    Gruss,
    Torsten
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Samurai
    Registriert seit
    30.09.2007
    Beiträge
    229
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Im IE 6 werden beim ersten Link keine Fehler angezeigt.

    Beim zweiten Link erscheint: Die Seite kann nicht angezeigt werden.
    Wer andern eine Bratwurst brät, wird selbst zum Bratwurstbratgerät.
    Ron Stoppable

  3. #3
    Kaiser(in)
    Registriert seit
    24.04.2006
    Ort
    Ludwigshafen
    Beiträge
    2.720
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Bereinige mal diese Fehler

  4. #4
    phpfan
    Gast

    Standard

    Bei 321 Fehlern dem IE die Schuld in die Schuhe zu schieben ist ja lustig.

    Klick mich

    @sejuma
    Der Validator auf selfhtml ist nicht so pingelig, den würde ich nicht nehmen.

  5. #5
    Kaiser(in)
    Registriert seit
    24.04.2006
    Ort
    Ludwigshafen
    Beiträge
    2.720
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Danke für den Tipp, phpfan.
    Aber ich wollte es nicht gleich übertreiben und noch mehr frustrieren!

  6. #6
    Youngster
    Themenstarter

    Registriert seit
    19.10.2007
    Ort
    Bendorf
    Beiträge
    10
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Zitat Zitat von Dikra
    Im IE 6 werden beim ersten Link keine Fehler angezeigt.

    Beim zweiten Link erscheint: Die Seite kann nicht angezeigt werden.
    Welchen Link meinst du? Also bei mir wurde die Seite im IE 6 (bis auf die Fehlerinformation) tadellos angezeigt...

  7. #7
    Youngster
    Themenstarter

    Registriert seit
    19.10.2007
    Ort
    Bendorf
    Beiträge
    10
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Zitat Zitat von sejuma
    Bereinige mal diese Fehler
    Danke, aber der Anker funktioniert definitv - ohne dass ich jetzt was dran verändert habe. Probier es selbst aus, und du gelangst beim Klick zum Impressum. Das sagt mir nurmehr, dass diese automatischen Validatoren nicht so pralle sind.

    Der Anker findet sich übrigens unter dem Eintrag in der Sidebar "seitenweise".

    <a name="impressum"></a>

    Also das sollte doch richtig so sein, oder? Im firefox funzt es jedenfalls...

  8. #8
    Youngster
    Themenstarter

    Registriert seit
    19.10.2007
    Ort
    Bendorf
    Beiträge
    10
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Zitat Zitat von phpfan
    Bei 321 Fehlern dem IE die Schuld in die Schuhe zu schieben ist ja lustig.
    Also Validatoren kann ich selbst benutzen... Eigentlich wollte ich nur wissen, was der Hintergrund der *einen* Fehlermeldung beim IE 7 sein kann - insofern diese Meldung bei euch auch kommt. Und der gibt einen Fehler in Zeile 2 Zeichen 8 aus. Lustigerweise eben aber nicht bei der anderen Seite mit identischem Quellcode.

    P.S.: Gib mal www.forum-hilfe.de im Validator von Selfhtml ein... Wow, 96 Fehler von denen letztlich keiner was am Bildschirm bemerkt. Genauso wie der angeblich fehlende Anker zum Impressum...

  9. #9
    Youngster
    Themenstarter

    Registriert seit
    19.10.2007
    Ort
    Bendorf
    Beiträge
    10
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Na gut, bei den 96 Fehlern handelt es sich um zu HTML inkombatible Kennzeichungen... aber was macht das in Surfer-Praxis...

  10. #10
    Youngster
    Themenstarter

    Registriert seit
    19.10.2007
    Ort
    Bendorf
    Beiträge
    10
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Ein letzter Nachtrag noch, nachdem ich mir die Ergebnisse des Validators von Selfhtml noch mal durchgelesen habe... Also ist ja nett, dass der einem ausgibt, was nicht erlaubt ist... Für mich stellt sich aber immer nur die Frage was funktioniert. Und letztlich habe ich das Template im Original von blogspot.com ja nicht programmiert. Aber in den bekannten Browsern funktioniert es (bis auf eine Fehlermeldung - trotz sauberer Darstellung). Wenn man andere blogspot-blogs im Validator eingibt, spuckt der nahezu die selben Informationen aus! Das hilft mir bei meinem individuellen Problemchen auch nicht weiter... denn die anderen Blogspot-blogs laufen dennoch ohne eine Fehlermeldung beim IE 7.

    Ich will also nicht wissen, wie viele in der Praxis unrelevante "Unerlaubtheiten" meine Seite hat (z.B. moniert der Validator ständig, dass das Attribut "width" im Iframe nicht erlaubt ist... gut, ich habe das nicht so programmiert, aber letztlich funktioniert es ja trotzdem...). Und wenns von mir aus 400 Unerlaubtheiten sind.. sondern ich möchte nur wissen, wie ich diesen *einen* Fehler beseitige, der beim IE 7 zu dieser Fehlermeldung führt. Aber ich glaube, wenn ich es nicht beseitigt kriege, ist es auch nicht so schlimm. Die Seite wird ja definitiv korrekt angezeigt...

Ähnliche Themen

  1. Mein Html editor geht nicht (hat sich erledigt)
    Von Marlo im Forum HTML & CSS Forum
    Antworten: 0
    Letzter Beitrag: 23.06.2008, 21:16
  2. gibt es einen FLASHPLAYER für die PLAYSTATION 3
    Von Addy im Forum Computer - Internet Forum
    Antworten: 0
    Letzter Beitrag: 21.08.2007, 18:53
  3. Gibt es vieleicht einen Script...
    Von im Forum Webanwendungen - Webapplikationen
    Antworten: 1
    Letzter Beitrag: 10.08.2007, 20:53
  4. Wo kann man sich gut eine E-Mail Adresse machen?/erledigt
    Von Minimi im Forum Off Topic und Quasselbox
    Antworten: 11
    Letzter Beitrag: 26.10.2006, 21:24
  5. hat sich erledigt
    Von vv im Forum Promotion - SEO - Suchmaschine (Google & Co) – Mitarbeiter & Linkpartnersuche
    Antworten: 3
    Letzter Beitrag: 26.06.2005, 15:34

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •