Ergebnis 1 bis 7 von 7

Thema: Explorer zeigt meine Buttons nicht (TEIL II)

  1. #1
    HTML Newbie
    Registriert seit
    15.07.2004
    Beiträge
    9
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard Explorer zeigt meine Buttons nicht (TEIL II)

    Hi an ALLE,

    mein Problem habe ich immer noch. Buttons werden nur von Netscape angezeigt und Explorer weigert sich! Wieso????

    Code:
    <HTML>
    <HEAD>
    <script language="JavaScript">
    <!--
    function newImage&#40;arg&#41; &#123;
            if &#40;document.images&#41; &#123;
                    rslt = new Image&#40;&#41;;
                    rslt.src = arg;
                    return rslt;
            &#125;
    &#125;
    
    function changeImages&#40;&#41; &#123;
            if &#40;document.images && &#40;preloadFlag == true&#41;&#41; &#123;
                    for &#40;var i=0; i<changeImages.arguments.length; i+=2&#41; &#123;
                            document&#91;changeImages.arguments&#91;i&#93;&#93;.src = changeImages.arguments&#91;i+1&#93;;
                    &#125;
            &#125;
    &#125;
    
    var preloadFlag = false;
    function preloadImages&#40;&#41; &#123;
            if &#40;document.images&#41; &#123;
                    b1_over = newImage&#40;"homeover.jpg"&#41;;
                    b2_over = newImage&#40;"werover.jpg"&#41;;
                    b3_over = newImage&#40;"aktuellesover.gif"&#41;;
                    b4_over = newImage&#40;"adressenover.gif"&#41;;
    		b5_over = newImage&#40;"forschungover.gif"&#41;;
    		b6_over = newImage&#40;"literaturover.gif"&#41;;
    		b7_over = newImage&#40;"infoover.gif"&#41;;
                    preloadFlag = true;
            &#125;
    &#125;
    
    // -->
    </script>
    
    </HEAD>
    
    <BODY ONLOAD="preloadImages&#40;&#41;;" bgcolor="#663366">
    
    <P ONMOUSEOVER="changeImages&#40;'b1', 'homeover.jpg'&#41;; return true;"
    ONMOUSEOUT="changeImages&#40;'b1', 'homebutton.jpg'&#41;; return true;">
    [img]homebutton.jpg[/img]</P>
    
    <P ONMOUSEOVER="changeImages&#40;'b2', 'werover.jpg'&#41;; return true;"
    ONMOUSEOUT="changeImages&#40;'b2', 'werbutton.jpg'&#41;; return true;">
    [img]werbutton.jpg[/img]</P>
    
    <P ONMOUSEOVER="changeImages&#40;'b3', 'aktuellesover.jpg'&#41;; return true;"
    ONMOUSEOUT="changeImages&#40;'b3', 'aktuellesbutton.jpg'&#41;; return true;">
    [img]aktuellesbutton.jpg[/img]</P>
    
    <P ONMOUSEOVER="changeImages&#40;'b4', 'adressenover.jpg'&#41;; return true;"
    ONMOUSEOUT="changeImages&#40;'b4', 'adressenbutton.jpg'&#41;; return true;">
    [img]adressenbutton.jpg[/img]</P>
    
    <P ONMOUSEOVER="changeImages&#40;'b5', 'forschungover.jpg'&#41;; return true;"
    ONMOUSEOUT="changeImages&#40;'b5', 'forschungbutton.jpg'&#41;; return true;">
    [img]forschungbutton.jpg[/img]</P>
    
    <P ONMOUSEOVER="changeImages&#40;'b6', 'literaturover.jpg'&#41;; return true;"
    ONMOUSEOUT="changeImages&#40;'b6', 'literaturbutton.jpg'&#41;; return true;">
    [img]literaturbutton.jpg[/img]</P>
    
    <P ONMOUSEOVER="changeImages&#40;'b7', 'infoover.jpg'&#41;; return true;"
    ONMOUSEOUT="changeImages&#40;'b7', 'infobutton.jpg'&#41;; return true;">
    [img]infobutton.jpg[/img]</P>
    
    
    </BODY>
    </HTML>
    Liegt es vielleicht daran, dass ich die Buttons von buttongenerator.com hab??

    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Großmeister(in)
    Registriert seit
    06.07.2004
    Ort
    NRW
    Beiträge
    681
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Kuck mal im Internet Explorer unter Extras - Internetoptionen - Erweitert - Multimedia - Bilder anzeigen.
    Das Kästchen muss hier aktiviert sein.
    System.out.print("Java ist nicht JavaScript!");

  3. #3
    HTML Newbie
    Themenstarter

    Registriert seit
    15.07.2004
    Beiträge
    9
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Neeeee leider war das Kätschen schon aktiviert?!?!
    Nicht einmal mein Logo wird angezeigt! Das kann doch nicht war sein! Ich lauf bald Amok

    Kann ich dir vielleicht meine Buttons zuschicken? Vielleicht funktionieren sie bei dir??


    Ich danke dir MRJAVA
    wenn du weitere Vorschläge hast, dann poste sie bitte!!!

  4. #4
    Großmeister(in)
    Registriert seit
    06.07.2004
    Ort
    NRW
    Beiträge
    681
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Weitere Vorschläge:

    - Darauf achten das die Dateinamen und Ordnernamen passen, und auch alle klein geschrieben sind.

    - Extras - Internetoptionen - Erweitert
    Button "Standard wiederherstellen

    - Extras - Internetoptionen - Sicherheit
    Stufe auf Mittel stellen

    - Nach ein Update für den Internet Explorer suchen
    System.out.print("Java ist nicht JavaScript!");

  5. #5
    HTML Newbie
    Themenstarter

    Registriert seit
    15.07.2004
    Beiträge
    9
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Ich habe jetzt Internet Explorer 6 installiert und es klappt immer noch nicht!

    Außerdem.....
    hätte ich die Datein und Ordnernamen groß geschrieben, dann würde Netscape die Buttons genauso wenig anzeigen ODER???

  6. #6
    Großmeister(in)
    Registriert seit
    06.07.2004
    Ort
    NRW
    Beiträge
    681
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Also bei mir klappt dein Code mit dem Internetexplorer einwandfrei.
    Wenn du alles gemacht hast was ich vorgeschlagen hab, und es immer noch net klappt weiß ich auch net weiter.
    System.out.print("Java ist nicht JavaScript!");

  7. #7
    HTML Newbie
    Themenstarter

    Registriert seit
    15.07.2004
    Beiträge
    9
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    lol

    was meinst du mit "Darauf achten das die Dateinamen und Ordnernamen passen"???

    am liebsten würde ich dir die ganzen Datein zuschicken, damit du sie dir kurz durch gucken kannst!
    Aber das wär bissel zu viel verlangt ODER

Ähnliche Themen

  1. homepage zeigt kein css Teil an
    Von im Forum HTML & CSS Forum
    Antworten: 3
    Letzter Beitrag: 07.07.2008, 20:03
  2. IE zeigt meine ani nicht an
    Von im Forum Flash Forum
    Antworten: 0
    Letzter Beitrag: 26.02.2007, 18:07
  3. IE Explorer zeigt alles korrekt nur firefox usw nicht ???
    Von ecksdream im Forum HTML & CSS Forum
    Antworten: 3
    Letzter Beitrag: 18.02.2007, 02:42
  4. Internet Explorer zeigt Bilder nicht an.
    Von xshocker im Forum HTML & CSS Forum
    Antworten: 7
    Letzter Beitrag: 18.10.2006, 23:13
  5. Explorer zeigt meine Buttons nicht
    Von Diva7384 im Forum Forum für Grafiken und Bildbearbeitung
    Antworten: 1
    Letzter Beitrag: 01.08.2004, 13:16

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •