Ergebnis 1 bis 6 von 6

Thema: CSS-Frage: Hover-Navigation

  1. #1
    Gast

    Standard CSS-Frage: Hover-Navigation

    Hi alle,

    Kann mir einer von euch sagen was ich falsch gemacht habe, dass auf dieser Seite bei der Navigation links im Firefox der Link bereits funktioniert wenn ich mit dem Cursor auf den "Button" fahre, im IE aber erst wenn ich über den Text fahre?

    Ich hoffe ihr versteht was ich meine

    Das stylesheet dazu ist hier.
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    phpfan
    Gast

    Standard

    Kann ich mit dem IE7 nicht nachvollziehen.

  3. #3
    Shogun Avatar von DarkSyranus
    Registriert seit
    28.03.2006
    Ort
    ::1/128
    Alter
    25
    Beiträge
    3.446
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings
    Blog-Einträge
    1

    Standard

    Ich hab zwar grade kein IE da, aber ich denke es liet daran, dass das a-Tag im FF von vornerein 100% width hat.
    Im IE musst du das mal ergänzen.
    Code:
    .navlist li a                              { display:block; padding:3px 0px 3px 8px; background-color:#D8D8D8; color:#000000; text-decoration:none; width: 100%; }
    Wenn nicht geht versuch mal anstatt der 100% die feste Breite der Liste zu nehmen,

  4. #4
    Kaiser(in)
    Registriert seit
    24.04.2006
    Ort
    Ludwigshafen
    Beiträge
    2.720
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Das sollte helfen.
    Ist aber eigentlich unnötig, denn display: block; sind bereits 100%.
    Doch das weiß der IE 6 offensichtlich nicht.

  5. #5
    guest
    Gast

    Standard Linktipp

    Das hiersollte helfen...
    (im übrigen eine Tolle Seite, wenn es um mehr oder weniger spezielle Probleme um CSS und HTML geht.)

  6. #6
    Kaiser(in)
    Registriert seit
    24.04.2006
    Ort
    Ludwigshafen
    Beiträge
    2.720
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    @guest:

    Da hast du vollkommen recht. Diese Seite hat in der Tat viele spezielle Probleme!

Ähnliche Themen

  1. CSS hover frage
    Von Martin279 im Forum HTML & CSS Forum
    Antworten: 2
    Letzter Beitrag: 19.07.2007, 16:54
  2. frage wegen css und hover bei links
    Von arnim im Forum HTML & CSS Forum
    Antworten: 7
    Letzter Beitrag: 16.06.2007, 01:02
  3. Navigation mit hover
    Von Andreas84 im Forum HTML & CSS Forum
    Antworten: 9
    Letzter Beitrag: 03.05.2007, 04:48
  4. a:hover - kruze frage dazu
    Von Mr.Egon im Forum HTML & CSS Forum
    Antworten: 12
    Letzter Beitrag: 07.04.2007, 02:13
  5. Frage zur Navigation
    Von Manuela im Forum Zope & Plone - das deutsche Hilfeforum
    Antworten: 4
    Letzter Beitrag: 16.01.2007, 11:20

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •