Ergebnis 1 bis 7 von 7

Thema: VirtualHost - Zope-2.10.0 hinter Apache verbergen

  1. #1
    Gast

    Standard VirtualHost - Zope-2.10.0 hinter Apache verbergen

    Hallo,

    Bin noch sehr unerfahren mit rewriterules und Virtual Hosts.

    Besitze einen Root-Server mit Suse 9.3 und Plesk.
    Also ich habe einen Zope-Server auf Port 8080 laufen und möchte diesen hinter dem Apache "verstecken".

    Wenn ich
    http://www.myDomain.de
    eingebe, soll er über VirtualHost auf
    http://www.myDomain.de:8080/bestimmterOrdner/ zugreifen.

    Für ein wenig Hilfe wäre ich dankbar.
    Was muss ich genau alles machen???

    Vielen Dank für eine genaue Anleitung
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Meister(in)
    Registriert seit
    15.03.2006
    Beiträge
    316
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Code:
    RewriteEngine On
    RewriteRule ^/(.*) http://localhost:8080/VirtualHostBase/http/%{SERVER_NAME}:80/XXXX/VirtualHostRoot/$1
    Erklärung unter anderem hier

    lg
    michi

  3. #3
    Gast

    Standard welche Datien müssen geändert werden

    Vielen Dank erstmal dafür.

    welche Datei(en) muss ich denn eigentlich auf meinem Server ändern?

    der Apache unter /etc/apache2/ ist es nicht, da ja alles über Plesk läuft.
    Nach der Konfiguration der Domain war folgendes auf dem Server angelegt:

    /srv/www/vhosts/myDomain.de/

    in dem Ordner sind weitere Verzeichnisse.
    (siehe Anhang)


    Vielen Dank
    Gruß Sasho
    Angehängte Grafiken Angehängte Grafiken

  4. #4
    Meister(in)
    Registriert seit
    15.03.2006
    Beiträge
    316
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Morgen. die Datei heißt
    "httpd.conf"

    und/oder "virtuahlhosts.conf"

    oder so ähnlich.... sorry, aber für linux und apache hab ich jemand anderen der das macht

    lg
    michi

  5. #5
    Gast

    Standard

    schau in der httpd.conf nach einem include für die virtualhost datei. Dort muss die RewriteRule dann in den entsprechenden Virtualhost Abschnitt.

  6. #6
    HTML Newbie
    Registriert seit
    29.06.2007
    Ort
    Tübingen
    Beiträge
    3
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard vhost.conf

    Ich habe einen Vserver mit Suse 9.3 und Plesk. Darauf läuft ein Plone 2.5.2.
    Plesk hat unter /srv/www/vhosts/domain-name/conf eine httpd.include angelegt.
    In den conf Ordner habe ich eine vhost.conf selber angelegt und die oben erwähnte Rewrite Rule hineingeschrieben.
    Bei mir:
    RewriteEngine On
    RewriteRule ^/(.*)http://localhost:8080/VirtualHostBas...ww.myDomain.de :80/
    bestimmterOrdner/VirtualHostRoot/$1 [L,P]
    #RewriteRule... in eine Zeile
    #bestimmter Ordner ist bei mir der Namen der Plone Instanz.

    Ich habe das Thema auf meinem Blog beschrieben.
    http://malogo.blogianer.de/post/comp...le-plone-plesk

    Wenn du noch ssl benutzt, dann mußt du noch eine vhost_ssl.conf anlegen.
    Grüße
    Mario

  7. #7
    Gast

    Standard

    Hallo Mario

    könnte zu diesem Thema auch etwas Hilfe gebrauchen.

    Beim Test funktioniert Plone einwandfrei ( IP:8080….. ) Nur über meine Domain kriege ich es nicht hin.
    Die zope.conf habe ich wie folgt angepasst: address 127.0.0.1:8080
    Eine vhost.conf habe ich erstellt und mit folgendem Eintrag ergänzt:
    RewriteEngine On
    RewriteRule ^/(.*) http://127.0.0.1:8080/VirtualHostBase/http/www.meineDomain.com:80/Meine-Plone-Seite/VirtualHostRoot/$1 [L,P]

    Nach Eingabe der Adresse im Browser, erhalte ich jedoch folgende Fehlermeldung: Forbidden You don't have permission to access / on this server.

    Entferne ich [L,P] erhalte die folgenden Fehler: Verbindung fehlgeschlagen. In der Eingabe leiste des Browser wird folgendes ausgegeben:
    http://127.0.0.1:8080/VirtualHostBas...rtualHostRoot/

    Kannst du mir weiterhelfen? Was bewirkt [L,P]? was könnte da noch schief laufen?

    Für deine Hilfe bin ich dir sehr dankbar.
    Hansruedi

Ähnliche Themen

  1. Plone hinter Apache - keine Stylesheets
    Von smatthes im Forum Zope & Plone - das deutsche Hilfeforum
    Antworten: 7
    Letzter Beitrag: 24.02.2008, 09:07
  2. VServer und zope2.10 hinter apache
    Von newsbie im Forum Zope & Plone - das deutsche Hilfeforum
    Antworten: 4
    Letzter Beitrag: 15.12.2007, 05:27
  3. Backgroundimage hinter einem Link
    Von im Forum HTML & CSS Forum
    Antworten: 2
    Letzter Beitrag: 09.08.2006, 09:05
  4. Quelltext verbergen
    Von sporty131280 im Forum HTML & CSS Forum
    Antworten: 10
    Letzter Beitrag: 05.09.2005, 15:36
  5. Mouseover mit Farbänderung HINTER dem Text...
    Von CHIEFmaster im Forum HTML & CSS Forum
    Antworten: 6
    Letzter Beitrag: 28.03.2005, 19:04

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •