Ergebnis 1 bis 4 von 4

Thema: Probleme bei request Objekt

  1. #1
    HTML Newbie
    Registriert seit
    25.05.2007
    Beiträge
    8
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard Probleme bei request Objekt

    Hallo zusammen,

    Ich hab nen kleines Problem mit dem request Objekt.

    Wenn ich mir ne URL zusammenbastel die dann etwa so aussieht:
    http://www.meine-domain.de:8080/irgendwas?param=abc
    krieg ich im Template über z.B.
    Code:
    <span tal&#58;content="request/param">Mein Parameter</span>
    den Wert 'abc' zurück.

    Wie sieht das aber bei ner URL aus, die so aufgebaut ist:
    http://www.meine-domain.de:8080/irge...abc&param2=def

    Sollte dann doch folgendermaßen gehen:
    Code:
    <span tal&#58;content="request/param1">Mein Parameter 1</span>
    <span tal&#58;content="request/param2">Mein Parameter 2</span>
    also im ersten Fall abc und im 2ten def

    Funktioniert aber leider nicht. Wenn ich die URL so aufrufe werd ich zu ner Fehlerseite weitergeleitet, die mir sagt, dass die Seite nicht existiert.
    Die Frage ist nun, wie kann ich eine solche URL mit beliebig vielen Parametern aufbauen und trotzdem wird die richtige in der URL angegebene Seite gefunden?

    Wer sich das Problem mal Live anschauen will, hier der Link:
    http://www.wow-morgenrot.de:8080/mor...=Schmiedekunst
    Es geht um die Links die direkt unter der Überschrift kommen. Da wird so eine mehrteilige URL erzeugt, die allerdings nicht richtig weiterleitet.

    Das ganze Produkt ist immo leider nur teilweise fertig, da ich zur Zeit halt an diesem Fehler häng und die letztendliche Formatierung am Ende kommt.

    Wär schön wenn jemand helfen könnte

    MFG ThLandua
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    HTML Newbie
    Themenstarter

    Registriert seit
    25.05.2007
    Beiträge
    8
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Wirklich keiner ne Ahnung woran das liegen könnt?

  3. #3
    Kaiserliche Hoheit
    Registriert seit
    22.02.2005
    Beiträge
    1.558
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Ich stelle fest, dass bereits dies hier einen 404 hervorbringt:
    http://www.wow-morgenrot.de:8080/morgenrot/recipe_view

    Anscheinend gibt es das Objekt recipe_view nicht, denn http://www.wow-morgenrot.de:8080/morgenrot findet Zope.

    Torty

    EDIT:
    Da hast du wohl ein "s" vergessen, denn dies hier scheint zun klappen:
    http://www.wow-morgenrot.de:8080/mor...nst&cat=Selten
    "Carpe Diem" powered by positiv Feelings

  4. #4
    HTML Newbie
    Themenstarter

    Registriert seit
    25.05.2007
    Beiträge
    8
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    omg, das hätt mich fast zur Verzweiflung gebracht... war dann doch nen ziemlich dummer Fehler meinerseits

    Aber vielen Dank für den Hinweis, das hat mich jetzt echt weitergebracht
    Ich glaub an so Fehlern kann man sich totsuchen und findets trotzdem net selbst

    Mfg ThLandua

Ähnliche Themen

  1. Image zum Objekt
    Von im Forum Zope & Plone - das deutsche Hilfeforum
    Antworten: 3
    Letzter Beitrag: 09.04.2008, 13:09
  2. prüfen ob request variable existiert
    Von mop im Forum Zope & Plone - das deutsche Hilfeforum
    Antworten: 2
    Letzter Beitrag: 08.12.2007, 18:12
  3. zugriff auf apache server mit request
    Von ledzep im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 0
    Letzter Beitrag: 27.03.2007, 18:23
  4. [Ajax] Erstes Objekt aus dem Request
    Von ::RMB:: im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 9
    Letzter Beitrag: 27.01.2007, 18:03
  5. Wie funktioniert ein Post Request
    Von Gast im Forum HTML & CSS Forum
    Antworten: 1
    Letzter Beitrag: 15.05.2006, 09:26

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •