Ergebnis 1 bis 5 von 5

Thema: Hilfe, meine Navi verrutscht

  1. #1
    Teeny
    Registriert seit
    14.05.2007
    Ort
    Im hohen Norden
    Beiträge
    49
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard Hilfe, meine Navi verrutscht

    Hi,

    ich bin gerade dabei mir eine Website für meine Onlinebewerbung zu bauen. Aber ich habe ein Darstellungsproblem.

    Die Navigationsleiste verrutscht total. Im Phase5 editor wird alles ordnungsgemäß angezeigt, die navigation sitzt unter dem Banner links neben meinem Textdiv.

    Aber im Firefox (und nur da) sitzt die navigation "oben links neben dem banner".

    Hier mein Code und die CSS:

    Code:

    Code:
    <body text="#1100E6" bgcolor="#FFFFFF" link="#FF0000" alink="#FF0000" vlink="#FF0000" background="images/bg_dots.gif">
    <div class="main">
    
    <div class="head">
    [img]images/head1.png[/img]
    </div>
    
     
    
    
    <div class="navi">
    
    
    
    <a href="index.html">[img]images/but1.jpg[/img]
    
    </a>
    <a href="#">[img]images/but2.jpg[/img]
    
    </a>
    <a href="#">[img]images/but3.jpg[/img]
    
    </a>
    <a href="#">[img]images/but7.jpg[/img]
    
    </a>
    <a href="#">[img]images/but8.jpg[/img]
    
    </a>
    <a href="#">[img]images/but5.jpg[/img]
    
    </a>
    <a href="#">[img]images/but6.jpg[/img]
    
    </a>
    </div>
    
    
    
    <div class="text">
    
    
    
    <p class="alert">Sehr geehrter Besucher, herzlich Willkommen auf meiner Onlinepräsenz.</p>
    
    BLABLABLABLABLABLABLABLABLABLA
    
              
    
    [img]images/us.png[/img]
    
    
    </div>
    
    
    
    <div class="foot">
    
    
    <font size="-2">Diese Seite wurde für eine Auflösung von 1024x768 Pixel Optimiert.</p>
    </div>
    
    </div>
    </body>
    Und mein CSS-Stylesheet:

    Code:
    .head&#123;
    position&#58; absolute;
    left&#58; 15%;
    width&#58; 680px;
    top&#58; 10px;
    &#125;
    &#125;
    .navi &#123;
    position&#58; absolute;
    left&#58; 15%;
    width&#58; 180px;
    top&#58; 143px;
    overflow&#58; auto;
    &#125;
    .text &#123;
    position&#58; absolute;
    left&#58; 35%;
    width&#58; 500px;
    height&#58; 500px;
    top&#58; 143px;
    text-align&#58; center;
    overflow&#58; auto;
    &#125;
    .foot &#123;
    position&#58; absolute;
    left&#58; 15%;
    width&#58; 695px;
    top&#58; 655px;
    text-align&#58; center;
    &#125;
    Könnt ihr mir weiterhelfen, bitte. Ich bin einfach nur ratlos.

    Danke ^^ euer Nemesis
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!
    Ich bin nur dafür verantwortlich was ich sage bzw hier schreibe und nicht dafür was du verstehst.

  2. #2
    König(in)
    Registriert seit
    06.06.2007
    Ort
    Bi
    Beiträge
    1.015
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Warum hast du denn auch von dem Text eine andere realtive angabe, als der rest? Das kann so ja nicht gehen , schau wie hier http://de.selfhtml.org/css/eigenscha...e/position.htm ^^
    Sämtlicher Code erhebt keinen Anspruch auf syntaktische Korrektheit geschweige denn Ausführbarkeit und ist für die Implementation außerhalb der Beispiele nicht geeignet.

    Kein Support für kommerzielle Scripts | Kein kostenloser Support via ICQ

  3. #3
    Meister(in)
    Registriert seit
    10.03.2006
    Beiträge
    271
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    du hast im css nach dem head teil

    eine } zu viel, oder seh ich da was falsch???

    evtl liegts ja da drann...

  4. #4
    der/die Göttliche Avatar von jojo87
    Registriert seit
    23.03.2007
    Ort
    Leipzig
    Alter
    30
    Beiträge
    3.131
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Desweiteren könntest du alles in ein großes div packen und mit position: relative arbeiten, wenns dann noch nötig ist.
    Außerdem hast du
    in <a> tags drin, ist meines Wissens nach invalid.

    Gruß
    Jojo

  5. #5
    Teeny
    Themenstarter

    Registriert seit
    14.05.2007
    Ort
    Im hohen Norden
    Beiträge
    49
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Ok dank euch Leute, das Problem habe ich beheben können. Die zweite Klammer im CSS war dran schuld. Hab ich einfach übersehen gehabt.

    Danke nochmal,

    Nemesis
    Ich bin nur dafür verantwortlich was ich sage bzw hier schreibe und nicht dafür was du verstehst.

Ähnliche Themen

  1. Navi hilfe
    Von Vodka im Forum HTML & CSS Forum
    Antworten: 7
    Letzter Beitrag: 30.07.2007, 14:22
  2. Inhalt verrutscht
    Von Stormfighter im Forum HTML & CSS Forum
    Antworten: 5
    Letzter Beitrag: 17.02.2007, 11:33
  3. Layout verrutscht
    Von Chrissi91 im Forum HTML & CSS Forum
    Antworten: 0
    Letzter Beitrag: 19.01.2007, 14:19
  4. hilfe bei dyn. navi horiz/vertik gesucht
    Von im Forum Flash Forum
    Antworten: 2
    Letzter Beitrag: 13.09.2006, 15:39
  5. design verrutscht
    Von sebrA im Forum HTML & CSS Forum
    Antworten: 4
    Letzter Beitrag: 21.11.2005, 12:53

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •