Ergebnis 1 bis 2 von 2

Thema: Umlauteproblem Umstellung von PloneFormGen 1.0.3 auf 1.1.2

  1. #1
    Gast

    Standard Umlauteproblem Umstellung von PloneFormGen 1.0.3 auf 1.1.2

    Hallo liebe Liste,

    Ich habe versucht, die ein Update von PloneFormGen 1.0.3. auf 1.1.2 zu machen. Leider ist dabei der folgende Fehler aufgetreten:

    Wenn ich den Zeichensatz in den Portal-Properties auf UTF-8 setzte, wird das Formular korrekt angezeigt, allerdings sind alle Umlaute auf der gesamten Site falsch.
    Stelle ich das default charset um auf iso-8859-1, bekomme ich zwar auf allen anderen Seiten die richtigen Umlaute angezeigt, aber beim Aufruf der Formulare kriege ich den folgenden Fehler angezeigt.

    UnicodeDecodeError: 'ascii' codec can't decode byte 0xfc in position 6:
    ordinal not in range(12

    Kann mir jemand helfen?

    Mit freundlichen Grüßen
    Petra Tegtmeyer


    Traceback (innermost last):
    Module ZPublisher.Publish, line 115, in publish
    Module ZPublisher.mapply, line 88, in mapply
    Module ZPublisher.Publish, line 41, in call_object
    Module Products.CMFFormController.ControllerPageTemplate, line 80, in __call__
    Module Products.CMFFormController.BaseControllerPageTempl ate, line 42, in _call
    Module Shared.DC.Scripts.Bindings, line 311, in __call__
    Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec
    Module Products.PageTemplates.ZopePageTemplate, line 255, in _exec
    Module Products.CacheSetup.patch_cmf, line 56, in PT_pt_render
    Module Products.CacheSetup.patch_utils, line 9, in call_pattern
    Module Products.PageTemplates.PageTemplate, line 104, in pt_render
    - <ControllerPageTemplate at /Plone/fg_base_view used for /Plone/csb/editKz>
    Module TAL.TALInterpreter, line 238, in __call__
    Module TAL.TALInterpreter, line 281, in interpret
    Module TAL.TALInterpreter, line 728, in do_defineMacro
    Module TAL.TALInterpreter, line 281, in interpret
    Module TAL.TALInterpreter, line 457, in do_optTag_tal
    Module TAL.TALInterpreter, line 442, in do_optTag
    Module TAL.TALInterpreter, line 437, in no_tag
    Module TAL.TALInterpreter, line 281, in interpret
    Module TAL.TALInterpreter, line 749, in do_useMacro
    Module TAL.TALInterpreter, line 281, in interpret
    Module TAL.TALInterpreter, line 457, in do_optTag_tal
    Module TAL.TALInterpreter, line 442, in do_optTag
    Module TAL.TALInterpreter, line 437, in no_tag
    Module TAL.TALInterpreter, line 281, in interpret
    Module TAL.TALInterpreter, line 780, in do_defineSlot
    Module TAL.TALInterpreter, line 281, in interpret
    Module TAL.TALInterpreter, line 457, in do_optTag_tal
    Module TAL.TALInterpreter, line 442, in do_optTag
    Module TAL.TALInterpreter, line 437, in no_tag
    Module TAL.TALInterpreter, line 281, in interpret
    Module TAL.TALInterpreter, line 728, in do_defineMacro
    Module TAL.TALInterpreter, line 281, in interpret
    Module TAL.TALInterpreter, line 715, in do_condition
    Module TAL.TALInterpreter, line 281, in interpret
    Module TAL.TALInterpreter, line 457, in do_optTag_tal
    Module TAL.TALInterpreter, line 442, in do_optTag
    Module TAL.TALInterpreter, line 437, in no_tag
    Module TAL.TALInterpreter, line 281, in interpret
    Module TAL.TALInterpreter, line 749, in do_useMacro
    Module TAL.TALInterpreter, line 281, in interpret
    Module TAL.TALInterpreter, line 749, in do_useMacro
    Module TAL.TALInterpreter, line 281, in interpret
    Module TAL.TALInterpreter, line 457, in do_optTag_tal
    Module TAL.TALInterpreter, line 442, in do_optTag
    Module TAL.TALInterpreter, line 437, in no_tag
    Module TAL.TALInterpreter, line 281, in interpret
    Module TAL.TALInterpreter, line 715, in do_condition
    Module TAL.TALInterpreter, line 281, in interpret
    Module TAL.TALInterpreter, line 715, in do_condition
    Module TAL.TALInterpreter, line 281, in interpret
    Module TAL.TALInterpreter, line 457, in do_optTag_tal
    Module TAL.TALInterpreter, line 442, in do_optTag
    Module TAL.TALInterpreter, line 437, in no_tag
    Module TAL.TALInterpreter, line 281, in interpret
    Module TAL.TALInterpreter, line 507, in do_setLocal_tal
    Module Products.PageTemplates.TALES, line 221, in evaluate
    - URL: /Plone/global_contentmenu
    - Line 82, Column 4
    - Expression: <PythonExpr here.getAddableTypesInMenu(allowedTypes)>
    - Names:
    {'container': <PloneSite at /Plone>,
    'context': <FormFolder at /Plone/csb/editKz>,
    'default': <Products.PageTemplates.TALES.Default instance at
    0x01631CB0>,
    'here': <FormFolder at /Plone/csb/editKz>,
    'loop': <Products.PageTemplates.TALES.SafeMapping object at
    0x05F909B8>,
    'modules': <Products.PageTemplates.ZRPythonExpr._SecureModule Importer
    instance at 0x01625238>,
    'nothing': None,
    'options': {'args': (),
    'state':
    <Products.CMFFormController.ControllerState.Contro llerState object at
    0x05E8E210>},
    'repeat': <Products.PageTemplates.TALES.SafeMapping object at
    0x05F909B8>,
    'request': <HTTPRequest,
    URL=http://localhost/csb/editKz/fg_base_view>,
    'root': <Application at >,
    'template': <ControllerPageTemplate at /Plone/fg_base_view used for /Plone/csb/editKz>,
    'traverse_subpath': [],
    'user': <PropertiedUser 'admin'>}
    Module Products.PageTemplates.ZRPythonExpr, line 47, in __call__
    - __traceback_info__: here.getAddableTypesInMenu(allowedTypes)
    Module Python expression "here.getAddableTypesInMenu(allowedTypes)", line 1, in <expression>
    Module Products.CMFCore.FSPythonScript, line 108, in __call__
    Module Shared.DC.Scripts.Bindings, line 311, in __call__
    Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec
    Module Products.CMFCore.FSPythonScript, line 164, in _exec
    Module None, line 20, in getAddableTypesInMenu
    - <FSPythonScript at /Plone/getAddableTypesInMenu used for /Plone/csb/editKz>
    - Line 20
    UnicodeDecodeError: 'ascii' codec can't decode byte 0xfc in position 6:
    ordinal not in range(12
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Interessierte/r
    Registriert seit
    24.09.2006
    Ort
    Nordhessen
    Beiträge
    127
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Hallo Petra,
    schreib doch mal den Maintainer von PloneFormGen an - der hat mir auch schonmal fix geholfen.

    Die Lösung würde mich sehr interessieren, weil ich die auf einer Seite auch im anderen Kontext habe.

    Viel Erfolg!

Ähnliche Themen

  1. Umstellung...auf Laptop (was ist mit XP 2.0?)
    Von Ghost Horse im Forum Computer - Internet Forum
    Antworten: 7
    Letzter Beitrag: 22.01.2008, 21:28
  2. PloneFormGen
    Von malogo im Forum Zope & Plone - das deutsche Hilfeforum
    Antworten: 1
    Letzter Beitrag: 05.07.2007, 12:16
  3. Header im Formular (PloneFormGen)
    Von guessti im Forum Zope & Plone - das deutsche Hilfeforum
    Antworten: 0
    Letzter Beitrag: 18.04.2007, 11:46
  4. PloneFormGen Fehler
    Von Gascht im Forum Zope & Plone - das deutsche Hilfeforum
    Antworten: 2
    Letzter Beitrag: 13.03.2007, 15:45

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •