Ergebnis 1 bis 9 von 9

Thema: Riesenproblem mit Kontaktformular! Hilfe gesucht!

  1. #1
    Meister(in) Avatar von Mütze
    Registriert seit
    04.04.2005
    Ort
    Bärlin
    Beiträge
    318
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard Riesenproblem mit Kontaktformular! Hilfe gesucht!

    Hallo,
    Die Website ist noch nicht online. Läuft unter Xampp auf dem Rechner.

    habe mir unter Zuhilfenahme des Standard Formularmakers (gibt's überall im www) ein Kontaktformular gebastelt. Man kann es ganz normal ausfüllen und es kommen auch die Meldungen, wie "Bitte geben Sie eine gültige E-Mail Adresse ein!", etc.
    Klicke ich dann auf "Senden", sendet er nicht, sondern öffnet meinen Thunderbird und im Textfeld stehen Teile des Scriptes (Sendermail u.Ä.).
    Hat Jemand einen Ratschlag für mich, möglichst einfach erklärt? Bin kein Coder, kann nur HTML und CSS für den Hausgebrauch.
    Schon mal ein Riesen-Danke im voraus. :P

    LG
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!
    ..... und wo lassen Sie denken?

  2. #2
    Meister(in)
    Registriert seit
    27.04.2006
    Ort
    Wien
    Beiträge
    263
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Schon mal überlegt, dass die PHP mail() Funktion nicht auf einem virtuellen Server funktioinert, da es keinen MailServer gibt? Es bleibt dir nichts anderes über als es auf deinem Webspace zu testen.

  3. #3
    Meister(in)
    Themenstarter
    Avatar von Mütze
    Registriert seit
    04.04.2005
    Ort
    Bärlin
    Beiträge
    318
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Danke.
    ich sag' ja, dass ich da noch doof bin. Ohne smtp o.ä. läuft nix.
    Nochmals Danke.

    LG
    ..... und wo lassen Sie denken?

  4. #4
    Shogun Avatar von DarkSyranus
    Registriert seit
    28.03.2006
    Ort
    ::1/128
    Alter
    25
    Beiträge
    3.446
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings
    Blog-Einträge
    1

    Standard

    Zitat Zitat von Mütze
    Danke.
    ich sag' ja, dass ich da noch doof bin. Ohne smtp o.ä. läuft nix.
    Nochmals Danke.

    LG
    Welchen xampp hast du denn?
    Bei mir ist nen mailserver mit bei, nennt sich Mercury.
    Kleine Anleitung gibts hier.

    Das Wichtigste steht soweit ich bemerkt habe bis post 6.

  5. #5
    Meister(in)
    Themenstarter
    Avatar von Mütze
    Registriert seit
    04.04.2005
    Ort
    Bärlin
    Beiträge
    318
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Hi, :P
    Mercury hab' ich auch. Habe ihn gerade angeworfen, nachdem ich die Verzeichnisse, die Richtigen meine ich, hineingepackt habe.
    Jetzt läuft auch das Kontaktformular.
    Danke, soweit war ich noch nicht.

    LG
    ..... und wo lassen Sie denken?

  6. #6
    Meister(in)
    Registriert seit
    27.04.2006
    Ort
    Wien
    Beiträge
    263
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    ja das habe ich vergessen zu erwähnen, sorry. Natürlich kannst du auch lokal einen Mail Server installieren, aber wie ich sehe hast du es schon geschafft!

    Viel Spaß noch

  7. #7
    HTML Newbie
    Registriert seit
    17.12.2006
    Ort
    Hamburg
    Beiträge
    2
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    ich hab auch n problem mit meinem formular. Es wird zwar über den server und ne .pl datei and die emailadresse geschickt aba die email die ankommt ist leer. Versteh ich nich. quelltext sieht so aus. die email adresse hab ich geändert weil ich nich will das man meine seite schon besuchen kann. *grins* is mir noch nich weit genug.....




    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">

    <head>

    <meta content="text/html; charset=ISO-8859-1" http-equiv="content-type" />
    <title>feedbackformular</title>

    <link rel="stylesheet" type="text/css" href="formate.css">

    <style type="text/css"></style>
    </head>

    <body>

    <h2>Feedback und Verbesserungsvorschläge</h2>

    <form name="feedback" method="post" action="/cgi-bin/email2.pl">
    <input type="hidden" name="empf" value="e-mail@blablabla.de"/>



    Vorname:

    <input name="vorname" value="Vorname" onclick="document.feedback.vorname.value=''">


    Nachname:
    <input name="nachname" value="Nachname" onclick="document.feedback.nachname.value=''">







    Mir hat die seite gefallen



    <input value="Ja" name="umfrage" type="radio">Ja


    <input value="Nein" name="umfrage" type="radio">Nein

    <textarea name="textfeld" cols="42" rows="10">
    Kommentare und Verbesserungsvorschl&auml;ge:
    </textarea>





    <input value="Zurücksetzen" type="reset"/>


    <input value="Abschicken" type="submit" />



    </form>



    </body>
    </html>





    Danke schonmal im vorraus

  8. #8
    Shogun Avatar von DarkSyranus
    Registriert seit
    28.03.2006
    Ort
    ::1/128
    Alter
    25
    Beiträge
    3.446
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings
    Blog-Einträge
    1

    Standard

    Und wo ist der Inhalt der .pl Datei?
    Die verschickt ja schliesßlich die Mail.

  9. #9
    HTML Newbie
    Registriert seit
    17.12.2006
    Ort
    Hamburg
    Beiträge
    2
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    problem hat sich von selber gelöst. In den mails steht irgendwie ganz komischerweise jez plötzlich was drin ( in den die schon angekommen waren)

    versteh ich nicht aba so ist es mir auch recht

    trotzdem danke

Ähnliche Themen

  1. kontaktformular hilfe
    Von im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 0
    Letzter Beitrag: 05.06.2008, 20:21
  2. Hilfe bei dem Kontaktformular
    Von forummx im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 1
    Letzter Beitrag: 09.06.2007, 17:44
  3. Hilfe beim erstellen von Umfragen und Kontaktformular!
    Von Ausgeber im Forum Zope & Plone - das deutsche Hilfeforum
    Antworten: 5
    Letzter Beitrag: 08.04.2007, 13:39
  4. Riesenproblem
    Von @lex im Forum HTML & CSS Forum
    Antworten: 3
    Letzter Beitrag: 17.01.2006, 12:26
  5. Antworten: 9
    Letzter Beitrag: 21.04.2005, 00:50

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •