Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: Validieren - Doctype Problem

  1. #1
    Teeny
    Registriert seit
    30.10.2006
    Beiträge
    30
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard Validieren - Doctype Problem

    Hallo zusammen, bin neu hier...

    Habe eine Homepage erstellt und vergessen den Doctype reinzuschreiben. Nun wenn ich das nun nachführe verliert mein Footer die Eigenschaften, der gesamte Body wird nicht mehr wie gewünscht in 100% angegeben sondern je nach Text länge. Ich hoffe ihr könnt mir da ein wenig helfen wie gesagt ich bin neu auch auf dem Gebiet HTML. Kann gut sein das die Page einige Fehler hat. Das Thema Doctype habe ich auf Selfhtml angeschaut da gibz einige. Nun wie finde ich heraus welche ich benutzt habe....

    http://wayneboyan.wa.ohost.de/index.html

    PS: Links funktionieren absichtlich noch net.
    PPS: Wie findet ihr die Page grafisch!?[/url]
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Gast

    Standard

    Hallo

    Vieleicht hilft dir dieser Artikel weiter:

    http://puredesign.ch/lounge/artikel/doctype.shtml

    Graphisch gefällt mir deine Seite eigentlich ganz gut. Sie ist gut strukturiert und angenehm fürs Auge. Nur die Schrift finde ich ein wenig trivial. Vieleicht liegt es aber auch daran, dass ich die von dir gewählte Schrift nicht installiert haben.

    Gruss

    http://www.css-garden.ch

  3. #3
    Gast

    Standard

    Nun ja ok ich nehme nun ein standartisiertes Doctype... keine ahnung warum das aber ok.... Wie schon erwähnt es funktioniert nicht dieses Doctype ist Gift für meine Webpage......

    Hier der direkte vergleich:

    So soll die Page aussehen (leider ohne Doctype)...
    http://wayneboyan.wa.ohost.de/

    Und so sieht Sie aus mit Doctype.... *auffooterschau*
    http://wayneboyan.wa.ohost.de/2/index.html

    Einige eigenschaften werden vom Doctype einfach ignoriert... please help

  4. #4
    Forum Guru
    Registriert seit
    14.06.2004
    Ort
    Schleswig-Holstein
    Beiträge
    5.439
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Moin!

    Warum nimmst du denn ein XHTML-Doctyp, wenn du gar kein XHTML-Quelltext hast?

    Nimm
    Code:
    <!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">
    dann sollte es passen, oder es sind Fehler im Quelltext.

    G.a.d.M.

    Ronald

  5. #5
    Teeny
    Themenstarter

    Registriert seit
    30.10.2006
    Beiträge
    30
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    funktioniert immer noch nicht...

    Meine versuche hier...

    http://wayneboyan.wa.ohost.de/2/index.html
    http://wayneboyan.wa.ohost.de/3/index.html
    http://wayneboyan.wa.ohost.de/4/index.html

    Jungs bitte.... Es ligt am Code^^ der is nicht standartisiert das ist dschungel Code php java html css wild gemixt...

  6. #6
    Forum Guru
    Registriert seit
    14.06.2004
    Ort
    Schleswig-Holstein
    Beiträge
    5.439
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Inkeinem der drei Beispiele finde ich den Dokumentenyp so, wie ich ihn angegeben habe.
    Du hast immer noch etwas dazu geschrieben, warum?

  7. #7
    Teeny
    Themenstarter

    Registriert seit
    30.10.2006
    Beiträge
    30
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Nun das kann ich dir beantworten...

    Die original page ist so wie du sie willst. Hier:

    http://wayneboyan.wa.ohost.de/

    Nun Layout ist so wie ich es haben will aber wenn ich die validieren will. -->

    This page is not Valid (no Doctype found)!

    Also wie wenn ich deine Zeile NICHT schreiben würde. Die hat wohl NULL effekt ohne das zusätzliche.

  8. #8
    Forum Guru
    Registriert seit
    14.06.2004
    Ort
    Schleswig-Holstein
    Beiträge
    5.439
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Aber es steht doch ein Doctype in der Seite http://wayneboyan.wa.ohost.de/
    und mein Validator mault nicht.

    Allerdings macht er folgende Anmerkungen:
    Code:
    Zeile 105 Zeichen 6 - Warnung&#58; Zu viele Bindestriche im Kommentar
    Zeile 131 Zeichen 6 - Warnung&#58; Zu viele Bindestriche im Kommentar
    Zeile 143 Zeichen 6 - Warnung&#58; Zu viele Bindestriche im Kommentar
    Zeile 145 Zeichen 10 - Warnung&#58; Zu viele Bindestriche im Kommentar
    Zeile 144 Zeichen 4 - Warnung&#58; <style> ist in <div> Elementen nicht erlaubt
    Zeile 163 Zeichen 6 - Warnung&#58; Unzulässiges <body> löschen
    Zeile 164 Zeichen 18 - Warnung&#58; Unmaskiertes "&" sollte als "&amp;" geschrieben werden
    Zeile 169 Zeichen 10 - Warnung&#58; Zu viele Bindestriche im Kommentar
    Zeile 172 Zeichen 10 - Warnung&#58; Zu viele Bindestriche im Kommentar
    Zeile 20 Zeichen 2 - Warnung&#58; Fehlendes </div>
    Zeile 22 Zeichen 2 - Warnung&#58; Element <table> hat proprietäres Attribut "height"
    Zeile 25 Zeichen 3 - Warnung&#58; Element <td> hat proprietäres Attribut "background"
    Zeile 25 Zeichen 3 - Warnung&#58; Element <td> hat proprietäres Attribut "text"
    Zeile 100 Zeichen 3 - Warnung&#58; Element <td> hat proprietäres Attribut "background"
    Zeile 100 Zeichen 3 - Warnung&#58; Element <td> hat proprietäres Attribut "text"
    Zeile 102 Zeichen 3 - Warnung&#58; Element <td> hat proprietäres Attribut "text"
    Zeile 136 Zeichen 4 - Warnung&#58; Element <td> hat proprietäres Attribut "background"
    Zeile 136 Zeichen 4 - Warnung&#58; Element <td> hat proprietäres Attribut "text"
    Zeile 141 Zeichen 4 - Warnung&#58; Element <td> hat proprietäres Attribut "background"
    Zeile 141 Zeichen 4 - Warnung&#58; Element <td> hat proprietäres Attribut "text"
    
    0 Fehler / 20 Warnungen
    und damit hat er auch recht, wenn ich es richtig sehe.

    Die Seite wird ja auch fast gut angezeigt, wenn man davon absieht, daß die Linkliste etwa 10 px zu kurz ist.

    G.a.d.M.

    Ronald

  9. #9
    Teeny
    Themenstarter

    Registriert seit
    30.10.2006
    Beiträge
    30
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Echt ez !?

    Hab Firefox 2.0^^ sieht schön aus bei mir....

    IE klappt sogar CSS
    Opera siehts auch schön aus... was hast den für'n Browser !?

    Screenshot wäre cool danke !

    (Nun ja ich validiere mit dem W3C Validator von http://validator.w3.org/ )

  10. #10
    Shogun Avatar von DarkSyranus
    Registriert seit
    28.03.2006
    Ort
    ::1/128
    Alter
    25
    Beiträge
    3.446
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings
    Blog-Einträge
    1

    Standard

    Moin
    Bei mir sieht die Seite sowohl im IE als auch im FF richtig aus, abgesehen wie Ronald schon sagt, der Linkliste.

    Probier mal folgenden Doctype:
    Zitat Zitat von doctype
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN">
    Groß- und Klein- Schreibung beachten.

Ähnliche Themen

  1. Website validieren!
    Von goldeneye im Forum HTML & CSS Forum
    Antworten: 2
    Letzter Beitrag: 07.08.2008, 14:06
  2. Validieren kleine Frage...
    Von Dragooni im Forum HTML & CSS Forum
    Antworten: 2
    Letzter Beitrag: 03.07.2007, 22:05
  3. Webseite validieren?
    Von Andreas84 im Forum HTML & CSS Forum
    Antworten: 15
    Letzter Beitrag: 17.05.2007, 00:37
  4. Validieren???
    Von Shrek2k1 im Forum HTML & CSS Forum
    Antworten: 1
    Letzter Beitrag: 04.01.2007, 19:07
  5. Validieren
    Von xXx_BaSStar_xXx im Forum HTML & CSS Forum
    Antworten: 8
    Letzter Beitrag: 05.12.2006, 19:25

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •