Ergebnis 1 bis 6 von 6

Thema: Blödes iFrame Problem mit dem Internet Explorer!

  1. #1
    HTML Newbie
    Registriert seit
    26.10.2006
    Beiträge
    3
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard Blödes iFrame Problem mit dem Internet Explorer!

    Hallo liebe HTML-Experten!

    Nach einer aufregenden Stufenfahrt, wollte ich die festgehaltenen Momente angemesen Würdigen und alle Fotos online stellen. Dies geht ohne weitere Probleme mit vorgefertigten PHP-Seiten. Alles schön und gut, aber da ich aufs Design großen Wert lege ergab sich folgendes Problem:
    Das von mir benutzte iFrame, dass die PHP-Seite anzeigt auf welcher alle Bilder drauf sind wird von allen Browsern so angezeigt wie ich es haben wollte, doch wie es kommen musste machte mir die Crew um Bill Gates einen Strich durch die Rechnung. Der Internet Explorer interpretiert dass auf einer Tabelle liegende iFrame eigenständig und zeigt die PHP-Seite daher einfach oben im Browser an, und der Rest der Homepage (die Tabelle) einfach da drunter.
    Hier der Link zur besagten Seite:

    http://jamaicafeelin.ja.ohost.de/NeapelfahrtBilder.html

    Und natürlich der Quelltext:
    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http&#58;//www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http&#58;//www.w3.org/1999/xhtml">
    
    <head>
    <script language="JavaScript1.2">
    function disableselect&#40;e&#41;&#123;
    return false
    &#125;
    function reEnable&#40;&#41;&#123;
    return true
    &#125;
    document.onselectstart=new Function &#40;"return false"&#41;
    if &#40;window.sidebar&#41;&#123;
    document.onmousedown=disableselect
    document.onclick=reEnable
    &#125;
    </script>
    <title>Neapel 2006 | Bilder</title>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
    <link rel="stylesheet" href="http&#58;//jamaicafeelin.ja.ohost.de/Files/mm_lodging1.css" type="text/css" /><style type="text/css">
    <!--
    body &#123;
    	background-color&#58; #fd8c1d;
    &#125;
    .Stil1 &#123;color&#58; #fd8c1d&#125;
    #Layer1 &#123;
    	position&#58;absolute;
    	width&#58;530px;
    	height&#58;327px;
    	z-index&#58;1;
    	left&#58; 451px;
    	top&#58; 261px;
    &#125;
    a&#58;visited &#123;
    	color&#58; #CC0000;
    &#125;
    a&#58;active &#123;
    	color&#58; #990000;
    &#125;
    #Layer2 &#123;
    	position&#58;absolute;
    	left&#58;492px;
    	top&#58;235px;
    	width&#58;469px;
    	height&#58;294px;
    	z-index&#58;1;
    &#125;
    body,td,th &#123;
    	font-family&#58; Georgia, Times New Roman, Times, serif;
    &#125;
    .Stil2 &#123;font-family&#58; Georgia, "Times New Roman", Times, serif&#125;
    .Stil3 &#123;color&#58; #FD8C1D&#125;
    #Layer3 &#123;
    	position&#58;absolute;
    	left&#58;443px;
    	top&#58;212px;
    	width&#58;569px;
    	height&#58;244px;
    	z-index&#58;1;
    &#125;
    #Layer4 &#123;
    	position&#58;absolute;
    	left&#58;444px;
    	top&#58;197px;
    	width&#58;573px;
    	height&#58;274px;
    	z-index&#58;1;
    &#125;
    .Stil4 &#123;	font-size&#58; 9px;
    	color&#58; #FFCC33;
    &#125;
    -->
    </style></head>
    <body>
    <table width="100%" border="0" cellspacing="0" cellpadding="0">
    	<tr>
    	<td width="15" nowrap="nowrap"> </td>
    
    	<td height="151" colspan="2" class="logo" nowrap="nowrap">   
    
    <span class="Stil2">[img]http&#58;//jamaicafeelin.ja.ohost.de/Pics/Neapel2006Web.jpg[/img]</span></p>	  </td>
    	<td width="1"></td>
    	</tr>
    
    	<tr bgcolor="#ffffff">
    	<td colspan="4">[img]http&#58;//jamaicafeelin.ja.ohost.de/Files/mm_spacer.gif[/img]</td>
    	</tr>
    
    	<tr bgcolor="#a4c2c2">
    
    	<td width="15" nowrap="nowrap" bgcolor="#CC0033"></td>
    	<td height="36" bgcolor="#CC0033" class="navText" id="navigation"></td>
    	<td bgcolor="#CC0033"></td>
    	<td width="1" bgcolor="#CC0033"></td>
    	</tr>
    
    	<tr bgcolor="#ffffff">
    	<td colspan="4">[img]http&#58;//jamaicafeelin.ja.ohost.de/Files/mm_spacer.gif[/img]</td>
    	</tr>
    
    	<tr bgcolor="#ffffff">
    	<td valign="top" width="15">[img]http&#58;//jamaicafeelin.ja.ohost.de/Files/mm_spacer.gif[/img]</td>
    	<td valign="top" width="35">[img]http&#58;//jamaicafeelin.ja.ohost.de/Files/mm_spacer.gif[/img]</td>
    	<td width="889" valign="top">
    
    	<table width="882" height="290" border="0" cellpadding="2" cellspacing="0">
            <tr>
              <td class="pageName" colspan="3">Picturez of MPG 13 </td>
            </tr>
    
           <tr>
             <td width="225" valign="bottom" class="subHeader Stil3">Piano di Sorrento </td>
    		 <td width="378" rowspan="2"></td>
    		 <td width="201" height="100" rowspan="2"></td>
            </tr>
            <tr>
              <td height="230" valign="top" class="bodyText"><p class="Stil2">Hier k&ouml;nnt Ihr euch Bilder der Jahrgangsstufenfahrt 13 des MPG angucken. </p>
    
                <p class="Stil2">Viel Spa&szlig; dabei! </p>
              <p class="Stil2">Zur&uuml;ck </p></td>
            </tr>
          </table>
    	   
    
    
    	  
    	</td>
    	<td></td>
    	
    	</tr>
    	<tr bgcolor="#ffffff">
    	  <td valign="top"></td>
    	  <td valign="top"></td>
    	  <td align="right" valign="bottom"><span class="Stil4">&copy;alexdesignz</span></td>
    	  <td></td>
    
      </tr>
    
    
    	<tr>
    	<td width="15"></td>
        <td width="35"></td>
        <td width="889"></td>
    	<td width="1"></td>
    	
    
    	<iframe src="http&#58;//jamaicafeelin.ja.ohost.de/Files/showit/index.php" name="Bilder" width="650" height="480"
            marginheight="20" marginwidth="20" frameborder="0" align="right">
      
    
    Ihr Browser kann leider keine eingebetteten Frames anzeigen</p>
    </iframe>
    
    
      </tr>
    </table>
    </body>
    </html>
    Habe das iFrame in alle Spalten und Zeilen reingeschrieben, aber der Sch*** Internet Explorer zeigt es einfach nich so an wie ich es will!
    Was noch zu sagen ist, habe bewusst keine "echten" Frames genommen, da sie nicht meinem Designwunsch entsprechen.

    Saß gestern mehrer Stunden dran, aber es will einfach nicht klappen, und ich will nunmal nicht die restlichen Leute meiner Stufe enttäuschen die den Standartbrowser Internet Explorer verwenden!!!

    Bitte helft mir!!! Würde mich unglablich freuen, wenn ich das Problem endlich in den Griff bekommen würde.
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Fortgeschrittene/r
    Registriert seit
    30.09.2006
    Beiträge
    150
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    du hast den iframe nicht verschachtelt einfach nur mitten in die tabelle gepackt die <td> tags fehlen !

    das kann daran liegen !
    Suchst du kostenlose Scripte ?

    dann klick hier
    http://rescue-center.de

  3. #3
    HTML Newbie
    Themenstarter

    Registriert seit
    26.10.2006
    Beiträge
    3
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Ja hast natürlich Recht, aber wenn ich das mit den <td> in die Tabelle einbette, wird das Fenster verschoben dargestellt, mit scrollen usw.
    Und ich weiss nicht wie ich dass Tabellenschema sonst so hinkriegen soll, dass die linke Seite der HP vom Aussehen so erhalten bleibt (siehe Link; Ansicht mit Firefox, Safari etc).
    Ach, und was ich gerade gehört hab von nem Freund, dass es nicht nur an dem von mir kritisierten internet Explorer liegt. Opera hat wohl das gleiche Problem. Trotzdem komisch, dass Firefox und Safari(auf nem Mac) dass "richtig", bzw so anzeigen wie ich es will. Ist wahrscheinlich nur ein "Effekt" dieser Browserm, die die Fehlposition des iFrames übergehen und es einfach überlagern. Die anderen Browser, wie IE, sind da wohl genauer und wollen exakte Programmierung. Doch dann stellt sich mir die Frage wie soll ich dass so hinbekommen wie ich es will?
    So soll dass Design nämlich bleiben:
    http://jamaicafeelin.ja.ohost.de/Neapelfahrt.html
    Und so dann mit der PHP-Seite:
    http://jamaicafeelin.ja.ohost.de/NeapelfahrtBilder.html(optimale ansicht nur in Firefox bzw. Safari)

    Hoffe mir kann jemand trotzdem weiterhelfen!

  4. #4
    Fortgeschrittene/r
    Registriert seit
    30.09.2006
    Beiträge
    150
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    dann mach es mit einem div container denn es muss ja die tabelle dan überlagern

    so
    Code:
    <div style="position&#58;absolute;top&#58;80px;left&#58;500px;><iframe src="bla.php"></iframe></div>
    die top und left werte muss du natürlich anpassen du kannst auch statt left right nehemen muss du mal schauen was besser ist !
    Suchst du kostenlose Scripte ?

    dann klick hier
    http://rescue-center.de

  5. #5
    HTML Newbie
    Themenstarter

    Registriert seit
    26.10.2006
    Beiträge
    3
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Danke für den Tipp! Habs aberbissel anders gemacht. Mit CSS nen Layer deklariert und dann mit <div id="Layer1"> eingefügt. Sieht jetzt supercool aus, auch im IE und Opera!

  6. #6
    Forum Guru
    Registriert seit
    14.06.2004
    Ort
    Schleswig-Holstein
    Beiträge
    5.439
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Zitat Zitat von Jamaicafeelin
    Sieht jetzt supercool aus, auch im IE und Opera!
    Stimmt, sieht cool aus: die hälfte deines Iframe ist außerhalb des Monitors (bei 1152 x 864 Pixel). Und wenn man dann nach rechts scrollt, dann ist das Layout ziemlich zerrissen.
    Wen du mich fragst, dann sieht das ziemlich sch.... aus.

    Schau dir mal deine PN an, ich hab dir vorhin schon eine Lösung geschickt.

    G.a.d.M.

    Ronald

Ähnliche Themen

  1. Problem im Internet Explorer
    Von stivi im Forum HTML & CSS Forum
    Antworten: 10
    Letzter Beitrag: 20.07.2008, 04:33
  2. Internet Explorer Problem
    Von pherison im Forum Zope & Plone - das deutsche Hilfeforum
    Antworten: 4
    Letzter Beitrag: 14.08.2007, 18:07
  3. Problem mit Internet Explorer / iframe
    Von sie-23 im Forum HTML & CSS Forum
    Antworten: 4
    Letzter Beitrag: 19.07.2007, 23:47
  4. background, problem mit internet explorer
    Von MeanMachine im Forum HTML & CSS Forum
    Antworten: 5
    Letzter Beitrag: 28.12.2006, 14:18
  5. Problem mit Imageanzeige im Internet Explorer
    Von David im Forum HTML & CSS Forum
    Antworten: 1
    Letzter Beitrag: 09.08.2006, 22:47

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •