Ergebnis 1 bis 6 von 6

Thema: Bug: Unerwünschter, großer Balken

  1. #1
    HTML Newbie
    Registriert seit
    24.10.2006
    Beiträge
    7
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard Bug: Unerwünschter, großer Balken

    Hallo zusammen!

    Mich plagt schon seit langem ein ziemlich nervendes Problem.

    Vor einem Monat konnte ich meinen neuen Weblog ins WWW stellen.

    Zu folgendem Problem:
    Wenn ihr meinen Weblog mit Internet Explorer oder Opera aufschaltet, könnt ihr einen riesigen schwarzen Balken in der unteren Navigation entdecken - ein riesiges Stück fehlt, einfach weggeschnitten. Wenn ihr die Seite per Mozilla Firefox aufruft, ist die Seite perfekt präsent. Diesen Bug kann ich mir nicht erklären. Der Weblog läuft unter dem offiziellen CMS von WordPress. In den Entwicklerforen erbat ich nach der Erstentdeckung dieses Bugs professionelle Hilfe von anderen Autoren (Bloggern), die dieses CMS mehr als gut kannten. Allerdings rieten sie mir nur zu einer HTML-Validation von W3C, die mir auch nicht besonders weiterhalf.

    Der Bug versteckt sich definitiv in der footer.php:
    Code:
    <?php
      get_sidebar&#40;&#41;;
    ?>
    
                            </div>
                          </td>
                        </tr>
                      </table>
                    </td>
                  </tr>
                  <tr>
                    <td style="background&#58; url&#40;'<?php bloginfo&#40;'stylesheet_directory'&#41;; ?>/images/back16.jpg'&#41; left repeat-y; height&#58; 100%; vertical-align&#58; top; text-align&#58; left;"><div id="blindworks" style="padding&#58; 5px 0 0 58px;"></div></td>
                  </tr>
                  <tr>
                    <td style="height&#58; 230px; background&#58; url&#40;'<?php bloginfo&#40;'stylesheet_directory'&#41;; ?>/images/back11.jpg'&#41; no-repeat bottom left; height&#58; 230px;"></td>
                  </tr>
                </table></td>
            </tr>
            <tr>
              <td colspan="2" style="background&#58; url&#40;'<?php bloginfo&#40;'stylesheet_directory'&#41;; ?>/images/back99.jpg'&#41; no-repeat;"></td>
            </tr>
          </table>
        </td>
      </tr>
    </table>
    
    </body>
    </html>
    Da der HTML-Validator keinerlei signifikanten Fehler in dieser Datei anzeigt, kann dieses Problem so nicht gelöst werden. Irgendeine Einstellung muss abgeändert werden, damit sich die untere Navigation nicht streckt. Vielleicht liegt's an einer Pixeleinstellung oder einem Fehler im Stylesheet? Ich besitze HTML-Grundkenntnisse, kann mich in diesem Gewirr aber nicht zurecht finden.

    Könnt ihr mir weiterhelfen? Nicht einmal in der WordPress-Gemeinschaft fand ich welche.
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Forum Guru
    Registriert seit
    04.04.2005
    Beiträge
    4.139
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Mach mal ein font-size:1px; rein.

    Ein Link wäre schön damit man sich das ganze einmal anschauen könnte
    Facebook Gruppe: Böses Encoding

  3. #3
    Meister(in)
    Registriert seit
    25.04.2005
    Ort
    Wuppertal
    Beiträge
    277
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Versuch ma so...
    Weiß net genau ob geht oO:

    Code:
    <?php
      get_sidebar&#40;&#41;;
    ?>
    
                            </div>
                          </td>
                        </tr>
                      </table>
                    </td>
                  </tr>
                  <tr>
                    <td background="<?php bloginfo&#40;'stylesheet_directory'&#41;; ?>/images/back16.jpg" height="100%"></td>
                  </tr>
                  <tr>
                    <td style="height&#58; 230px; background&#58; url&#40;'<?php bloginfo&#40;'stylesheet_directory'&#41;; ?>/images/back11.jpg'&#41; no-repeat bottom left; height&#58; 230px;"></td>
                  </tr>
                </table></td>
            </tr>
            <tr>
              <td colspan="2" style="background&#58; url&#40;'<?php bloginfo&#40;'stylesheet_directory'&#41;; ?>/images/back99.jpg'&#41; no-repeat;"></td>
            </tr>
          </table>
        </td>
      </tr>
    </table>
    
    </body>
    </html>
    Mfg Gigazone

  4. #4
    HTML Newbie
    Themenstarter

    Registriert seit
    24.10.2006
    Beiträge
    7
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Zitat Zitat von ::RMB::
    Ein Link wäre schön damit man sich das ganze einmal anschauen könnte
    Link ist im ersten Beitrag vorhanden: http://BLOGSPIRACY.com

    Werde Eure Vorschläge versuchen.

    Hier ist eine kleine Beschreibung der signifikanten Grafiken, die womöglich etwas mit dem Bug zu tun haben könnten:


  5. #5
    HTML Newbie
    Themenstarter

    Registriert seit
    24.10.2006
    Beiträge
    7
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    An Gigazone: Leider funktionierte deine Variante nicht. Der Code verdoppelte die äussere Steinmauer.

    An RMB: Wo soll ich die "font size 1 pixels" einfügen? Die Schriftgrösse ist hier ja nicht relevant. Das Problem sollte zwischen den beiden oben aufgeführten Grafiken liegen. Irgendeine Einstellung veranlasst die untere Navigation so, dass sie sich komplett strecken muss.

    Hier nochmals der Code von der footer.php:
    Code:
    <?php
      get_sidebar&#40;&#41;;
    ?>
    
                            </div>
                          </td>
                        </tr>
                      </table>
                    </td>
                  </tr>
                  <tr>
                    <td style="background&#58; url&#40;'<?php bloginfo&#40;'stylesheet_directory'&#41;; ?>/images/back16.jpg'&#41; left repeat-y; height&#58; 100%; vertical-align&#58; top; text-align&#58; left;"><div id="blindworks" style="padding&#58; 5px 0 0 58px;"></div></td>
                  </tr>
                  <tr>
                    &#91;b&#93;<td style="height&#58; 230px; background&#58; url&#40;'<?php bloginfo&#40;'stylesheet_directory'&#41;; ?>/images/back11.jpg'&#41; no-repeat bottom left; height&#58; 230px;"></td>
                  </tr>
                </table></td>
            </tr>
            <tr>
              <td colspan="2" style="background&#58; url&#40;'<?php bloginfo&#40;'stylesheet_directory'&#41;; ?>/images/back99.jpg'&#41; no-repeat;"></td>&#91;/b&#93;
            </tr>
          </table>
        </td>
      </tr>
    </table>
    
    </body>
    </html>
    ... und hier noch ein kleiner Ausschnitt des Bugs (sieht bei IE und Opera gleich aus):


    Der schwarze Balken streckt sich bis unten in den Footer-Bereich.

  6. #6
    HTML Newbie
    Themenstarter

    Registriert seit
    24.10.2006
    Beiträge
    7
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Weiß denn niemand weiter?

Ähnliche Themen

  1. Bitte verwenden Sie keine Wörter die in unerwünschter Werbun
    Von Bienchen1984 im Forum Forum-Hilfe.de intern
    Antworten: 3
    Letzter Beitrag: 01.11.2006, 12:58
  2. Handling großer Datenmengen
    Von dulldeidi im Forum Zope & Plone - das deutsche Hilfeforum
    Antworten: 5
    Letzter Beitrag: 20.10.2006, 18:29
  3. Großer Counter?
    Von Gigazone im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 3
    Letzter Beitrag: 07.04.2006, 21:20

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •