Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11

Thema: PHP-Nuke 8.0 + Funpic probs!!!

  1. #1
    Azubi(ne)
    Registriert seit
    19.06.2005
    Beiträge
    79
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard PHP-Nuke 8.0 + Funpic probs!!!

    Hallo Leute,

    Kurze Beschreibung:

    Habe mir Kostenlosen Webspace bei funpic.de besorgt.

    Habe PHP-Nuke 8.0 und über FTP hochgeladen.
    Die Site wird richtig angezeigt, außer das oben die Warnung steht.

    Warning: ini_set() has been disabled for security reasons in /usr/export/www/vhosts/funnetwork/hosting/matsonic/mainfile.php on line 259

    Wäre nett wenn mir jemand sagen könnte was das heißt und wie ich diesen Fehler beheben kann.

    Bedanke mich im vorraus für jede Antwort/Hilfe.
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!

  2. #2
    Azubi(ne)
    Themenstarter

    Registriert seit
    19.06.2005
    Beiträge
    79
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    kann mir keiner helfen ???

  3. #3
    meikschmidt
    Gast

    Standard

    Kann mir keiner helfen? - Es ist Nacht, viele schlafen jetzt. Heute kommt bestimmt noch die richtige Antwort

    steht ja eigentlich schon da was los ist:

    "ini_set()ist aus Sicherheit Gründen gesperrt worden" was in der Datei mainfile.php in der zeile 259 definiert wurde. aber da wissen die experten in sachen php mehr als ich.

  4. #4
    Kaiser(in)
    Registriert seit
    09.12.2005
    Alter
    29
    Beiträge
    2.496
    Danke
    1
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    das is eine funktion in php, und die wurde von funpic anscheinend ausgestellt.
    mehr nich, kann man sich aber doch auch denken °_°
    Sei immer du selbst. Außer du kannst Batman sein. Sei immer Batman!

  5. #5
    GAST
    Gast

    Standard ANTWORT

    WÜRDE MAL DIE ZEILE LÖSCHEN UND NEU UPLOADEN DANN GEHTS AUCH MIT DEM NACHBARN..ne dann ghetsecht....löschen die zeile...

  6. #6
    Kaiser(in)
    Registriert seit
    09.12.2005
    Alter
    29
    Beiträge
    2.496
    Danke
    1
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    super idee, aus einem fertigen script einfach mal ne zeile löschen
    Sei immer du selbst. Außer du kannst Batman sein. Sei immer Batman!

  7. #7
    N3tRunn3r
    Gast

    Standard IQ165

    Hi, habe mir eben phpNuke8 gezogen, als Open Source.

    Habe mich total ausgeGoogled, gerade zu diesem Thema:
    Warning: ini_set() has been disabled for security reasons in /usr/export/www/vhosts/funnetwork/hosting/xxxxxx/mainfile.php on line 259

    Nichts ausserordentliches gefunden, bis ich auf eine blanke Idee gekommen bin.

    Öffnet die config.php, sucht den Eintrag: $display_errors = false;
    und bearbeitet diese Zeile so: $display_errors = "false";

    sichert das ganze ab, natürlich auch an das backup der alten config.php denken und uploaded es.
    Es waren nur simple "" zu setzen. Im ganzen GoogleSystem stand nichts von alldem drinne.

    Sollte es jedoch nicht funktionieren, öffnet die mainfile.php und versichert euch, dass ein @ vor ini_set('display_errors', 1); steht.
    Also: @ini_set('display_errors', 1);

    sichert das ab, wie immer und los gehts!
    __________________________________________________ ____

    So! Und nun nochmal alles zum Mitschreiben: << Schritt-für-Schritt >>

    Eine Kopie der "mainfile.php" erstellen, sowie config.php!
    Öffnet zuerst die mainfile.php, sucht den Eintrag ini_set('display_errors', 1); und setzt ein @ davor. Es sollte so aussehen:

    // Error reporting, to be set in config.php
    if($display_errors) {
    @ini_set('display_errors', 1);
    error_reporting(E_ALL^E_NOTICE);
    } else {
    ini_set('display_errors', 0);
    error_reporting(0);
    }

    Sichert die Datei ab und uppt es hoch. Nun refresht man sein phpNuke8. Die Meldung steht immer noch da...
    Daher öffnet die config.php, sucht den Eintrag $display_errors = false; und setzt 2 "" an false dran, so dass es so aussehen soll:

    $display_errors = "false";

    sichert auch die datei ab und uppt es ebenso hoch. Site nochmal refreshen und das ganze is weg!!!

    Ich nehme mal an, dass wie hier es mit einem lächerlichen Bug zu tun haben. Denn, sobald man nicht alles einzeln uploaded, sondern gleichzeitig die 2 files bearbeitet und hochladet, passiert überhauptnix!

    Ich habe es heute zum ersten mal mit php scripte zu tun und habe schon bald eine nette lösung gefunden, sowie es nirgends in inet steht!

    hf 8D

    BEST REGARDS

    N3tRunn3r

  8. #8
    muzzik
    Gast

    Standard Danke

    Danke es geht super

  9. #9
    Gast

    Standard

    ich könnte dich KÜSSEN

  10. #10
    Unregistriert
    Gast

    Lächeln AW: PHP-Nuke 8.0 + Funpic probs!!!

    Lieber N3tRunn3r ,

    auch von mir etwas verspätet viiiielen Dank

Ähnliche Themen

  1. php-Nuke
    Von htmlfreak im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 0
    Letzter Beitrag: 09.10.2007, 19:42
  2. PHP-Nuke
    Von htmlfreak im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 2
    Letzter Beitrag: 06.10.2007, 13:16
  3. PHP Nuke
    Von Alfred im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 6
    Letzter Beitrag: 08.05.2007, 11:48
  4. php-nuke
    Von kulo im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 2
    Letzter Beitrag: 10.01.2005, 21:56
  5. Php Nuke
    Von Nixchecker im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 6
    Letzter Beitrag: 25.07.2004, 16:30

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •