Ergebnis 1 bis 4 von 4

Thema: embed src erkennt den Pfad nicht

  1. #1
    Samurai
    Registriert seit
    07.08.2005
    Beiträge
    231
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard embed src erkennt den Pfad nicht

    Guten morgen zusammen!

    Erstmal den Quellcode:
    Code:
    				<table border='0' cellpadding='0' cellspacing='0'>
    					<tr>
    						<td background='img/fernseher-oben.jpg' colspan='3' height='95' width='600'></td>
    					</tr>
    					<tr>
    						<td background='img/fernseher-links.jpg' height='292' width='138'></td>
    						<td height='292' width='329'>
    							<?php
    							$play = $_GET&#91;"video"&#93;;
    							echo $play;
    							echo "<embed src=\"$play\" width='329' height='292' autostart='false' loop='false' hidden='false'>";
    							?>
    						</td>
    						<td background='img/fernseher-rechts.jpg' height='292' width='133'></td>
    					</tr>
    					<tr>
    						<td background='img/fernseher-unten.jpg' colspan='3' height='113' width='600'></td>
    					</tr>
    				</table>
    				
    
    
    				<?php
    					echo "
    					[img]img/boxing1.jpg[/img]
    					[img]img/boxing2.jpg[/img]
    
    					[img]img/koenen1.jpg[/img]
    					[img]img/koenen2.jpg[/img]
    
    					[img]img/filmche.jpg[/img]
    					[img]img/blowjob.jpg[/img]
    
    					[img]img/winken.jpg[/img]";
    				?>
    Wieso erkennt er den Pfad nicht und spielt das Video ab?
    Der Pfad ist auf jeden Fall richtig.

    Danke schonmal im vorraus.
    Achtung: Dies ist ein alter Thread im HTML und Webmaster Forum
    Diese Diskussion ist älter als 90 Tage. Die darin enthaltenen Informationen sind möglicherweise nicht mehr aktuell. Erstelle bitte zu deiner Frage ein neues Thema im Forum !!!!!


  2. #2
    Gast

    Standard

    wo gibst du denn hier einen Pfad zum Video an???

    dies hier kann er nicht sein:

    Hier mal ein Lösungsbeispiel

    Code:
    <?php
    if &#40;$_GET&#91;'video'&#93; ==1&#41; &#123;
    echo"<embed src='pfadzumvideo/boxing1.wmv' width='329' height='292' autostart='false' loop='false' hidden='false'>";
    &#125;
    ?>
    Der Link sieht dann entsprechend so aus:

    Das ganze kann man dann für die anderen videos auch machen nur entsprechend Link und $_GET['video'] ==1 ändern. zb. 2 usw.

    gibt aber mit sicherheit noch einfachere Lösungen mir fällt nur grad nix anderes ein!

  3. #3
    Samurai
    Themenstarter

    Registriert seit
    07.08.2005
    Beiträge
    231
    Danke
    0
    Bekam 0 mal "Danke" in 0 Postings

    Standard

    Ich hatte mir das so gedacht. Wenn man zB auf den obersten Link klickt wird die Variable Video
    mit dem Inhalt videos/boxing1.wmv per get übergeben.

    Oben wir das dann $play übergeben, sodass im embed src ja folgendes steht:
    <embed src=\"videos/boxing1\".

    Oder sehe ich das falsch?


  4. #4
    Gast

    Standard

    die überlegung war auch soweit richtig, aber du hattest keinen pfad zum Video angeben.

    Desweiteren musst du noch jeden video einen wert zuweisen, da die Get abfrage sonst den unterschiede zwischen video 1 und 2 zb. nicht erkennt.
    und somit das video nicht abspielt.

    deswegen habe ich bei meiner Get abfrage einen wert 1 hinzugefügt, welcher für das erste video steht.

    das gleiche musst du dann entsprechend für video zwei auch machen usw.

    also für video 2 sähe das ganze dann so auch

    Code:
    <?php 
    if &#40;$_GET&#91;'video'&#93; ==2&#41; &#123; 
    echo"<embed src='pfadzumvideo/boxing2.wmv' width='329' height='292' autostart='false' loop='false' hidden='false'>"; 
    &#125; 
    ?>
    Der Link:

    usw.

Ähnliche Themen

  1. Antworten: 0
    Letzter Beitrag: 21.12.2007, 18:20
  2. FF erkennt PHP-Stylesheet nicht
    Von Niels im Forum PHP Forum - Apache - CGI - Perl - JavaScript und Co.
    Antworten: 4
    Letzter Beitrag: 15.10.2007, 20:45
  3. wmv embed funzt beim explorer nicht
    Von milkore im Forum HTML & CSS Forum
    Antworten: 2
    Letzter Beitrag: 13.03.2007, 08:43
  4. Erkennt JPG nicht
    Von nuessler im Forum Computer - Internet Forum
    Antworten: 5
    Letzter Beitrag: 07.02.2005, 17:05
  5. EMBED Befehl geht nicht
    Von Woogy im Forum HTML & CSS Forum
    Antworten: 1
    Letzter Beitrag: 15.01.2005, 09:10

Stichworte

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •